aboutsummaryrefslogtreecommitdiff
path: root/x11/9menu/Makefile
diff options
context:
space:
mode:
authorAlexey Dokuchaev <danfe@FreeBSD.org>2009-12-15 01:51:07 +0000
committerAlexey Dokuchaev <danfe@FreeBSD.org>2009-12-15 01:51:07 +0000
commit058baaa337c55841c695c531ec7a0f5e0b1a02e0 (patch)
treea823d7dcfc7c50a0f899381129e6226efe39b6a9 /x11/9menu/Makefile
parent8b85deb57c15b9c7dd89d8979104151e9c16b8a7 (diff)
Notes
Diffstat (limited to 'x11/9menu/Makefile')
-rw-r--r--x11/9menu/Makefile10
1 files changed, 7 insertions, 3 deletions
diff --git a/x11/9menu/Makefile b/x11/9menu/Makefile
index d1bd6ee7fb6a..e516f4151002 100644
--- a/x11/9menu/Makefile
+++ b/x11/9menu/Makefile
@@ -16,17 +16,21 @@ EXTRACT_SUFX= .shar.gz
MAINTAINER= ports@FreeBSD.org
COMMENT= A simple menu patterned after Plan9
-EXTRACT_CMD= zcat
+EXTRACT_CMD= ${GZCAT}
EXTRACT_BEFORE_ARGS= # empty
-EXTRACT_AFTER_ARGS= | sh
+EXTRACT_AFTER_ARGS= | ${SH}
USE_XORG= x11
NO_WRKSUBDIR= yes
MAKEFILE= Makefile.noimake
+ALL_TARGET= 9menu
MAKE_ARGS= CC="${CC}" CFLAGS="${CFLAGS} -I${LOCALBASE}/include" \
LIBS="-L${LOCALBASE}/lib -lX11"
PLIST_FILES= bin/9menu
MAN1= 9menu.1
-MANCOMPRESSED= yes # vendor installation routine does this for us
+
+do-install:
+ ${INSTALL_PROGRAM} ${WRKSRC}/${PORTNAME} ${PREFIX}/bin
+ ${INSTALL_MAN} ${WRKSRC}/${MAN1} ${MAN1PREFIX}/man/man1
.include <bsd.port.mk>