aboutsummaryrefslogtreecommitdiff
path: root/x11/XFree86-4-clients/Makefile
diff options
context:
space:
mode:
authorEric Anholt <anholt@FreeBSD.org>2003-11-09 04:44:30 +0000
committerEric Anholt <anholt@FreeBSD.org>2003-11-09 04:44:30 +0000
commit4c54a5df65f30cf93465420e2d123e40a9b4ccdf (patch)
tree7fc79bedea27d5cecb4cc63a22913c45d5049423 /x11/XFree86-4-clients/Makefile
parent9b751cff107b06dbc96a0d55dc4d3e7827e9212c (diff)
downloadports-4c54a5df65f30cf93465420e2d123e40a9b4ccdf.tar.gz
ports-4c54a5df65f30cf93465420e2d123e40a9b4ccdf.zip
Notes
Diffstat (limited to 'x11/XFree86-4-clients/Makefile')
-rw-r--r--x11/XFree86-4-clients/Makefile16
1 files changed, 14 insertions, 2 deletions
diff --git a/x11/XFree86-4-clients/Makefile b/x11/XFree86-4-clients/Makefile
index 21ee681e0780..6b9ae3f549a5 100644
--- a/x11/XFree86-4-clients/Makefile
+++ b/x11/XFree86-4-clients/Makefile
@@ -7,7 +7,7 @@
PORTNAME= clients
PORTVERSION= 4.3.0
-PORTREVISION= 3
+PORTREVISION= 4
CATEGORIES= x11
MASTER_SITES= ${MASTER_SITE_XFREE}
MASTER_SITE_SUBDIR= 4.3.0
@@ -28,7 +28,7 @@ LIB_DEPENDS= freetype.9:${PORTSDIR}/print/freetype2 \
SCRIPTS_ENV= InstallXdmConfig=${InstallXdmConfig} \
InstallXinitConfig=${InstallXinitConfig} \
InstallAppDefFiles=${InstallAppDefFiles}
-
+
MAKE_ENV= PKGNAMEPREFIX=${PKGNAMEPREFIX} \
PORTNAME=${PORTNAME} \
PORTVERSION=${PORTVERSION}
@@ -52,6 +52,18 @@ InstallXdmConfig?= DEFAULT
InstallXinitConfig?= DEFAULT
InstallAppDefFiles?= DEFAULT
+.if !defined(WITH_SETUID_LUIT)
+pre-everything::
+ @${ECHO_MSG} "If you want to use xterm with locales in a secure manner, luit must be installed"
+ @${ECHO_MSG} "setuid. If you want to do this, hit Ctrl-C now and use \"make WITH_SETUID_LUIT=yes\""
+.endif
+
+.if defined(WITH_SETUID_LUIT)
+post-install:
+ ${CHOWN} root:wheel ${PREFIX}/bin/luit
+ ${CHMOD} 04711 ${PREFIX}/bin/luit
+.endif
+
.include "${.CURDIR}/../../x11/XFree86-4-libraries/Makefile.inc"
.include <bsd.port.pre.mk>
.include "${FILESDIR}/manpages"