aboutsummaryrefslogtreecommitdiff
path: root/x11/XFree86-4-clients
diff options
context:
space:
mode:
authorEric Anholt <anholt@FreeBSD.org>2002-07-18 20:30:22 +0000
committerEric Anholt <anholt@FreeBSD.org>2002-07-18 20:30:22 +0000
commita5596482c6ab677399ec6caa872847fb08a36bcd (patch)
treeb964abf535bc03854ad6684d05872c74c936bf8f /x11/XFree86-4-clients
parentb4b23fe6b8b83e2f81e86d26fc88d98f022f98da (diff)
downloadports-a5596482c6ab677399ec6caa872847fb08a36bcd.tar.gz
ports-a5596482c6ab677399ec6caa872847fb08a36bcd.zip
Notes
Diffstat (limited to 'x11/XFree86-4-clients')
-rw-r--r--x11/XFree86-4-clients/Makefile4
-rw-r--r--x11/XFree86-4-clients/scripts/configure41
2 files changed, 8 insertions, 37 deletions
diff --git a/x11/XFree86-4-clients/Makefile b/x11/XFree86-4-clients/Makefile
index 07f8c7d1a11a..4329a85616ac 100644
--- a/x11/XFree86-4-clients/Makefile
+++ b/x11/XFree86-4-clients/Makefile
@@ -30,7 +30,6 @@ PATCHDIR= ${.CURDIR}/../XFree86-4-libraries/files
SCRIPTS_ENV= InstallXdmConfig=${InstallXdmConfig} \
InstallXinitConfig=${InstallXinitConfig} \
InstallAppDefFiles=${InstallAppDefFiles} \
- HasXdmAuth=${HasXdmAuth} \
HasSecureRPC=${HasSecureRPC} \
HasPam=${HasPam}
MAKE_ENV= PKGNAMEPREFIX=${PKGNAMEPREFIX} \
@@ -43,7 +42,6 @@ INSTALL_TARGET= FreeBSDPortsInstall FreeBSDPortsInstall.man
# XFree86 User Config:
# Name Default Meaning
# ----------------------------------------------------------------------------
-# HasXdmAuth YES support XDM-AUTHORIZATION-1.
# HasSecureRPC YES build with SecureRPC (require FreeBSD-3 or later)
# HasPam YES support PAM (require FreeBSD-3.1 or later)
# InstallXdmConfig YES install config files for xdm.
@@ -55,7 +53,6 @@ INSTALL_TARGET= FreeBSDPortsInstall FreeBSDPortsInstall.man
InstallXdmConfig?= DEFAULT
InstallXinitConfig?= DEFAULT
InstallAppDefFiles?= DEFAULT
-HasXdmAuth?= YES
HasSecureRPC?= DEFAULT
HasPam?= DEFAULT
@@ -64,6 +61,7 @@ post-extract:
${EXTRACT_CMD} ${EXTRACT_BEFORE_ARGS} \
${DISTDIR}/${DIST_SUBDIR}/X${PORTVERSION:S/.//g}src-2.tgz \
| ${TAR} -xf - xc/fonts/util )
+ ${CP} ${DISTDIR}/${DIST_SUBDIR}/Wraphelp.c ${WRKSRC}/lib/Xdmcp/
post-patch:
cd ${WRKSRC}/nls; \
diff --git a/x11/XFree86-4-clients/scripts/configure b/x11/XFree86-4-clients/scripts/configure
index b1db6e5c4e7c..c562846bc8bb 100644
--- a/x11/XFree86-4-clients/scripts/configure
+++ b/x11/XFree86-4-clients/scripts/configure
@@ -1,14 +1,14 @@
#!/bin/sh
-# This scripts work as following:
-# (1) cp current xf86site.def (it may be created by imake-4 ports)
+# This script does the following:
+# (1) cp current xf86site.def (it is created by the imake-4 port)
# to ${WRKDIR}/xc/config/cf.
-# this means this ports use imake-4's config defaultly.
+# this means this port uses imake-4's config for defaults.
# (2) Generate temporal config for compiling.
# Some configs, such as `ForceNormalLib', `FreeBSDBuildXprog', are
-# used for compiling this ports localy. so these configs will be generated
-# this scripts. these configs will be stored to `host.def' file.
-# but this host.def will never install. use local only.
+# used locally for compiling this port, so these configs will be generated
+# by this script. These configs will be stored to the `host.def' file,
+# but this host.def will never be installed.
ORIGDEF=$PREFIX/lib/X11/config/xf86site.def
DESTDEF=$WRKDIR/xc/config/cf/xf86site.def
@@ -71,36 +71,9 @@ configure () {
echo "#define FreeBSDBuildXlib NO" >> $LOCALDEF
echo "#define FreeBSDBuildXbin YES" >> $LOCALDEF
- # Check Wraphelp.c
- if [ $HasXdmAuth = DEFAULT ]; then
- HasXdmAuth=$(awk '/^#define.*HasXdmAuth/ {print $3}' $ORIGDEF|tail -1)
- fi
-
- cpwh=NO
- if [ $HasXdmAuth = YES ]; then
- WH=$WRKDIR/xc/lib/Xdmcp/Wraphelp.c
- if [ -f $WH ] ; then
- cpwh=SOURCE
- elif [ -f $DISTDIR/xc/Wraphelp.c ] ; then
- cpwh=$DISTDIR/xc/Wraphelp.c
- else
- echo "==> You must fetch USA-legal Wraphelp.c manually"
- echo "==> and put it to ${DISTDIR}/xc/."
- exit 1
- fi
- if [ X$cpwh != XNO -a X$cpwh != XSOURCE ]; then
- tr -d '\r' < $cpwh > $WH
- fi
- fi
-
# Copy ORIGDEF to DESTDEF
rm -f $DESTDEF
- grep -v '#define.*HasXdmAuth' $ORIGDEF >> $DESTDEF
- if [ $cpwh = NO ] ; then
- echo "#define HasXdmAuth NO" >> $DESTDEF
- else
- echo "#define HasXdmAuth YES" >> $DESTDEF
- fi
+ cp -f $ORIGDEF $DESTDEF
# copy generated config to host.def
cp -f $LOCALDEF $HOSTDEF