aboutsummaryrefslogtreecommitdiff
path: root/x11/XFree86-4-clients
diff options
context:
space:
mode:
authorAlexander Kabaev <kan@FreeBSD.org>2004-01-03 21:35:04 +0000
committerAlexander Kabaev <kan@FreeBSD.org>2004-01-03 21:35:04 +0000
commitb3c869bb5c356632f83e3f8c909489fd6e467bbd (patch)
tree33178edaf9ecba8d6e8b5c8b2419609ae7a2b252 /x11/XFree86-4-clients
parentd4f420056d1f6dd8baf53d87e85da2e015a13e91 (diff)
downloadports-b3c869bb5c356632f83e3f8c909489fd6e467bbd.tar.gz
ports-b3c869bb5c356632f83e3f8c909489fd6e467bbd.zip
Notes
Diffstat (limited to 'x11/XFree86-4-clients')
-rw-r--r--x11/XFree86-4-clients/Makefile3
-rw-r--r--x11/XFree86-4-clients/files/patch-Imake.rules16
-rw-r--r--x11/XFree86-4-clients/files/patch-Xres.cpp50
3 files changed, 68 insertions, 1 deletions
diff --git a/x11/XFree86-4-clients/Makefile b/x11/XFree86-4-clients/Makefile
index c651d5f8449c..4335348373cd 100644
--- a/x11/XFree86-4-clients/Makefile
+++ b/x11/XFree86-4-clients/Makefile
@@ -36,7 +36,8 @@ XBUILD_DIRS= lib/xtrans lib/lbxutil programs fonts/util
XINSTALL_DIRS= programs fonts/util
XINSTALL_MAN_DIRS= programs
-.for pf in patch-bdftruncate.pl patch-ucs2any.pl
+.for pf in patch-bdftruncate.pl patch-ucs2any.pl \
+ patch-Xres.cpp patch-Imake.rules
EXTRA_PATCHES+= ${FILESDIR}/${pf}
.endfor
diff --git a/x11/XFree86-4-clients/files/patch-Imake.rules b/x11/XFree86-4-clients/files/patch-Imake.rules
new file mode 100644
index 000000000000..025c07f750bd
--- /dev/null
+++ b/x11/XFree86-4-clients/files/patch-Imake.rules
@@ -0,0 +1,16 @@
+--- config/cf/Imake.rules.orig Sat Jan 3 16:16:06 2004
++++ config/cf/Imake.rules Sat Jan 3 16:18:47 2004
+@@ -3148,7 +3148,12 @@
+ * Also delete line numbers from the cpp output (-P is not portable, I guess).
+ */
+ #ifndef CppSedMagic
+-#define CppSedMagic sed -e '/^# *[0-9][0-9]* *.*$$/d' -e '/^XCOMM$$/s//#/' -e '/^XCOMM[^a-zA-Z0-9_]/s/^XCOMM/#/'
++#define CppSedMagic sed -e '/^# *[0-9][0-9]* *.*$$/d' \
++ -e '/^#line *[0-9][0-9]* *.*$$/d' \
++ -e '/^[ ]*XCOMM$$/s/XCOMM/#/' \
++ -e '/^[ ]*XCOMM[^a-zA-Z0-9_]/s/XCOMM/#/' \
++ -e '/^[ ]*XHASH/s/XHASH/#/' \
++ -e '/\@\@$$/s/\@\@$$/\\/'
+ #endif /* CppSedMagic */
+
+ #ifndef CppFileTarget
diff --git a/x11/XFree86-4-clients/files/patch-Xres.cpp b/x11/XFree86-4-clients/files/patch-Xres.cpp
new file mode 100644
index 000000000000..80d3b73b56ed
--- /dev/null
+++ b/x11/XFree86-4-clients/files/patch-Xres.cpp
@@ -0,0 +1,50 @@
+--- programs/xdm/config/Xres.cpp.orig Sat Jan 3 15:50:37 2004
++++ programs/xdm/config/Xres.cpp Sat Jan 3 15:53:22 2004
+@@ -28,7 +28,7 @@
+ #endif /* XPM */
+ xlogin*fail: Login incorrect
+ #ifdef XPM
+-/**/#if WIDTH > 800
++XHASHif WIDTH > 800
+ xlogin*greetFont: -adobe-helvetica-bold-o-normal--24-240-75-75-p-138-iso8859-1
+ xlogin*font: -adobe-helvetica-medium-r-normal--18-180-75-75-p-98-iso8859-1
+ xlogin*promptFont: -adobe-helvetica-bold-r-normal--18-180-75-75-p-103-iso8859-1
+@@ -38,9 +38,9 @@
+ xlogin*font: -adobe-helvetica-medium-r-normal--12-120-75-75-p-67-iso8859-1
+ xlogin*promptFont: -adobe-helvetica-bold-r-normal--12-120-75-75-p-70-iso8859-1
+ xlogin*failFont: -adobe-helvetica-bold-o-normal--14-140-75-75-p-82-iso8859-1
+-/**/#endif
++XHASHendif
+ #endif /* XPM */
+-/**/#ifdef COLOR
++XHASHifdef COLOR
+ #ifndef XPM
+ xlogin*greetColor: CadetBlue
+ #else
+@@ -56,7 +56,7 @@
+ xlogin*failColor: red
+ *Foreground: black
+ *Background: #fffff0
+-/**/#else
++XHASHelse
+ #ifdef XPM
+ xlogin*borderWidth: 3
+ xlogin*frameWidth: 0
+@@ -68,13 +68,13 @@
+ xlogin*Foreground: black
+ xlogin*Background: white
+ #endif /* XPM */
+-/**/#endif
++XHASHendif
+ #ifdef XPM
+-/**/#if PLANES >= 8
++XHASHif PLANES >= 8
+ xlogin*logoFileName: BITMAPDIR/**//XDM_PIXMAP
+-/**/#else
++XHASHelse
+ xlogin*logoFileName: BITMAPDIR/**//XDM_BWPIXMAP
+-/**/#endif
++XHASHendif
+ xlogin*useShape: true
+ xlogin*logoPadding: 10
+ #endif /* XPM */