aboutsummaryrefslogtreecommitdiff
path: root/x11/XFree86-4
diff options
context:
space:
mode:
authorJean-Marc Zucconi <jmz@FreeBSD.org>2000-09-30 22:13:04 +0000
committerJean-Marc Zucconi <jmz@FreeBSD.org>2000-09-30 22:13:04 +0000
commitadfa9e2a0a8e0cee479ff15a86c6abfe563a4481 (patch)
tree13823ca5212ed9472bbb69259f3317112c67344f /x11/XFree86-4
parent7915997aa981332e922e52e4e8af5be1023e186a (diff)
downloadports-adfa9e2a0a8e0cee479ff15a86c6abfe563a4481.tar.gz
ports-adfa9e2a0a8e0cee479ff15a86c6abfe563a4481.zip
Notes
Diffstat (limited to 'x11/XFree86-4')
-rw-r--r--x11/XFree86-4/Makefile2
-rw-r--r--x11/XFree86-4/files/patch-k73
2 files changed, 42 insertions, 33 deletions
diff --git a/x11/XFree86-4/Makefile b/x11/XFree86-4/Makefile
index d570c297caad..abc41d2c9a9a 100644
--- a/x11/XFree86-4/Makefile
+++ b/x11/XFree86-4/Makefile
@@ -7,7 +7,7 @@
PORTNAME= XFree86
PORTVERSION= 4.0.1
-PORTREVISION= 1
+PORTREVISION= 2
CATEGORIES= x11
MASTER_SITES= ${MASTER_SITE_XFREE}
MASTER_SITE_SUBDIR= ${PORTVERSION}
diff --git a/x11/XFree86-4/files/patch-k b/x11/XFree86-4/files/patch-k
index e5308d958553..6d0d89d6ae47 100644
--- a/x11/XFree86-4/files/patch-k
+++ b/x11/XFree86-4/files/patch-k
@@ -1,32 +1,41 @@
---- programs/Xserver/hw/xfree86/input/mouse/mouse.c.orig Sun Jul 23 17:50:10 2000
-+++ programs/Xserver/hw/xfree86/input/mouse/mouse.c Sun Jul 23 17:54:22 2000
-@@ -692,10 +692,15 @@
- pMse->protocolID = protocolID;
- }
- }
-+#ifndef __FreeBSD__
- memcpy(pMse->protoPara, proto[pMse->protocolID], sizeof(pMse->protoPara));
-+#endif
- if (automatic) {
-
- if (name) {
-+#ifdef __FreeBSD__
-+ memcpy(pMse->protoPara, proto[pMse->protocolID], sizeof(pMse->protoPara));
-+#endif
- /* Possible protoPara overrides from SetupAuto. */
- for (i = 0; i < sizeof(pMse->protoPara); i++)
- if (protoPara[i] != -1)
---- programs/Xserver/hw/xfree86/os-support/bsd/bsd_mouse.c.orig Sat Feb 12 22:45:41 2000
-+++ programs/Xserver/hw/xfree86/os-support/bsd/bsd_mouse.c Sun Jul 23 17:50:10 2000
-@@ -165,7 +165,11 @@
- mode.rate = rate > 0 ? rate : -1;
- mode.resolution = res > 0 ? res : -1;
- mode.accelfactor = -1;
-+#ifdef __FreeBSD__
-+ mode.level = 1;
-+#else
- mode.level = -1;
-+#endif
- ioctl(pInfo->fd, MOUSE_SETMODE, &mode);
- }
- #endif
+*** xc/programs/Xserver/hw/xfree86/input/mouse/mouse.c.orig Sat Jul 1 01:39:02 2000
+--- xc/programs/Xserver/hw/xfree86/input/mouse/mouse.c Fri Sep 22 11:30:18 2000
+***************
+*** 584,591 ****
+ { 0xc0, 0x00, 0x00, 0x00, 6, 0x00, 0xff, MPF_NONE }, /* NetScroll */
+ /* Bus Mouse */
+ { 0xf8, 0x80, 0x00, 0x00, 5, 0x00, 0xff, MPF_NONE }, /* BusMouse */
+! /* Auto */
+! { 0xf8, 0x80, 0x00, 0x00, 5, 0x00, 0xff, MPF_NONE }, /* dummy entry */
+ };
+
+ /*
+--- 584,591 ----
+ { 0xc0, 0x00, 0x00, 0x00, 6, 0x00, 0xff, MPF_NONE }, /* NetScroll */
+ /* Bus Mouse */
+ { 0xf8, 0x80, 0x00, 0x00, 5, 0x00, 0xff, MPF_NONE }, /* BusMouse */
+! { 0xf8, 0x80, 0x00, 0x00, 5, 0x00, 0xff, MPF_NONE }, /* Auto */
+! { 0xf8, 0x80, 0x00, 0x00, 8, 0x00, 0xff, MPF_NONE }, /* SysMouse */
+ };
+
+ /*
+*** xc/programs/Xserver/hw/xfree86/os-support/bsd/bsd_mouse.c.orig Sat Feb 12 21:45:41 2000
+--- xc/programs/Xserver/hw/xfree86/os-support/bsd/bsd_mouse.c Fri Sep 22 11:30:18 2000
+***************
+*** 165,171 ****
+--- 165,179 ----
+ mode.rate = rate > 0 ? rate : -1;
+ mode.resolution = res > 0 ? res : -1;
+ mode.accelfactor = -1;
++ #if defined(__FreeBSD__)
++ /*
++ * As the FreeBSD sysmouse driver defaults to protocol level 0 everytime
++ * it is opened we enforce protocol level 1 again at this point.
++ */
++ mode.level = 1;
++ #else
+ mode.level = -1;
++ #endif
+ ioctl(pInfo->fd, MOUSE_SETMODE, &mode);
+ }
+ #endif