aboutsummaryrefslogtreecommitdiff
path: root/x11/alltray/Makefile
diff options
context:
space:
mode:
authorJose Alonso Cardenas Marquez <acm@FreeBSD.org>2006-07-28 20:25:07 +0000
committerJose Alonso Cardenas Marquez <acm@FreeBSD.org>2006-07-28 20:25:07 +0000
commitc245f713043176bcbf0d60db178bee892e99c670 (patch)
tree44fae88da2c20bb6605abe850606a6ea3e84931a /x11/alltray/Makefile
parent59a513b8ee25940c295f40d571b5b3c59110b07e (diff)
downloadports-c245f713043176bcbf0d60db178bee892e99c670.tar.gz
ports-c245f713043176bcbf0d60db178bee892e99c670.zip
Notes
Diffstat (limited to 'x11/alltray/Makefile')
-rw-r--r--x11/alltray/Makefile19
1 files changed, 14 insertions, 5 deletions
diff --git a/x11/alltray/Makefile b/x11/alltray/Makefile
index befe9b0156dc..e4450141f2f4 100644
--- a/x11/alltray/Makefile
+++ b/x11/alltray/Makefile
@@ -6,16 +6,15 @@
#
PORTNAME= alltray
-PORTVERSION= 0.66
+PORTVERSION= 0.69
CATEGORIES= x11
MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
-MASTER_SITE_SUBDIR= alltray
+MASTER_SITE_SUBDIR= ${PORTNAME}
MAINTAINER= acm@FreeBSD.org
COMMENT= Dock any application with no native tray icon
-USE_X_PREFIX= yes
-USE_GNOME= gtk20 gconf2
+USE_GNOME= gtk20
GNU_CONFIGURE= yes
INSTALLS_SHLIB= yes
CONFIGURE_ENV= CPPFLAGS="-I${X11BASE}/include" LDFLAGS="-L${X11BASE}/lib"
@@ -23,6 +22,16 @@ USE_GCC= 3.4+
MAN1= alltray.1
+OPTIONS= KDE "Support only KDE desktop" off
+
+.include <bsd.port.pre.mk>
+
+.if defined(WITH_KDE)
+CONFIGURE_ARGS= --disable-gconf
+.else
+USE_GNOME+= gconf2
+.endif
+
post-patch:
@${REINPLACE_CMD} -e 's|-ldl||' ${WRKSRC}/lib/Makefile.in
@${REINPLACE_CMD} -e 's|-L/usr/X11R6/lib||' ${WRKSRC}/src/Makefile.in
@@ -32,4 +41,4 @@ post-patch:
@${REINPLACE_CMD} -e 's|liballtray\.so\.0\.0\.0|liballtray.so.0|; \
s|/usr/lib|${PREFIX}/lib|' ${WRKSRC}/src/child.c
-.include <bsd.port.mk>
+.include <bsd.port.post.mk>