aboutsummaryrefslogtreecommitdiff
path: root/x11/altyo
diff options
context:
space:
mode:
authorCarlos J. Puga Medina <cpm@FreeBSD.org>2017-09-15 09:38:58 +0000
committerCarlos J. Puga Medina <cpm@FreeBSD.org>2017-09-15 09:38:58 +0000
commitb0fe6d2543c5b7edf61c5f5da7c5b72abd12009e (patch)
treeab38ff38ec219e5fab601b9c14464fa820944033 /x11/altyo
parent1773c8adf43ef94c65a64bca35a527d6bb7793c9 (diff)
downloadports-b0fe6d2543c5b7edf61c5f5da7c5b72abd12009e.tar.gz
ports-b0fe6d2543c5b7edf61c5f5da7c5b72abd12009e.zip
Notes
Diffstat (limited to 'x11/altyo')
-rw-r--r--x11/altyo/Makefile2
-rw-r--r--x11/altyo/files/patch-altyo__settings.vala56
-rw-r--r--x11/altyo/files/patch-altyo__window.vala11
3 files changed, 68 insertions, 1 deletions
diff --git a/x11/altyo/Makefile b/x11/altyo/Makefile
index fff3cd715980..f8053b39b71d 100644
--- a/x11/altyo/Makefile
+++ b/x11/altyo/Makefile
@@ -4,8 +4,8 @@
PORTNAME= altyo
DISTVERSIONPREFIX= debian/
DISTVERSION= 0.4_rc19
-PORTREVISION= 1
DISTVERSIONSUFFIX= -${GH_ACCOUNT}1
+PORTREVISION= 1
CATEGORIES= x11
MAINTAINER= nivit@FreeBSD.org
diff --git a/x11/altyo/files/patch-altyo__settings.vala b/x11/altyo/files/patch-altyo__settings.vala
new file mode 100644
index 000000000000..7353d38df2c3
--- /dev/null
+++ b/x11/altyo/files/patch-altyo__settings.vala
@@ -0,0 +1,56 @@
+--- altyo_settings.vala.orig 2016-04-19 20:55:59 UTC
++++ altyo_settings.vala
+@@ -701,7 +701,11 @@ public class AYSettings : AYTab{
+ view.get_cursor(out path,out s_column);
+ if(store.get_iter(out iter,path))
+ if(!store.iter_has_child(iter)){
++#if VALA_0_36
++ store.remove(ref iter);
++#else
+ store.remove(iter);
++#endif
+ if(store.get_iter(out iter,path))
+ view.set_cursor(path,null,false);
+ else if(path.prev())
+@@ -735,7 +739,11 @@ public class AYSettings : AYTab{
+ view.get_cursor(out path,out s_column);
+ if(store.get_iter(out iter,path))
+ if(!store.iter_has_child(iter)){
++#if VALA_0_36
++ store.remove(ref iter);
++#else
+ store.remove(iter);
++#endif
+ if(store.get_iter(out iter,path))
+ view.set_cursor(path,null,false);
+ else if(path.prev())
+@@ -769,7 +777,11 @@ public class AYSettings : AYTab{
+ view.get_cursor(out path,out s_column);
+ if(store.get_iter(out iter,path))
+ if(!store.iter_has_child(iter)){
++#if VALA_0_36
++ store.remove(ref iter);
++#else
+ store.remove(iter);
++#endif
+ if(store.get_iter(out iter,path))
+ view.set_cursor(path,null,false);
+ else if(path.prev())
+@@ -956,7 +968,7 @@ public class AYSettings : AYTab{
+ string msg="";
+ uint line,pos;
+ if(!this.check_css(B.buffer.text,ref S,out line,out pos)){
+- msg=_("in line %d at position %d error:%s").printf(line,pos,S);
++ msg=_("in line %d at position %d error:%s").printf((int)line,(int)pos,S);
+ debug("on_check_css_button_activate %s",msg);
+ TextIter where;
+ B.buffer.get_iter_at_line_offset(out where,(int)line,(int)pos);
+@@ -1606,7 +1618,7 @@ public class AYSettings : AYTab{
+ string S="";
+ uint line,pos;
+ if(!this.check_css(s,ref S,out line,out pos)){
+- string msg=_("New style will not be saved!\nin line %d at position %d\nerror:%s").printf(line,pos,S);
++ string msg=_("New style will not be saved!\nin line %d at position %d\nerror:%s").printf((int)line,(int)pos,S);
+ debug("on config apply css error %s",msg);
+ this.ayobject.main_window.show_message_box(_("AltYo CSS style error"),msg);
+ }else{//looks good
diff --git a/x11/altyo/files/patch-altyo__window.vala b/x11/altyo/files/patch-altyo__window.vala
new file mode 100644
index 000000000000..f3bc23255784
--- /dev/null
+++ b/x11/altyo/files/patch-altyo__window.vala
@@ -0,0 +1,11 @@
+--- altyo_window.vala.orig 2016-04-19 20:55:59 UTC
++++ altyo_window.vala
+@@ -2889,7 +2889,7 @@ public class AYObject :Object{
+ for (item_it = this.children_removed.last(); item_it != null; item_it = item_it.prev) {
+ AYTab tab = item_it.data;
+ tab.stop_remove_timer();//disable timer while popup shown
+- string s = ( tab.tbutton.tab_title != null ? tab.tbutton.tab_title : _("index %d").printf(tab.tbutton.tab_index) );
++ string s = ( tab.tbutton.tab_title != null ? tab.tbutton.tab_title : _("index %d").printf((int)tab.tbutton.tab_index) );
+ menuitem = new Gtk.MenuItem.with_label ("%d: %s".printf(index,s));
+ menuitem.activate.connect(()=>{
+ debug("trying to restore tab %s",menuitem.label);