aboutsummaryrefslogtreecommitdiff
path: root/x11/apwal/Makefile
diff options
context:
space:
mode:
authorBaptiste Daroussin <bapt@FreeBSD.org>2014-01-06 08:25:43 +0000
committerBaptiste Daroussin <bapt@FreeBSD.org>2014-01-06 08:25:43 +0000
commit0d78e955ddf19e9d2a2b3c5ca5a7a6978ab8b267 (patch)
treed7d6756b6065753f53ad76f8bd2b6cb103de0552 /x11/apwal/Makefile
parent3bf65cd9f595745737c4faad8f858cc1e3050db9 (diff)
downloadports-0d78e955ddf19e9d2a2b3c5ca5a7a6978ab8b267.tar.gz
ports-0d78e955ddf19e9d2a2b3c5ca5a7a6978ab8b267.zip
Notes
Diffstat (limited to 'x11/apwal/Makefile')
-rw-r--r--x11/apwal/Makefile8
1 files changed, 3 insertions, 5 deletions
diff --git a/x11/apwal/Makefile b/x11/apwal/Makefile
index e5ab995440b0..1f0773a707ad 100644
--- a/x11/apwal/Makefile
+++ b/x11/apwal/Makefile
@@ -11,21 +11,19 @@ MAINTAINER= ports@FreeBSD.org
COMMENT= Simple and powerful application launcher
USE_GNOME= gtk20 libxml2
-USE_GMAKE= yes
-USES= pkgconfig
+USES= gmake pkgconfig
WRKSRC= ${WRKDIR}/${PORTNAME}/src
PLIST_FILES= bin/apwal bin/apwal-editor
-NO_STAGE= yes
post-patch:
@${CP} ${FILESDIR}/group_member.c ${WRKSRC}
@${REINPLACE_CMD} -e 's|/usr/share|${PREFIX}/share|g' \
${WRKSRC}/cereimg.c ${WRKSRC}/../example/apwalrc.xml
do-install:
- ${INSTALL_PROGRAM} ${WRKSRC}/apwal ${PREFIX}/bin
- ${LN} -sf ${PREFIX}/bin/apwal ${PREFIX}/bin/apwal-editor
+ ${INSTALL_PROGRAM} ${WRKSRC}/apwal ${STAGEDIR}${PREFIX}/bin
+ ${LN} -sf apwal ${STAGEDIR}${PREFIX}/bin/apwal-editor
.include <bsd.port.mk>