aboutsummaryrefslogtreecommitdiff
path: root/x11/apwal/Makefile
diff options
context:
space:
mode:
authorPav Lucistnik <pav@FreeBSD.org>2003-12-06 13:07:52 +0000
committerPav Lucistnik <pav@FreeBSD.org>2003-12-06 13:07:52 +0000
commit8661561f12bea6a9b46f87d7563bc4c24b684380 (patch)
tree0dbb92f7afa5a1af4a36c4703a31ba12f4a3d983 /x11/apwal/Makefile
parent58f793741af5fad1ed31c134f799a06107fd3de2 (diff)
downloadports-8661561f12bea6a9b46f87d7563bc4c24b684380.tar.gz
ports-8661561f12bea6a9b46f87d7563bc4c24b684380.zip
Notes
Diffstat (limited to 'x11/apwal/Makefile')
-rw-r--r--x11/apwal/Makefile31
1 files changed, 31 insertions, 0 deletions
diff --git a/x11/apwal/Makefile b/x11/apwal/Makefile
new file mode 100644
index 000000000000..a6f63fce781a
--- /dev/null
+++ b/x11/apwal/Makefile
@@ -0,0 +1,31 @@
+# New ports collection makefile for: apwal
+# Date created: Nov 26, 2003
+# Whom: Volker Stolz <stolz@i2.informatik.rwth-aachen.de>
+#
+# $FreeBSD$
+#
+
+PORTNAME= apwal
+PORTVERSION= 0.4.2
+CATEGORIES= x11
+MASTER_SITES= http://apwal.free.fr/download/
+
+MAINTAINER= stolz@i2.informatik.rwth-aachen.de
+COMMENT= Simple and powerful application launcher
+
+USE_GNOME= gtk20 libxml2
+USE_X_PREFIX= yes
+USE_GMAKE= yes
+USE_REINPLACE= yes
+
+WRKSRC= ${WRKDIR}/${PORTNAME}/src
+
+post-patch:
+ @${CP} ${FILESDIR}/group_member.c ${WRKSRC}
+ @${REINPLACE_CMD} -e 's|/usr/share|${PREFIX}/share/gnome|g' ${WRKSRC}/cereimg.c ${WRKSRC}/../example/apwalrc.xml
+
+do-install:
+ ${INSTALL_PROGRAM} ${WRKSRC}/apwal ${PREFIX}/bin
+ ${LN} -sf ${PREFIX}/bin/apwal ${PREFIX}/bin/apwal-editor
+
+.include <bsd.port.mk>