aboutsummaryrefslogtreecommitdiff
path: root/x11/babl
diff options
context:
space:
mode:
authorJeremy Messenger <mezz@FreeBSD.org>2012-03-16 03:12:33 +0000
committerJeremy Messenger <mezz@FreeBSD.org>2012-03-16 03:12:33 +0000
commit78dc195ea927f88123d23a61bfac9eb98f398ae8 (patch)
tree3a131217a47f5bd8b0863a121df5adca83717f89 /x11/babl
parent6c70c5f94ba65295accd6a05ac9b3ce84151924c (diff)
downloadports-78dc195ea927f88123d23a61bfac9eb98f398ae8.tar.gz
ports-78dc195ea927f88123d23a61bfac9eb98f398ae8.zip
Notes
Diffstat (limited to 'x11/babl')
-rw-r--r--x11/babl/Makefile4
-rw-r--r--x11/babl/files/patch-sse-fixups.c28
2 files changed, 32 insertions, 0 deletions
diff --git a/x11/babl/Makefile b/x11/babl/Makefile
index f0646348216c..2953c14ed64b 100644
--- a/x11/babl/Makefile
+++ b/x11/babl/Makefile
@@ -38,4 +38,8 @@ CONFIGURE_ARGS+=--disable-mmx \
--disable-altivec
.endif
+post-patch:
+ @${REINPLACE_CMD} -e 's|x86_64|amd64|g' \
+ ${WRKSRC}/configure
+
.include <bsd.port.post.mk>
diff --git a/x11/babl/files/patch-sse-fixups.c b/x11/babl/files/patch-sse-fixups.c
new file mode 100644
index 000000000000..48dda3f0d584
--- /dev/null
+++ b/x11/babl/files/patch-sse-fixups.c
@@ -0,0 +1,28 @@
+--- extensions/sse-fixups.c~
++++ extensions/sse-fixups.c
+@@ -23,6 +23,8 @@
+
+ #if defined(__GNUC__) && (__GNUC__ >= 4) && defined(USE_SSE) && defined(USE_MMX)
+
++#include <xmmintrin.h>
++
+ #include <stdint.h>
+ #include <stdlib.h>
+
+@@ -40,11 +42,11 @@ typedef int g2int __attribute__ ((ve
+ #define g4float_zero g4float_all(0.0)
+ #define g4float_ff g4float_all(255.0)
+
+-#define g4float_max(a,b) __builtin_ia32_maxps(a, b)
+-#define g4float_min(a,b) __builtin_ia32_minps(a, b)
+-#define g4float_cvt2pi(a) __builtin_ia32_cvtps2pi(a)
+-#define g4float_movhl(a,b) __builtin_ia32_movhlps(a, b)
+-#define g4float_emms __builtin_ia32_emms
++#define g4float_max(a,b) _mm_max_ps(a, b)
++#define g4float_min(a,b) _mm_min_ps(a, b)
++#define g4float_cvt2pi(a) _mm_cvtps_pi32(a)
++#define g4float_movhl(a,b) _mm_movehl_ps(a, b)
++#define g4float_emms _mm_empty
+
+
+ static INLINE long