aboutsummaryrefslogtreecommitdiff
path: root/x11/bbrun/Makefile
diff options
context:
space:
mode:
authorPatrick Li <pat@FreeBSD.org>2001-12-02 02:28:11 +0000
committerPatrick Li <pat@FreeBSD.org>2001-12-02 02:28:11 +0000
commit96cdc05fc3f566bbaf6ed9150c39da835b93dfdf (patch)
tree3b01ba9b8d060d83ae49441a84f0a273081b03c1 /x11/bbrun/Makefile
parentd8000cd312294fc60257b5a9d92856f90c8d5b90 (diff)
downloadports-96cdc05fc3f566bbaf6ed9150c39da835b93dfdf.tar.gz
ports-96cdc05fc3f566bbaf6ed9150c39da835b93dfdf.zip
Notes
Diffstat (limited to 'x11/bbrun/Makefile')
-rw-r--r--x11/bbrun/Makefile31
1 files changed, 31 insertions, 0 deletions
diff --git a/x11/bbrun/Makefile b/x11/bbrun/Makefile
new file mode 100644
index 000000000000..7e8095b39979
--- /dev/null
+++ b/x11/bbrun/Makefile
@@ -0,0 +1,31 @@
+# New ports collection makefile for: bbrun
+# Date created: 3 August 2001
+# Whom: Adam Weinberger
+#
+# $FreeBSD$
+#
+
+PORTNAME= bbrun
+PORTVERSION= 1.1
+CATEGORIES= x11-wm
+MASTER_SITES= http://bbtools.windsofstorm.net/sources/contrib/
+
+MAINTAINER= monkey@crackula.com
+
+RUN_DEPENDS= blackbox:${PORTSDIR}/x11-wm/blackbox
+
+USE_X_PREFIX= yes
+USE_GTK= yes
+USE_GMAKE= yes
+WRKSRC= ${WRKDIR}/${DISTNAME}/bbrun
+
+do-install:
+ @${INSTALL_PROGRAM} ${WRKSRC}/bbrun ${PREFIX}/bin
+
+post-install:
+.if !defined(NOPORTDOCS)
+ @${MKDIR} ${DOCSDIR}
+ @${INSTALL_DATA} ${WRKSRC}/../README ${DOCSDIR}
+.endif
+
+.include <bsd.port.mk>