aboutsummaryrefslogtreecommitdiff
path: root/x11/buttonbox
diff options
context:
space:
mode:
authorTrevor Johnson <trevor@FreeBSD.org>2000-12-17 09:52:13 +0000
committerTrevor Johnson <trevor@FreeBSD.org>2000-12-17 09:52:13 +0000
commitabc03967eea61f2a0dbe8df77427065cc94fc376 (patch)
tree80dbc9799e9847b466b5a71cd6d1dc0e86ffa019 /x11/buttonbox
parent642d9d5d0768d2dcaa8dcf06282537d4e1d427ca (diff)
downloadports-abc03967eea61f2a0dbe8df77427065cc94fc376.tar.gz
ports-abc03967eea61f2a0dbe8df77427065cc94fc376.zip
Notes
Diffstat (limited to 'x11/buttonbox')
-rw-r--r--x11/buttonbox/Makefile47
-rw-r--r--x11/buttonbox/distinfo1
-rw-r--r--x11/buttonbox/pkg-comment1
-rw-r--r--x11/buttonbox/pkg-descr11
4 files changed, 60 insertions, 0 deletions
diff --git a/x11/buttonbox/Makefile b/x11/buttonbox/Makefile
new file mode 100644
index 000000000000..c11004d8bddd
--- /dev/null
+++ b/x11/buttonbox/Makefile
@@ -0,0 +1,47 @@
+# New ports collection makefile for: buttonbox
+# Date created: 2000-12-17
+# Whom: trevor
+#
+# $FreeBSD$
+#
+
+PORTNAME= buttonbox
+PORTVERSION= 0.03
+CATEGORIES= x11
+MASTER_SITES= http://www.sto-kerrig.org/free-software/projects/button-box/
+DISTNAME= ${PORTNAME:S/b/B/g}-${PORTVERSION}
+
+MAINTAINER= trevor@FreeBSD.org
+
+DOCDIR= share/doc/${PORTNAME}
+DOCS= COPYING ChangeLog DEDICATION README TODO
+PLIST= ${WRKDIR}/pkg-plist
+
+USE_X_PREFIX= yes
+
+do-build:
+ cd ${WRKSRC} && ${CC} ${CFLAGS} -o buttonbox -L${X11BASE}/lib \
+ -I${X11BASE}/include -lX11 -lXext button.c configuration.c \
+ colour.c dispatcher.c main.c
+
+pre-install:
+ ${ECHO} bin/buttonbox > ${PLIST}
+ ${ECHO} lib/X11/app-defaults/ButtonBox.ad >> ${PLIST}
+.if !defined(NOPORTDOCS)
+ for i in ${DOCS}; \
+ do ${ECHO} ${DOCDIR}/$${i} >> ${PLIST}; \
+ done
+ ${ECHO} @dirrm ${DOCDIR} >> ${PLIST}
+.endif
+
+do-install:
+ ${INSTALL_DATA} ${WRKSRC}/ButtonBox.ad ${X11BASE}/lib/X11/app-defaults/
+ ${INSTALL_PROGRAM} ${WRKSRC}/buttonbox ${X11BASE}/bin/
+.if !defined(NOPORTDOCS)
+ ${MKDIR} ${PREFIX}/${DOCDIR}
+ for i in ${DOCS}; \
+ do ${INSTALL_DATA} ${WRKSRC}/$${i} ${PREFIX}/${DOCDIR}; \
+ done
+.endif
+
+.include <bsd.port.mk>
diff --git a/x11/buttonbox/distinfo b/x11/buttonbox/distinfo
new file mode 100644
index 000000000000..b29d59f0d526
--- /dev/null
+++ b/x11/buttonbox/distinfo
@@ -0,0 +1 @@
+MD5 (ButtonBox-0.03.tar.gz) = 515db920de6ddca4534250955d837fd3
diff --git a/x11/buttonbox/pkg-comment b/x11/buttonbox/pkg-comment
new file mode 100644
index 000000000000..82c1f48d7126
--- /dev/null
+++ b/x11/buttonbox/pkg-comment
@@ -0,0 +1 @@
+Xlib-based application launcher
diff --git a/x11/buttonbox/pkg-descr b/x11/buttonbox/pkg-descr
new file mode 100644
index 000000000000..7a86ca5896c9
--- /dev/null
+++ b/x11/buttonbox/pkg-descr
@@ -0,0 +1,11 @@
+from the Web page:
+
+ ButtonBox is a simple application for the X Window System
+ that sits in the corner of the screen, waiting for you to
+ click on one of the buttons it provides. When you do, it
+ launches the program.
+
+WWW: http://www.sto-kerrig.org/free-software/projects/button-box/
+
+Trevor Johnson
+trevor@FreeBSD.org