aboutsummaryrefslogtreecommitdiff
path: root/x11/cinnamon-menus
diff options
context:
space:
mode:
authorKoop Mast <kwm@FreeBSD.org>2014-11-19 11:49:04 +0000
committerKoop Mast <kwm@FreeBSD.org>2014-11-19 11:49:04 +0000
commitaf3811313c14afb06fe2d1f6158e3e431bbfc2b6 (patch)
tree1ad98a4e8faecd0e2fa9ac2c18e65da4cf89c236 /x11/cinnamon-menus
parentc7d4d6bd7ef6ff4955eab2863a5c6e2feb14b839 (diff)
Notes
Diffstat (limited to 'x11/cinnamon-menus')
-rw-r--r--x11/cinnamon-menus/Makefile34
-rw-r--r--x11/cinnamon-menus/distinfo2
-rw-r--r--x11/cinnamon-menus/pkg-descr4
-rw-r--r--x11/cinnamon-menus/pkg-plist8
4 files changed, 48 insertions, 0 deletions
diff --git a/x11/cinnamon-menus/Makefile b/x11/cinnamon-menus/Makefile
new file mode 100644
index 000000000000..68c850ed2bb1
--- /dev/null
+++ b/x11/cinnamon-menus/Makefile
@@ -0,0 +1,34 @@
+# Created by: Gustau Perez i Querol <gustau.perez@gmail.com>
+# $FreeBSD$
+# $MCom: ports/trunk/x11/cinnamon-menus/Makefile 20031 2014-11-02 21:47:55Z kwm $
+
+PORTNAME= cinnamon-menus
+PORTVERSION= 2.2.0
+CATEGORIES= x11 gnome
+MASTER_SITES= http://github.com/linuxmint/${PORTNAME}/archive/${PORTVERSION}.tar.gz?dummy=/
+DIST_SUBDIR= gnome3
+
+MAINTAINER= gnome@FreeBSD.org
+COMMENT= Additional UI API for cinnamon
+
+BUILD_DEPENDS= gnome-autogen.sh:${PORTSDIR}/devel/gnome-common \
+ xkeyboard-config>=0:${PORTSDIR}/x11/xkeyboard-config \
+ libxkbfile>=0:${PORTSDIR}/x11/libxkbfile
+RUN_DEPENDS= xkeyboard-config>=0:${PORTSDIR}/x11/xkeyboard-config \
+ libxkbfile>=0:${PORTSDIR}/x11/libxkbfile
+
+USES= autoreconf:build gettext gmake libtool pathfix pkgconfig \
+ python:2 tar:xz
+USE_GNOME= gnomemenus3 gnomeprefix gtk30 intlhack \
+ introspection:build
+USE_LDCONFIG= yes
+GNU_CONFIGURE= yes
+PATHFIX_MAKEFILEIN= Makefile.am
+CPPFLAGS+= -I${LOCALBASE}/include
+LDFLAGS+= -L${LOCALBASE}/lib
+INSTALL_TARGET= install-strip
+
+pre-configure:
+ cd ${WRKSRC} && ${SETENV} NOCONFIGURE=yes ${SH} ./autogen.sh
+
+.include <bsd.port.mk>
diff --git a/x11/cinnamon-menus/distinfo b/x11/cinnamon-menus/distinfo
new file mode 100644
index 000000000000..fb9742cb01f3
--- /dev/null
+++ b/x11/cinnamon-menus/distinfo
@@ -0,0 +1,2 @@
+SHA256 (gnome3/cinnamon-menus-2.2.0.tar.xz) = e354273c29bc610925d81263c90c9e67137a39fb8d241e125d530842a60ec286
+SIZE (gnome3/cinnamon-menus-2.2.0.tar.xz) = 542548
diff --git a/x11/cinnamon-menus/pkg-descr b/x11/cinnamon-menus/pkg-descr
new file mode 100644
index 000000000000..195e8f44d373
--- /dev/null
+++ b/x11/cinnamon-menus/pkg-descr
@@ -0,0 +1,4 @@
+This package is a replacemenent of gnome-menus for
+the cinnamon project.
+
+WWW: https://github.com/linuxmint/cinnamon-menus
diff --git a/x11/cinnamon-menus/pkg-plist b/x11/cinnamon-menus/pkg-plist
new file mode 100644
index 000000000000..fead2ebd7056
--- /dev/null
+++ b/x11/cinnamon-menus/pkg-plist
@@ -0,0 +1,8 @@
+include/cinnamon-menus-3.0/gmenu-tree.h
+lib/libcinnamon-menu-3.a
+lib/libcinnamon-menu-3.so
+lib/libcinnamon-menu-3.so.0
+lib/libcinnamon-menu-3.so.0.0.1
+lib/girepository-1.0/CMenu-3.0.typelib
+libdata/pkgconfig/libcinnamon-menu-3.0.pc
+share/gir-1.0/CMenu-3.0.gir