aboutsummaryrefslogtreecommitdiff
path: root/x11/cinnamon/Makefile
diff options
context:
space:
mode:
authorKoop Mast <kwm@FreeBSD.org>2015-08-05 19:13:24 +0000
committerKoop Mast <kwm@FreeBSD.org>2015-08-05 19:13:24 +0000
commitd129587b5d568b0ff5300386f1e1b706c349f38e (patch)
treee398c7b6ea5203fd3953999e6dd9d6c83c9ec931 /x11/cinnamon/Makefile
parentc13de12f75988e599e389d9c77ed92db8d927185 (diff)
downloadports-d129587b5d568b0ff5300386f1e1b706c349f38e.tar.gz
ports-d129587b5d568b0ff5300386f1e1b706c349f38e.zip
Notes
Diffstat (limited to 'x11/cinnamon/Makefile')
-rw-r--r--x11/cinnamon/Makefile7
1 files changed, 3 insertions, 4 deletions
diff --git a/x11/cinnamon/Makefile b/x11/cinnamon/Makefile
index 9e00517c0202..b1d692c4025e 100644
--- a/x11/cinnamon/Makefile
+++ b/x11/cinnamon/Makefile
@@ -37,7 +37,7 @@ RUN_DEPENDS= py*-dbus>=0:${PORTSDIR}/devel/py-dbus \
WRKSRC= ${WRKDIR}/Cinnamon-${PORTVERSION}
-USES= autoreconf:build compiler:c11 gettext gmake libtool \
+USES= autoreconf compiler:c11 gettext gmake libtool \
pathfix pkgconfig python shebangfix
USE_GNOME= evolutiondataserver3 gconf2 gnomedesktop3 \
gnomeprefix gtk30 intlhack introspection:build
@@ -62,6 +62,8 @@ OPTIONS_DEFINE= NLS
NLS_RUN_DEPENDS= cinnamon-translations>=0:${PORTSDIR}/misc/cinnamon-translations
post-patch:
+# we need this for intltoolize otherwise it can't copy the m4 file ...
+ @${MKDIR} ${WRKSRC}/m4
@${MKDIR} ${WRKSRC}/files${PREFIX}
.for d in bin lib share
@${MV} ${WRKSRC}/files/usr/${d} ${WRKSRC}/files${PREFIX}
@@ -140,9 +142,6 @@ post-patch:
@${FIND} ${WRKSRC} -name '*.orig' -delete
@${FIND} ${WRKSRC} -name '*.bak' -delete
-pre-configure:
- cd ${WRKSRC} && NOCONFIGURE=yes ${SH} ./autogen.sh
-
post-install:
@${PYTHON_CMD} ${WRKSRC}/files/generate_desktop_files