aboutsummaryrefslogtreecommitdiff
path: root/x11/compositeext/Makefile
diff options
context:
space:
mode:
authorEric Anholt <anholt@FreeBSD.org>2003-12-27 01:32:08 +0000
committerEric Anholt <anholt@FreeBSD.org>2003-12-27 01:32:08 +0000
commit81521106a38c1c1e5f75a75ea8a61f379e25bec8 (patch)
tree4854d4a0d29f84506863e487c9aac057b466441d /x11/compositeext/Makefile
parent7ee04b912d2979b037aa095a618437d78babfe3d (diff)
downloadports-81521106a38c1c1e5f75a75ea8a61f379e25bec8.tar.gz
ports-81521106a38c1c1e5f75a75ea8a61f379e25bec8.zip
Notes
Diffstat (limited to 'x11/compositeext/Makefile')
-rw-r--r--x11/compositeext/Makefile29
1 files changed, 29 insertions, 0 deletions
diff --git a/x11/compositeext/Makefile b/x11/compositeext/Makefile
new file mode 100644
index 000000000000..677e27f60ba0
--- /dev/null
+++ b/x11/compositeext/Makefile
@@ -0,0 +1,29 @@
+# New ports collection makefile for: compositeext
+# Date Created: 13 Nov, 2003
+# Whom: Eric Anholt <anholt@FreeBSD.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= compositeext
+PORTVERSION= 2.0.p1
+CATEGORIES= x11
+MASTER_SITES= http://pdx.freedesktop.org/~anholt/dist/
+
+MAINTAINER= x11@FreeBSD.org
+COMMENT= X Composite extension headers and specification
+
+LIB_PC_DEPENDS= ${X11BASE}/libdata/pkgconfig/fixesext.pc:${PORTSDIR}/x11/fixesext
+BUILD_DEPENDS= pkg-config:${PORTSDIR}/devel/pkgconfig \
+ ${LIB_PC_DEPENDS}
+RUN_DEPENDS= ${LIB_PC_DEPENDS}
+
+USE_BZIP2= yes
+PREFIX?= ${X11BASE}
+GNU_CONFIGURE= yes
+CONFIGURE_TARGET= --build=${MACHINE_ARCH}-portbld-freebsd${OSREL}
+USE_GMAKE= yes
+NO_BUILD= yes
+WRKSRC= ${WRKDIR}/${PORTNAME}-2.0
+
+.include <bsd.port.mk>