aboutsummaryrefslogtreecommitdiff
path: root/x11/dgs/Makefile
diff options
context:
space:
mode:
authorYukihiro Nakai <nakai@FreeBSD.org>1999-11-09 08:50:56 +0000
committerYukihiro Nakai <nakai@FreeBSD.org>1999-11-09 08:50:56 +0000
commitc12d25996824948e40f9093e12044360cf12755b (patch)
treecc0a58ff327975075e84c5a1f384f5bd95e790d3 /x11/dgs/Makefile
parentfa5f532a80e815902685394445db2a0b8c4621cb (diff)
downloadports-c12d25996824948e40f9093e12044360cf12755b.tar.gz
ports-c12d25996824948e40f9093e12044360cf12755b.zip
Notes
Diffstat (limited to 'x11/dgs/Makefile')
-rw-r--r--x11/dgs/Makefile20
1 files changed, 13 insertions, 7 deletions
diff --git a/x11/dgs/Makefile b/x11/dgs/Makefile
index be58afd38c9e..e061d85e69f3 100644
--- a/x11/dgs/Makefile
+++ b/x11/dgs/Makefile
@@ -1,27 +1,33 @@
# New ports collection makefile for: dgs
-# Version required: 0.5.0
+# Version required: 0.5.8
# Date created: 22 April 1998
# Whom: Yukihiro Nakai <Nakai@technologist.com>
#
# $FreeBSD$
#
-DISTNAME= dgs-0.5.0
+DISTNAME= dgs-0.5.8
CATEGORIES= x11
MASTER_SITES= ${MASTER_SITE_GNU}
MASTER_SITE_SUBDIR= dgs
-MAINTAINER= nacai@iname.com
+MAINTAINER= nakai@FreeBSD.org
LIB_DEPENDS= jpeg.9:${PORTSDIR}/graphics/jpeg \
png.3:${PORTSDIR}/graphics/png \
- tiff.4:${PORTSDIR}/graphics/tiff
+ tiff.4:${PORTSDIR}/graphics/tiff \
+ glib12.3:${PORTSDIR}/devel/glib12
+BUILD_DEPENDS= gs:${PORTSDIR}/print/ghostscript55
-WRKSRC= ${WRKDIR}/${DISTNAME}/dgs
+GLIB_CONFIG= ${LOCALBASE}/bin/glib12-config
-GNU_CONFIGURE= yes
+USE_GMAKE= yes
USE_X_PREFIX= yes
+GNU_CONFIGURE= yes
+CONFIGURE_ENV= GLIB_CONFIG=${GLIB_CONFIG}
+MAKE_ENV= INSTALL=${INSTALL}
-MAN1= gs.1 pdf2ps.1 ps2ascii.1 ps2epsi.1 ps2pdf.1
+MAN1= gs.1
+MANM= dpsexec makepsres xepsf
.include <bsd.port.mk>