aboutsummaryrefslogtreecommitdiff
path: root/x11/e17-module-calendar
diff options
context:
space:
mode:
authorStanislav Sedov <stas@FreeBSD.org>2006-10-08 13:48:37 +0000
committerStanislav Sedov <stas@FreeBSD.org>2006-10-08 13:48:37 +0000
commitee774b0f4fa7f1842f6b4dfdfe60b22cbcf12442 (patch)
tree1bf12eadb5a7920766bf7a613174c0475b810d0d /x11/e17-module-calendar
parent32e98c797bd5b952894ff185e59df8a91844f4ab (diff)
downloadports-ee774b0f4fa7f1842f6b4dfdfe60b22cbcf12442.tar.gz
ports-ee774b0f4fa7f1842f6b4dfdfe60b22cbcf12442.zip
Notes
Diffstat (limited to 'x11/e17-module-calendar')
-rw-r--r--x11/e17-module-calendar/Makefile29
-rw-r--r--x11/e17-module-calendar/distinfo6
-rw-r--r--x11/e17-module-calendar/files/patch-src_e_mod_main.c20
3 files changed, 21 insertions, 34 deletions
diff --git a/x11/e17-module-calendar/Makefile b/x11/e17-module-calendar/Makefile
index a0c387313007..96735db318aa 100644
--- a/x11/e17-module-calendar/Makefile
+++ b/x11/e17-module-calendar/Makefile
@@ -6,27 +6,28 @@
#
PORTNAME= calendar
-PORTVERSION= 23062006
-PORTREVISION= 2
+PORTVERSION= 20060926
+PORTREVISION= 0
+PORTEPOCH= 1
CATEGORIES= x11
-MASTER_SITES= http://mbsd.msk.ru/dist/
+MASTER_SITES= http://sunner.elcomnet.ru/~stas/
PKGNAMEPREFIX= e17-module-
DISTNAME= ${PORTNAME}-${PORTVERSION}
-MAINTAINER= ssedov@mbsd.msk.ru
+MAINTAINER= stas@FreeBSD.org
COMMENT= Nice calendar module for e17
-BUILD_DEPENDS= enlightenment:${PORTSDIR}/x11-wm/enlightenment-devel
-RUN_DEPENDS= ${BUILD_DEPENDS}
+BUILD_DEPENDS= enlightenment-config:${PORTSDIR}/x11-wm/enlightenment-devel
+RUN_DEPENDS= enlightenment-config:${PORTSDIR}/x11-wm/enlightenment-devel
USE_BZIP2= yes
-USE_X_PREFIX= yes
USE_GMAKE= yes
+USE_GNOME= gnometarget pkgconfig
+USE_EFL= ecore evas edje eet
+USE_EFL_ESMART= trans_x11
GNU_CONFIGURE= yes
-CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include -I${X11BASE}/include" \
- LDFLAGS="-L${LOCALBASE}/lib -L${X11BASE}/lib"
-PLIST_SUB+= MODULE_ARCH=freebsd${OSREL}-${ARCH}
+IGNORE= doesn't compile with recent e17
.if !defined(WITHOUT_NLS)
USE_GETTEXT= yes
@@ -36,4 +37,10 @@ CONFIGURE_ARGS= --disable-nls
PLIST_SUB+= NLS="@comment "
.endif
-.include <bsd.port.mk>
+.include <bsd.port.pre.mk>
+
+post-patch:
+ @${REINPLACE_CMD} -e s,`${PRINTF} '\r'`,,g ${WRKSRC}/src/*.[ch]
+
+.include "../../x11-wm/enlightenment-devel/bsd.efl.mk"
+.include <bsd.port.post.mk>
diff --git a/x11/e17-module-calendar/distinfo b/x11/e17-module-calendar/distinfo
index 3e641ac6c035..492ca7b8e1dc 100644
--- a/x11/e17-module-calendar/distinfo
+++ b/x11/e17-module-calendar/distinfo
@@ -1,3 +1,3 @@
-MD5 (calendar-23062006.tar.bz2) = 161a388d25c7abd9a73142aad0792f4b
-SHA256 (calendar-23062006.tar.bz2) = 3c96faa84c4776c9a1d970962ade1b36113d2226ed657ee0290fc98328f90e4d
-SIZE (calendar-23062006.tar.bz2) = 554819
+MD5 (calendar-20060926.tar.bz2) = a7c47f3efc02a2688ce4b8cc3fe2a659
+SHA256 (calendar-20060926.tar.bz2) = cdfaa4277375994287149310cf3b2a4be224cd38304ff3909f99006c55ec9331
+SIZE (calendar-20060926.tar.bz2) = 552639
diff --git a/x11/e17-module-calendar/files/patch-src_e_mod_main.c b/x11/e17-module-calendar/files/patch-src_e_mod_main.c
deleted file mode 100644
index 1425a4ef7ec1..000000000000
--- a/x11/e17-module-calendar/files/patch-src_e_mod_main.c
+++ /dev/null
@@ -1,20 +0,0 @@
---- src/e_mod_main.c.orig Thu Jul 6 23:11:37 2006
-+++ src/e_mod_main.c Thu Jul 6 23:13:48 2006
-@@ -47,7 +47,7 @@
-
- {
- e_error_dialog_show
-- ("Module API Error", "Error initializing Module: calendar\n"
-+ (module, "Module API Error", "Error initializing Module: calendar\n"
- "It requires a minimum module API version of: %i.\n"
- "The module API advertized by Enlightenment is: %i.\n"
- "Aborting module.", E_MODULE_API_VERSION, module->api->version);
-@@ -102,7 +102,7 @@
- EAPI int
- e_modapi_about(E_Module *module)
- {
-- e_error_dialog_show(D_("Enlightenment calendar Module"), D_("A simple module to give E17 a desktop calendar "));
-+ e_error_dialog_show(module, D_("Enlightenment calendar Module"), D_("A simple module to give E17 a desktop calendar "));
- return 1;
- }
-