aboutsummaryrefslogtreecommitdiff
path: root/x11/e17-module-moon/Makefile
diff options
context:
space:
mode:
authorIon-Mihai Tetcu <itetcu@FreeBSD.org>2006-06-24 17:47:57 +0000
committerIon-Mihai Tetcu <itetcu@FreeBSD.org>2006-06-24 17:47:57 +0000
commitffc3a6a03e86f76fc90a7cd34faa7827455cb4e1 (patch)
tree9d6ad75ff195d6564adb71bd4224af87f092b3d3 /x11/e17-module-moon/Makefile
parent97a0e44f75d26813ba6dadf247fee79cb1f5cbd6 (diff)
downloadports-ffc3a6a03e86f76fc90a7cd34faa7827455cb4e1.tar.gz
ports-ffc3a6a03e86f76fc90a7cd34faa7827455cb4e1.zip
Notes
Diffstat (limited to 'x11/e17-module-moon/Makefile')
-rw-r--r--x11/e17-module-moon/Makefile36
1 files changed, 36 insertions, 0 deletions
diff --git a/x11/e17-module-moon/Makefile b/x11/e17-module-moon/Makefile
new file mode 100644
index 000000000000..cd5e080b7c9c
--- /dev/null
+++ b/x11/e17-module-moon/Makefile
@@ -0,0 +1,36 @@
+# New ports collection makefile for: e17-module-moon
+# Date created: 23 June 2006
+# Whom: Stanislav Sedov <ssedov@mbsd.msk.ru>
+#
+# $FreeBSD$
+#
+
+PORTNAME= moon
+PORTVERSION= 23062006
+CATEGORIES= x11
+MASTER_SITES= http://mbsd.msk.ru/dist/
+PKGNAMEPREFIX= e17-module-
+DISTNAME= ${PORTNAME}-${PORTVERSION}
+
+MAINTAINER= ssedov@mbsd.msk.ru
+COMMENT= An e17 Moon Clock module
+
+BUILD_DEPENDS= enlightenment:${PORTSDIR}/x11-wm/enlightenment-devel
+RUN_DEPENDS= ${BUILD_DEPENDS}
+
+USE_BZIP2= yes
+USE_X_PREFIX= yes
+USE_GMAKE= yes
+GNU_CONFIGURE= yes
+CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include -I${X11BASE}/include" \
+ LDFLAGS="-L${LOCALBASE}/lib -L${X11BASE}/lib"
+
+.if !defined(WITHOUT_NLS)
+USE_GETTEXT= yes
+PLIST_SUB+= NLS=""
+.else
+CONFIGURE_ARGS= --disable-nls
+PLIST_SUB+= NLS="@comment "
+.endif
+
+.include <bsd.port.mk>