aboutsummaryrefslogtreecommitdiff
path: root/x11/e17-module-rain/Makefile
diff options
context:
space:
mode:
authorIon-Mihai Tetcu <itetcu@FreeBSD.org>2006-07-10 20:08:21 +0000
committerIon-Mihai Tetcu <itetcu@FreeBSD.org>2006-07-10 20:08:21 +0000
commite7022df49ceeeffe0494d3d26e73878d0033ebc9 (patch)
tree28644101f688db92f12178d69fe19706e2b6dcc8 /x11/e17-module-rain/Makefile
parent661eb26c12967a194f7f5d1a4e345b9f4a21ed35 (diff)
downloadports-e7022df49ceeeffe0494d3d26e73878d0033ebc9.tar.gz
ports-e7022df49ceeeffe0494d3d26e73878d0033ebc9.zip
Notes
Diffstat (limited to 'x11/e17-module-rain/Makefile')
-rw-r--r--x11/e17-module-rain/Makefile36
1 files changed, 36 insertions, 0 deletions
diff --git a/x11/e17-module-rain/Makefile b/x11/e17-module-rain/Makefile
new file mode 100644
index 000000000000..c59c711ffa99
--- /dev/null
+++ b/x11/e17-module-rain/Makefile
@@ -0,0 +1,36 @@
+# New ports collection makefile for: e17-module-rain
+# Date created: 23 June 2006
+# Whom: Stanislav Sedov <ssedov@mbsd.msk.ru>
+#
+# $FreeBSD$
+#
+
+PORTNAME= rain
+PORTVERSION= 20060707
+CATEGORIES= x11
+MASTER_SITES= http://mbsd.msk.ru/dist/
+PKGNAMEPREFIX= e17-module-
+DISTNAME= ${PORTNAME}-${PORTVERSION}
+
+MAINTAINER= ssedov@mbsd.msk.ru
+COMMENT= An e17 module which draws raindrops on your screen
+
+BUILD_DEPENDS= enlightenment:${PORTSDIR}/x11-wm/enlightenment-devel
+RUN_DEPENDS= ${BUILD_DEPENDS}
+
+USE_BZIP2= yes
+USE_X_PREFIX= yes
+USE_GMAKE= yes
+GNU_CONFIGURE= yes
+CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include -I${X11BASE}/include" \
+ LDFLAGS="-L${LOCALBASE}/lib -L${X11BASE}/lib"
+
+.if !defined(WITHOUT_NLS)
+USE_GETTEXT= yes
+PLIST_SUB+= NLS=""
+.else
+CONFIGURE_ARGS= --disable-nls
+PLIST_SUB+= NLS="@comment "
+.endif
+
+.include <bsd.port.mk>