aboutsummaryrefslogtreecommitdiff
path: root/x11/eaglemode
diff options
context:
space:
mode:
authorDmitry Marakasov <amdmi3@FreeBSD.org>2018-12-25 16:29:25 +0000
committerDmitry Marakasov <amdmi3@FreeBSD.org>2018-12-25 16:29:25 +0000
commitc9bb29895f2fb1df29f75d77ddab0e050f3527b2 (patch)
tree513ba6f4fd4670e45bd4d89616f5fa1017f7dc0d /x11/eaglemode
parentb5722fac7fda1cc7c206797b533eae81d21c5f1d (diff)
Notes
Diffstat (limited to 'x11/eaglemode')
-rw-r--r--x11/eaglemode/Makefile8
-rw-r--r--x11/eaglemode/distinfo6
-rw-r--r--x11/eaglemode/files/patch-makers-unicc-plugins-unicc__gnu.pm18
-rw-r--r--x11/eaglemode/files/patch-makers_unicc_plugins_unicc__gnu.pm33
4 files changed, 39 insertions, 26 deletions
diff --git a/x11/eaglemode/Makefile b/x11/eaglemode/Makefile
index 8bd4d2aedc95..14532baf1c83 100644
--- a/x11/eaglemode/Makefile
+++ b/x11/eaglemode/Makefile
@@ -2,8 +2,7 @@
# $FreeBSD$
PORTNAME= eaglemode
-PORTVERSION= 0.93.2
-PORTREVISION= 2
+PORTVERSION= 0.94.0
CATEGORIES= x11
MASTER_SITES= SF/${PORTNAME}/${PORTNAME}-${PORTVERSION}
@@ -16,7 +15,8 @@ LIB_DEPENDS= libpng.so:graphics/png \
libtiff.so:graphics/tiff \
libfreetype.so:print/freetype2
-USES= compiler:features jpeg perl5 pkgconfig shebangfix tar:bzip2
+USES= compiler:features jpeg gnome perl5 \
+ pkgconfig tar:bzip2
USE_PERL5= build
USE_XORG= x11 xext xxf86vm
SUB_FILES= eaglemode.sh
@@ -58,8 +58,6 @@ BUILD_ARGS+= xine-inc-dir="${LOCALBASE}/include" \
.endif
post-patch:
- @${REINPLACE_CMD} -e 's|gcc|${CC}|; s|"-O2"|"${CFLAGS}"|' \
- ${WRKSRC}/makers/unicc/plugins/unicc_gnu.pm
@${FIND} ${WRKSRC} -name "*.pl" | ${XARGS} \
${REINPLACE_CMD} -e '1s|/usr/bin/perl|${perl_CMD}|'
diff --git a/x11/eaglemode/distinfo b/x11/eaglemode/distinfo
index b60a71ae4dd1..6ad473f642c1 100644
--- a/x11/eaglemode/distinfo
+++ b/x11/eaglemode/distinfo
@@ -1,3 +1,3 @@
-TIMESTAMP = 1532802088
-SHA256 (eaglemode-0.93.2.tar.bz2) = 28724e92d17d9cb6a6dc5de5b5097e5c85389abffde3d216a33188a8f0de9bf9
-SIZE (eaglemode-0.93.2.tar.bz2) = 16541578
+TIMESTAMP = 1545663590
+SHA256 (eaglemode-0.94.0.tar.bz2) = 33798753e41f22756a6402efc445729d25ef93982a43de36de5ac8e4535b23eb
+SIZE (eaglemode-0.94.0.tar.bz2) = 16726294
diff --git a/x11/eaglemode/files/patch-makers-unicc-plugins-unicc__gnu.pm b/x11/eaglemode/files/patch-makers-unicc-plugins-unicc__gnu.pm
deleted file mode 100644
index 03823c0b2463..000000000000
--- a/x11/eaglemode/files/patch-makers-unicc-plugins-unicc__gnu.pm
+++ /dev/null
@@ -1,18 +0,0 @@
---- makers/unicc/plugins/unicc_gnu.pm.orig 2008-10-29 08:27:34.000000000 +0300
-+++ makers/unicc/plugins/unicc_gnu.pm 2008-10-30 00:08:33.000000000 +0300
-@@ -142,6 +142,7 @@
- push(@args,GetObjFiles->[$index]);
- }
-
-+ @args = split(/\s+/, join(' ', @args));
- return PrintAndRun(@args);
- }
-
-@@ -178,6 +179,7 @@
- }
- }
-
-+ @args = split(/\s+/, join(' ', @args));
- return PrintAndRun(@args);
- }
-
diff --git a/x11/eaglemode/files/patch-makers_unicc_plugins_unicc__gnu.pm b/x11/eaglemode/files/patch-makers_unicc_plugins_unicc__gnu.pm
new file mode 100644
index 000000000000..2889c9c9588e
--- /dev/null
+++ b/x11/eaglemode/files/patch-makers_unicc_plugins_unicc__gnu.pm
@@ -0,0 +1,33 @@
+--- makers/unicc/plugins/unicc_gnu.pm.orig 2018-12-23 06:47:44 UTC
++++ makers/unicc/plugins/unicc_gnu.pm
+@@ -35,7 +35,7 @@ my $IsWinOrCygwin;
+ my $IsDarwin;
+
+ {
+- my $s=`gcc -dumpversion`; # Examples: "4.3", "2.95.3"
++ my $s=`$ENV{'CC'} -dumpversion`; # Examples: "4.3", "2.95.3"
+ if ($? != 0) { exit(1); }
+ for (;; $s=substr($s,1)) {
+ if (length($s)==0) { die("Cannot determine GCC version, stopped"); }
+@@ -112,9 +112,9 @@ sub Compile
+ push(@args,("-o",GetObjFiles->[$index]));
+ }
+ else {
+- push(@args,"gcc");
++ push(@args,$isCpp ? $ENV{'CXX'} : $ENV{'CC'});
+ if (HaveDebug) { push(@args,"-g"); }
+- push(@args,"-O2");
++ push(@args,split(/\s+/, $isCpp ? $ENV{'CXXFLAGS'} : $ENV{'CFLAGS'}));
+ if ($isCpp && $GccVersion>=4.7 && $GccVersion<6.1) {
+ push(@args,"-std=c++11");
+ }
+@@ -167,7 +167,8 @@ sub Link
+ push(@args,(@{GetObjFiles()}));
+ }
+ else {
+- push(@args,"gcc");
++ push(@args,$ENV{'CC'});
++ push(@args,split(/\s+/, $ENV{'LDFLAGS'}));
+ if (HaveDebug) { push(@args,"-g"); }
+ if ($type eq 'dynlib') {
+ push(@args,$IsDarwin ? "-dynamiclib" : "-shared");