aboutsummaryrefslogtreecommitdiff
path: root/x11/ebuttons/Makefile
diff options
context:
space:
mode:
authorKirill Ponomarev <krion@FreeBSD.org>2003-12-09 20:13:44 +0000
committerKirill Ponomarev <krion@FreeBSD.org>2003-12-09 20:13:44 +0000
commit814bf4b0b1d493769e0c9214e729098b251a63f6 (patch)
tree2987140fdae8deb84582df625f3cb381e697932a /x11/ebuttons/Makefile
parentc30df7f98176cf6486d52f4b9a4a707c0747dba3 (diff)
Notes
Diffstat (limited to 'x11/ebuttons/Makefile')
-rw-r--r--x11/ebuttons/Makefile14
1 files changed, 8 insertions, 6 deletions
diff --git a/x11/ebuttons/Makefile b/x11/ebuttons/Makefile
index e0221bd347c0..b1af8fbbf393 100644
--- a/x11/ebuttons/Makefile
+++ b/x11/ebuttons/Makefile
@@ -1,4 +1,4 @@
-# New ports collection makefile for: E-Buttons 0.2
+# New ports collection makefile for: E-Buttons
# Date created: 30 March 2000
# Whom: jhb
#
@@ -7,6 +7,7 @@
PORTNAME= E-buttons
PORTVERSION= 0.2
+PORTREVISION= 1
CATEGORIES= x11
MASTER_SITES= http://www.moodfarm.demon.co.uk/download/
EXTRACT_SUFX= .tgz
@@ -14,17 +15,18 @@ EXTRACT_SUFX= .tgz
MAINTAINER= ports@FreeBSD.org
COMMENT= A simple epplet that contains several buttons used to launch programs
-LIB_DEPENDS= epplet.1:${PORTSDIR}/x11-wm/epplets
+LIB_DEPENDS= epplet.1:${PORTSDIR}/x11-wm/libepplet
WRKSRC= ${WRKDIR}/E-buttons
USE_X_PREFIX= yes
-pre-patch:
- ${CP} ${FILESDIR}/Makefile ${WRKSRC}
+CPPFLAGS= -I${X11BASE}/include ${PTHREAD_CFLAGS}
+LDFLAGS= -L${X11BASE}/lib -lepplet ${PTHREAD_LIBS}
-pre-build:
- @(cd ${WRKSRC} && ${MAKE} clean)
+do-build:
+ cd ${WRKSRC} && ${CC} ${CFLAGS} ${CPPFLAGS} -o E-Buttons.epplet \
+ ${PORTNAME}.c ${LDFLAGS}
do-install:
${INSTALL_PROGRAM} ${WRKSRC}/E-Buttons.epplet ${PREFIX}/bin