aboutsummaryrefslogtreecommitdiff
path: root/x11/ecore-input_evas
diff options
context:
space:
mode:
authorStanislav Sedov <stas@FreeBSD.org>2010-12-14 07:30:56 +0000
committerStanislav Sedov <stas@FreeBSD.org>2010-12-14 07:30:56 +0000
commit4e6b9d37ad988e5ce212eb64d3da6c89f036995b (patch)
treec034200ad770d5a81c162443b728bd36b7987a9c /x11/ecore-input_evas
parent32d827c027cde0f59dfae87babbc1499241115ab (diff)
Notes
Diffstat (limited to 'x11/ecore-input_evas')
-rw-r--r--x11/ecore-input_evas/Makefile49
-rw-r--r--x11/ecore-input_evas/distinfo2
-rw-r--r--x11/ecore-input_evas/pkg-descr5
-rw-r--r--x11/ecore-input_evas/pkg-plist5
4 files changed, 61 insertions, 0 deletions
diff --git a/x11/ecore-input_evas/Makefile b/x11/ecore-input_evas/Makefile
new file mode 100644
index 000000000000..cd26db8d7d18
--- /dev/null
+++ b/x11/ecore-input_evas/Makefile
@@ -0,0 +1,49 @@
+# New ports collection makefile for: ecore-input_evas
+# Date created: 14 June 2010
+# Whom: Grzegorz Blach <magik@roorback.net>
+#
+# $FreeBSD$
+#
+
+PORTNAME= input_evas
+DISTVERSION= 1.0.0.beta
+CATEGORIES= x11 enlightenment
+MASTER_SITES= http://download.enlightenment.org/releases/ \
+ http://files.roorback.net/e17/2010-10-03/base/
+PKGNAMEPREFIX= ecore-
+DISTNAME= ecore-${DISTVERSION}
+
+MAINTAINER= magik@roorback.net
+COMMENT= Enlightenment core abstraction library (evas input module)
+
+LICENSE= BSD
+DIST_SUBDIR= e17
+USE_BZIP2= yes
+GNU_CONFIGURE= yes
+USE_EFL= ecore evas libtool_hack
+USE_EFL_ECORE= input
+USE_GNOME= gnomehack pkgconfig gnometarget
+USE_LDCONFIG= yes
+BUILD_WRKSRC= ${WRKSRC}/src/lib/ecore_input_evas
+INSTALL_WRKSRC= ${BUILD_WRKSRC}
+
+.include <../../devel/ecore-main/Makefile.inc>
+
+CONFIGURE_ARGS+= --enable-ecore-input \
+ --enable-ecore-input_evas
+
+.include <bsd.port.pre.mk>
+
+post-patch:
+ @${REINPLACE_CMD} -E \
+ -e 's,\$$\(top_builddir\)/src/lib/ecore/\.libs,${LOCALBASE}/lib,'\
+ -e 's,\$$\(top_builddir\)/src/lib/ecore_input/\.libs,${LOCALBASE}/lib,'\
+ -e 's,\$$\(top_builddir\)/src/lib/ecore/libecore\.la,-lecore,'\
+ -e 's,\$$\(top_builddir\)/src/lib/ecore_input/libecore_input\.la,-lecore_input,'\
+ ${BUILD_WRKSRC}/Makefile.in
+
+post-install:
+ ${INSTALL_DATA} ${WRKSRC}/ecore-input-evas.pc \
+ ${PREFIX}/libdata/pkgconfig/
+
+.include <bsd.port.post.mk>
diff --git a/x11/ecore-input_evas/distinfo b/x11/ecore-input_evas/distinfo
new file mode 100644
index 000000000000..36d07e85437a
--- /dev/null
+++ b/x11/ecore-input_evas/distinfo
@@ -0,0 +1,2 @@
+SHA256 (e17/ecore-1.0.0.beta.tar.bz2) = 9fd367f9ff10568082e65c1def46e64fb96b359221e0d6aea11c6c3f6bd5282f
+SIZE (e17/ecore-1.0.0.beta.tar.bz2) = 916635
diff --git a/x11/ecore-input_evas/pkg-descr b/x11/ecore-input_evas/pkg-descr
new file mode 100644
index 000000000000..2559668d0e57
--- /dev/null
+++ b/x11/ecore-input_evas/pkg-descr
@@ -0,0 +1,5 @@
+A core event abstracter layer and X abstraction layer that makes doing
+selections, Xdnd, general X stuff, and event loops, timeouts and idle handlers
+fast, optimised, and convenient.
+
+WWW: http://enlightenment.sourceforge.net/Libraries/Ecore/
diff --git a/x11/ecore-input_evas/pkg-plist b/x11/ecore-input_evas/pkg-plist
new file mode 100644
index 000000000000..69513ee591f1
--- /dev/null
+++ b/x11/ecore-input_evas/pkg-plist
@@ -0,0 +1,5 @@
+include/ecore-1/Ecore_Input_Evas.h
+lib/libecore_input_evas.so
+lib/libecore_input_evas.so.1
+libdata/pkgconfig/ecore-input-evas.pc
+@dirrmtry include/ecore-1