aboutsummaryrefslogtreecommitdiff
path: root/x11/ecore-x11
diff options
context:
space:
mode:
authorStanislav Sedov <stas@FreeBSD.org>2008-03-11 21:13:53 +0000
committerStanislav Sedov <stas@FreeBSD.org>2008-03-11 21:13:53 +0000
commit9a2e4c8b780fc607dc4b4adabefb354c84401a96 (patch)
treef59767aed29b447d3d80ab987e898598663c27e3 /x11/ecore-x11
parent621c804e48a9fdddd6a00d78585fa8cb20c8460e (diff)
downloadports-9a2e4c8b780fc607dc4b4adabefb354c84401a96.tar.gz
ports-9a2e4c8b780fc607dc4b4adabefb354c84401a96.zip
Notes
Diffstat (limited to 'x11/ecore-x11')
-rw-r--r--x11/ecore-x11/Makefile115
-rw-r--r--x11/ecore-x11/distinfo3
-rw-r--r--x11/ecore-x11/pkg-descr5
-rw-r--r--x11/ecore-x11/pkg-plist8
4 files changed, 131 insertions, 0 deletions
diff --git a/x11/ecore-x11/Makefile b/x11/ecore-x11/Makefile
new file mode 100644
index 000000000000..5b6c43d60f7e
--- /dev/null
+++ b/x11/ecore-x11/Makefile
@@ -0,0 +1,115 @@
+# New ports collection makefile for: ecore-x11
+# Date created: 17 September 2007
+# Whom: Stanislav Sedov <stas@FreeBSD.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= x11
+PORTVERSION= 0.9.9.042
+PORTREVISION= 0
+CATEGORIES= x11
+MASTER_SITES= ftp://ftp.springdaemons.com/pub/snapshots/e17/ \
+ http://download.enlightenment.org/snapshots/2008-01-25/
+PKGNAMEPREFIX= ecore-
+DISTNAME= ecore-${PORTVERSION}
+
+MAINTAINER= stas@FreeBSD.org
+COMMENT= Enlightenment core abstraction library (x11 module)
+
+GNU_CONFIGURE= yes
+USE_BZIP2= yes
+USE_GNOME= gnomehack pkgconfig gnometarget
+USE_LDCONFIG= yes
+USE_GETOPT_LONG=yes
+USE_EFL= ecore
+USE_EFL_ECORE= txt
+BUILD_WRKSRC= ${WRKSRC}/src/lib/ecore_x
+INSTALL_WRKSRC= ${BUILD_WRKSRC}
+XEXTDIR= ${LOCALBASE}/include/X11/extensions
+
+CONFIGURE_ARGS= --disable-ecore-con \
+ --disable-ecore-config \
+ --disable-ecore-desktop \
+ --disable-ecore-directfb \
+ --disable-ecore-evas \
+ --disable-ecore-file \
+ --disable-ecore-ipc \
+ --disable-ecore-job \
+ --disable-ecore-sdl \
+ --disable-ecore-txt \
+ --enable-ecore-x \
+ --disable-ecore-imf \
+ --disable-ecore-imf_evas
+
+OPTIONS= XDAMAGE "Enable Xdamage support (requires X11)" on \
+ XDPMS "Enable Xdpms support (requires X11)" on \
+ XFIXES "Enable Xfixes support (requires X11)" on \
+ XINERAMA "Enable Xinerama support (requires X11)" on \
+ XPRINT "Enable Xprint support (requires X11)" on \
+ XRANDR "Enable Xrandr support (requires X11)" on \
+ XRENDER "Enable Xrender support (requires X11)" on \
+ XSS "Enable Xscrnsaver support (requires X11)" on \
+ XCURSOR "Enable Xcursor support (requires X11)" on
+
+.include <bsd.port.pre.mk>
+
+.if !defined(WITHOUT_XDAMAGE) || exists(${XEXTDIR}/Xdamage.h)
+USE_XORG+= xdamage
+WITH_X11= yes
+.endif
+
+.if !defined(WITHOUT_XDPMS) || exists(${XEXTDIR}/dpms.h)
+USE_XORG+= xextproto
+WITH_X11= yes
+.endif
+
+.if !defined(WITHOUT_XFIXES) || exists(${XEXTDIR}/Xfixes.h)
+USE_XORG+= xfixes
+WITH_X11= yes
+.endif
+
+.if !defined(WITHOUT_XINERAMA) || exists(${XEXTDIR}/Xinerama.h)
+USE_XORG+= xineramaproto
+WITH_X11= yes
+.endif
+
+.if !defined(WITHOUT_XPRINT) || exists(${XEXTDIR}/Print.h)
+USE_XORG+= printproto
+WITH_X11= yes
+.endif
+
+.if !defined(WITHOUT_XRANDR) || exists(${XEXTDIR}/Xrandr.h)
+USE_XORG+= xrandr
+WITH_X11= yes
+.endif
+
+.if !defined(WITHOUT_XRENDER) || exists(${XEXTDIR}/Xrender.h)
+USE_XORG+= xrender
+WITH_X11= yes
+.endif
+
+.if !defined(WITHOUT_XSS) || exists(${XEXTDIR}/scrnsaver.h)
+USE_XORG+= xscrnsaver
+WITH_X11= yes
+.endif
+
+.if !defined(WITHOUT_XCURSOR) \
+ || exists(${LOCALBASE}/include/X11/Xcursor/Xcursor.h)
+USE_XORG+= xcursor
+WITH_X11= yes
+.endif
+
+post-patch:
+ @${REINPLACE_CMD} -E \
+ -e 's,\$$\(top_builddir\)/src/lib/ecore/\.libs,${LOCALBASE}/lib,'\
+ -e 's,\$$\(top_builddir\)/src/lib/ecore_txt/\.libs,${LOCALBASE}/lib,'\
+ -e 's,\$$\(top_builddir\)/src/lib/ecore/libecore\.la,-lecore,'\
+ -e 's,\$$\(top_builddir\)/src/lib/ecore_txt/libecore_txt\.la,-lecore_txt,'\
+ ${BUILD_WRKSRC}/Makefile.in
+
+post-install:
+ ${INSTALL_DATA} ${WRKSRC}/ecore-x.pc \
+ ${PREFIX}/libdata/pkgconfig/
+
+.include <bsd.port.post.mk>
diff --git a/x11/ecore-x11/distinfo b/x11/ecore-x11/distinfo
new file mode 100644
index 000000000000..4672f6a1c167
--- /dev/null
+++ b/x11/ecore-x11/distinfo
@@ -0,0 +1,3 @@
+MD5 (ecore-0.9.9.042.tar.bz2) = a66df2b5f0b1a6abc47bb50bf2b26846
+SHA256 (ecore-0.9.9.042.tar.bz2) = 26486fd2c80e4000b673f81ce637aa50c17c767e4c2af8f56de5d110e387d136
+SIZE (ecore-0.9.9.042.tar.bz2) = 5285732
diff --git a/x11/ecore-x11/pkg-descr b/x11/ecore-x11/pkg-descr
new file mode 100644
index 000000000000..2559668d0e57
--- /dev/null
+++ b/x11/ecore-x11/pkg-descr
@@ -0,0 +1,5 @@
+A core event abstracter layer and X abstraction layer that makes doing
+selections, Xdnd, general X stuff, and event loops, timeouts and idle handlers
+fast, optimised, and convenient.
+
+WWW: http://enlightenment.sourceforge.net/Libraries/Ecore/
diff --git a/x11/ecore-x11/pkg-plist b/x11/ecore-x11/pkg-plist
new file mode 100644
index 000000000000..acc2454607d3
--- /dev/null
+++ b/x11/ecore-x11/pkg-plist
@@ -0,0 +1,8 @@
+include/Ecore_X.h
+include/Ecore_X_Atoms.h
+include/Ecore_X_Cursor.h
+lib/libecore_x.a
+lib/libecore_x.la
+lib/libecore_x.so
+lib/libecore_x.so.9
+libdata/pkgconfig/ecore-x.pc