aboutsummaryrefslogtreecommitdiff
path: root/x11/ecore-x11
diff options
context:
space:
mode:
authorStanislav Sedov <stas@FreeBSD.org>2010-12-14 07:30:56 +0000
committerStanislav Sedov <stas@FreeBSD.org>2010-12-14 07:30:56 +0000
commit4e6b9d37ad988e5ce212eb64d3da6c89f036995b (patch)
treec034200ad770d5a81c162443b728bd36b7987a9c /x11/ecore-x11
parent32d827c027cde0f59dfae87babbc1499241115ab (diff)
downloadports-4e6b9d37ad988e5ce212eb64d3da6c89f036995b.tar.gz
ports-4e6b9d37ad988e5ce212eb64d3da6c89f036995b.zip
Notes
Diffstat (limited to 'x11/ecore-x11')
-rw-r--r--x11/ecore-x11/Makefile44
-rw-r--r--x11/ecore-x11/distinfo5
-rw-r--r--x11/ecore-x11/files/patch-src_lib_ecore_x_xlib_ecore_x_randr_12.c44
-rw-r--r--x11/ecore-x11/pkg-plist11
4 files changed, 70 insertions, 34 deletions
diff --git a/x11/ecore-x11/Makefile b/x11/ecore-x11/Makefile
index e26cb373b20b..c36d00b8a9f4 100644
--- a/x11/ecore-x11/Makefile
+++ b/x11/ecore-x11/Makefile
@@ -6,40 +6,32 @@
#
PORTNAME= x11
-PORTVERSION= 0.9.9.042
-PORTREVISION= 0
-CATEGORIES= x11
-MASTER_SITES= ftp://ftp.springdaemons.com/pub/snapshots/e17/ \
- http://download.enlightenment.org/snapshots/2008-01-25/
+DISTVERSION= 1.0.0.beta
+CATEGORIES= x11 enlightenment
+MASTER_SITES= http://download.enlightenment.org/releases/ \
+ http://files.roorback.net/e17/2010-10-03/base/
PKGNAMEPREFIX= ecore-
-DISTNAME= ecore-${PORTVERSION}
+DISTNAME= ecore-${DISTVERSION}
MAINTAINER= stas@FreeBSD.org
COMMENT= Enlightenment core abstraction library (x11 module)
-GNU_CONFIGURE= yes
+LICENSE= BSD
+DIST_SUBDIR= e17
USE_BZIP2= yes
+GNU_CONFIGURE= yes
+USE_EFL= ecore libtool_hack
+USE_EFL_ECORE= input
USE_GNOME= gnomehack pkgconfig gnometarget
USE_LDCONFIG= yes
-USE_EFL= ecore
-USE_EFL_ECORE= txt
BUILD_WRKSRC= ${WRKSRC}/src/lib/ecore_x
INSTALL_WRKSRC= ${BUILD_WRKSRC}
XEXTDIR= ${LOCALBASE}/include/X11/extensions
-CONFIGURE_ARGS= --disable-ecore-con \
- --disable-ecore-config \
- --disable-ecore-desktop \
- --disable-ecore-directfb \
- --disable-ecore-evas \
- --disable-ecore-file \
- --disable-ecore-ipc \
- --disable-ecore-job \
- --disable-ecore-sdl \
- --disable-ecore-txt \
- --enable-ecore-x \
- --disable-ecore-imf \
- --disable-ecore-imf_evas
+.include <../../devel/ecore-main/Makefile.inc>
+
+CONFIGURE_ARGS+= --enable-ecore-x \
+ --enable-ecore-input
OPTIONS= XDAMAGE "Enable Xdamage support (requires X11)" on \
XDPMS "Enable Xdpms support (requires X11)" on \
@@ -102,10 +94,12 @@ WITH_X11= yes
post-patch:
@${REINPLACE_CMD} -E \
-e 's,\$$\(top_builddir\)/src/lib/ecore/\.libs,${LOCALBASE}/lib,'\
- -e 's,\$$\(top_builddir\)/src/lib/ecore_txt/\.libs,${LOCALBASE}/lib,'\
+ -e 's,\$$\(top_builddir\)/src/lib/ecore_input/\.libs,${LOCALBASE}/lib,'\
-e 's,\$$\(top_builddir\)/src/lib/ecore/libecore\.la,-lecore,'\
- -e 's,\$$\(top_builddir\)/src/lib/ecore_txt/libecore_txt\.la,-lecore_txt,'\
- ${BUILD_WRKSRC}/Makefile.in
+ -e 's,\$$\(top_builddir\)/src/lib/ecore_input/libecore_input\.la,-lecore_input,'\
+ ${BUILD_WRKSRC}/Makefile.in \
+ ${BUILD_WRKSRC}/xcb/Makefile.in \
+ ${BUILD_WRKSRC}/xlib/Makefile.in
post-install:
${INSTALL_DATA} ${WRKSRC}/ecore-x.pc \
diff --git a/x11/ecore-x11/distinfo b/x11/ecore-x11/distinfo
index 4672f6a1c167..36d07e85437a 100644
--- a/x11/ecore-x11/distinfo
+++ b/x11/ecore-x11/distinfo
@@ -1,3 +1,2 @@
-MD5 (ecore-0.9.9.042.tar.bz2) = a66df2b5f0b1a6abc47bb50bf2b26846
-SHA256 (ecore-0.9.9.042.tar.bz2) = 26486fd2c80e4000b673f81ce637aa50c17c767e4c2af8f56de5d110e387d136
-SIZE (ecore-0.9.9.042.tar.bz2) = 5285732
+SHA256 (e17/ecore-1.0.0.beta.tar.bz2) = 9fd367f9ff10568082e65c1def46e64fb96b359221e0d6aea11c6c3f6bd5282f
+SIZE (e17/ecore-1.0.0.beta.tar.bz2) = 916635
diff --git a/x11/ecore-x11/files/patch-src_lib_ecore_x_xlib_ecore_x_randr_12.c b/x11/ecore-x11/files/patch-src_lib_ecore_x_xlib_ecore_x_randr_12.c
new file mode 100644
index 000000000000..353f6734744e
--- /dev/null
+++ b/x11/ecore-x11/files/patch-src_lib_ecore_x_xlib_ecore_x_randr_12.c
@@ -0,0 +1,44 @@
+--- src/lib/ecore_x/xlib/ecore_x_randr_12.c.orig 2010-09-29 17:38:19.000000000 -0700
++++ src/lib/ecore_x/xlib/ecore_x_randr_12.c 2010-12-12 20:35:14.000000000 -0800
+@@ -370,6 +370,32 @@
+ #endif
+ }
+
++static size_t
++strnlen_local(const char *s, size_t maxlen)
++{
++ size_t len;
++
++ for (len = 0; len < maxlen; len++, s++) {
++ if (!*s)
++ break;
++ }
++ return (len);
++}
++
++static char *
++strndup_local(const char *str, size_t n)
++{
++ size_t len;
++ char *copy;
++
++ len = strnlen_local(str, n);
++ if ((copy = malloc(len + 1)) == NULL)
++ return (NULL);
++ memcpy(copy, str, len);
++ copy[len] = '\0';
++ return (copy);
++}
++
+ /*
+ * @brief get detailed information for a given mode id
+ * @param root window which's screen's ressources are queried
+@@ -405,7 +431,7 @@
+ ret->vSyncEnd = res->modes[i].vSyncEnd;
+ ret->vTotal = res->modes[i].vTotal;
+ if (!(ret->name =
+- strndup(res->modes[i].name, res->modes[i].nameLength)))
++ strndup_local(res->modes[i].name, res->modes[i].nameLength)))
+ {
+ ret->name = NULL;
+ ret->nameLength = 0;
diff --git a/x11/ecore-x11/pkg-plist b/x11/ecore-x11/pkg-plist
index acc2454607d3..8f712c5a4106 100644
--- a/x11/ecore-x11/pkg-plist
+++ b/x11/ecore-x11/pkg-plist
@@ -1,8 +1,7 @@
-include/Ecore_X.h
-include/Ecore_X_Atoms.h
-include/Ecore_X_Cursor.h
-lib/libecore_x.a
-lib/libecore_x.la
+include/ecore-1/Ecore_X.h
+include/ecore-1/Ecore_X_Atoms.h
+include/ecore-1/Ecore_X_Cursor.h
lib/libecore_x.so
-lib/libecore_x.so.9
+lib/libecore_x.so.1
libdata/pkgconfig/ecore-x.pc
+@dirrmtry include/ecore-1