aboutsummaryrefslogtreecommitdiff
path: root/x11/electricsheep/Makefile
diff options
context:
space:
mode:
authorAnders Nordby <anders@FreeBSD.org>2002-03-24 19:28:48 +0000
committerAnders Nordby <anders@FreeBSD.org>2002-03-24 19:28:48 +0000
commit5fd4ae2e00e1840d568aabc7e0c11b3e1503eb6f (patch)
treeebf0f6bc10cf42a416a9bb29b0dbb5d9384f3782 /x11/electricsheep/Makefile
parent64491432c4332e117122ed549c6469a285239519 (diff)
downloadports-5fd4ae2e00e1840d568aabc7e0c11b3e1503eb6f.tar.gz
ports-5fd4ae2e00e1840d568aabc7e0c11b3e1503eb6f.zip
Notes
Diffstat (limited to 'x11/electricsheep/Makefile')
-rw-r--r--x11/electricsheep/Makefile40
1 files changed, 40 insertions, 0 deletions
diff --git a/x11/electricsheep/Makefile b/x11/electricsheep/Makefile
new file mode 100644
index 000000000000..b6f749042652
--- /dev/null
+++ b/x11/electricsheep/Makefile
@@ -0,0 +1,40 @@
+# New ports collection makefile for: electricsheep
+# Date created: 11 Feb 2002
+# Whom: David Yeske <dyeske@yahoo.com>
+#
+# $FreeBSD$
+#
+
+PORTNAME= electricsheep
+PORTVERSION= 2.1
+CATEGORIES= x11
+MASTER_SITES= http://www-2.cs.cmu.edu/~spot/cache/
+
+MAINTAINER= dyeske@yahoo.com
+
+LIB_DEPENDS= jpeg:${PORTSDIR}/graphics/jpeg
+RUN_DEPENDS= xloadimage:${PORTSDIR}/x11/xloadimage \
+ xsetbg:${PORTSDIR}/graphics/xli \
+ curl:${PORTSDIR}/ftp/curl
+
+USE_X_PREFIX= yes
+GNU_CONFIGURE= yes
+
+pre-patch:
+ @${PERL} -pi -e 's|/usr/include/X11|${X11BASE}/include|g; \
+ s|/usr/lib/libjpeg.so.62|${LOCALBASE}/lib/libjpeg.so|g;' \
+ ${WRKSRC}/video_out/Makefile
+
+post-patch:
+ @${PERL} -pi -e 's|/usr/local/share|${PREFIX}/share/electricsheep|g;' \
+ ${WRKSRC}/electricsheep.c
+
+do-install:
+ ${INSTALL_PROGRAM} ${WRKSRC}/electricsheep ${PREFIX}/bin
+ ${INSTALL_PROGRAM} ${WRKSRC}/flame/anim-flame ${PREFIX}/bin
+ ${INSTALL_PROGRAM} ${WRKSRC}/flame/pick-flame ${PREFIX}/bin
+ ${INSTALL_PROGRAM} ${WRKSRC}/video_out/mpeg_play ${PREFIX}/bin/mpeg-loop
+ ${INSTALL} -d -m 0755 ${PREFIX}/share/electricsheep
+ ${INSTALL_DATA} ${WRKSRC}/*.tif ${PREFIX}/share/electricsheep
+
+.include <bsd.port.mk>