aboutsummaryrefslogtreecommitdiff
path: root/x11/erun/Makefile
diff options
context:
space:
mode:
authorKirill Ponomarev <krion@FreeBSD.org>2003-12-09 20:20:44 +0000
committerKirill Ponomarev <krion@FreeBSD.org>2003-12-09 20:20:44 +0000
commit89b3d628cdb5b15de322fa24b66e03b29286bea9 (patch)
treec7549512ed44d30a46b9b62b43a706cd0356015e /x11/erun/Makefile
parent4a268837eeb15870d54d6e81676c55ed6785f179 (diff)
Notes
Diffstat (limited to 'x11/erun/Makefile')
-rw-r--r--x11/erun/Makefile11
1 files changed, 10 insertions, 1 deletions
diff --git a/x11/erun/Makefile b/x11/erun/Makefile
index a08fdb006863..292be6e5bd99 100644
--- a/x11/erun/Makefile
+++ b/x11/erun/Makefile
@@ -19,6 +19,15 @@ LIB_DEPENDS= epplet.1:${PORTSDIR}/x11-wm/libepplet
WRKSRC= ${WRKDIR}/${PORTNAME}
USE_X_PREFIX= yes
-USE_GNOME= imlib
+
+CPPFLAGS= -I${X11BASE}/include ${PTHREAD_CFLAGS}
+LDFLAGS= -L${X11BASE}/lib -lepplet ${PTHREAD_LIBS}
+
+do-build:
+ cd ${WRKSRC} && ${CC} ${CFLAGS} ${CPPFLAGS} -o ${PORTNAME}.epplet \
+ ${PORTNAME}.c ${LDFLAGS}
+
+do-install:
+ ${INSTALL_PROGRAM} ${WRKSRC}/${PORTNAME}.epplet ${PREFIX}/bin
.include <bsd.port.mk>