aboutsummaryrefslogtreecommitdiff
path: root/x11/eterm
diff options
context:
space:
mode:
authorJimmy Olgeni <olgeni@FreeBSD.org>2001-02-17 22:28:10 +0000
committerJimmy Olgeni <olgeni@FreeBSD.org>2001-02-17 22:28:10 +0000
commitb91acc0bddc0d734b1e2b7ea316b436190755023 (patch)
tree8ae12abbafa7b872c71ca0a99e8cbac62637389e /x11/eterm
parent9937c7f036f476a572a778bc1611f7b9efd8de0e (diff)
downloadports-b91acc0bddc0d734b1e2b7ea316b436190755023.tar.gz
ports-b91acc0bddc0d734b1e2b7ea316b436190755023.zip
Notes
Diffstat (limited to 'x11/eterm')
-rw-r--r--x11/eterm/Makefile23
-rw-r--r--x11/eterm/distinfo2
-rw-r--r--x11/eterm/files/extra-patch-kanji9
-rw-r--r--x11/eterm/files/patch-ac22
-rw-r--r--x11/eterm/files/patch-af66
-rw-r--r--x11/eterm/files/patch-ag11
-rw-r--r--x11/eterm/files/patch-ah11
-rw-r--r--x11/eterm/files/patch-ai35
-rw-r--r--x11/eterm/files/patch-aj11
-rw-r--r--x11/eterm/files/patch-libmej:Makefile.in11
-rw-r--r--x11/eterm/files/patch-sec127
-rw-r--r--x11/eterm/files/patch-src:Makefile.in11
-rw-r--r--x11/eterm/files/patch-src:command.c21
-rw-r--r--x11/eterm/files/patch-src:startup.c11
-rw-r--r--x11/eterm/files/patch-themes:Makefile.in10
-rw-r--r--x11/eterm/pkg-descr3
-rw-r--r--x11/eterm/pkg-plist86
17 files changed, 136 insertions, 234 deletions
diff --git a/x11/eterm/Makefile b/x11/eterm/Makefile
index eadfaacb5179..ac5f16934bd8 100644
--- a/x11/eterm/Makefile
+++ b/x11/eterm/Makefile
@@ -6,10 +6,10 @@
#
PORTNAME= eterm
-PORTVERSION= 0.8.10
+PORTVERSION= 0.9
CATEGORIES= x11
MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
-MASTER_SITE_SUBDIR= eterm
+MASTER_SITE_SUBDIR= eterm
DISTNAME= Eterm-${PORTVERSION}
MAINTAINER= olgeni@FreeBSD.org
@@ -21,28 +21,21 @@ USE_X_PREFIX= yes
USE_IMLIB= yes
USE_LIBTOOL= yes
INSTALLS_SHLIB= yes
-CONFIGURE_ENV= LDFLAGS="-L${LOCALBASE}/lib"
+CONFIGURE_ARGS= --enable-trans=imlib --enable-utmp \
+ --enable-xim --with-theme-update
+CONFIGURE_ENV= LIBS="-lxpg4"
MAN1= Eterm.1
-.if ( defined(KANJI) )
-EXTRA_PATCHES= ${PATCHDIR}/extra-patch-kanji
-.endif
-
-# this is needed to remove leftover files from applied patches.
-pre-install:
-.for i in Eterm emacs irc mutt tn3270 trans
- @${RM} -f ${WRKSRC}/themes/$i/*.orig
-.endfor
-
post-install:
@${CHMOD} 4711 ${PREFIX}/bin/Eterm
-.ifndef NOPORTDOCS
+.if !defined(NOPORTDOCS)
@${MKDIR} ${PREFIX}/share/doc/Eterm
@${INSTALL_DATA} ${WRKSRC}/ReleaseNotes ${PREFIX}/share/doc/Eterm
+ @${INSTALL_DATA} ${WRKSRC}/doc/Eterm.1.html ${PREFIX}/share/doc/Eterm
+ @${INSTALL_DATA} ${WRKSRC}/doc/Eterm_reference.html ${PREFIX}/share/doc/Eterm
@${INSTALL_DATA} ${WRKSRC}/doc/Eterm.tcap ${PREFIX}/share/doc/Eterm
@${INSTALL_DATA} ${WRKSRC}/doc/Eterm.ti ${PREFIX}/share/doc/Eterm
- @${INSTALL_DATA} ${WRKSRC}/doc/Eterm.1.html ${PREFIX}/share/doc/Eterm
.endif
.include <bsd.port.mk>
diff --git a/x11/eterm/distinfo b/x11/eterm/distinfo
index 5d2ad791014d..8a70d6d77521 100644
--- a/x11/eterm/distinfo
+++ b/x11/eterm/distinfo
@@ -1 +1 @@
-MD5 (Eterm-0.8.10.tar.gz) = 44b0b498d8186205d0898b266643fbf1
+MD5 (Eterm-0.9.tar.gz) = 0da2a2c9a5d9e9f698d7f89ccb2f9f38
diff --git a/x11/eterm/files/extra-patch-kanji b/x11/eterm/files/extra-patch-kanji
deleted file mode 100644
index 9542bc1f8da9..000000000000
--- a/x11/eterm/files/extra-patch-kanji
+++ /dev/null
@@ -1,9 +0,0 @@
---- config.h.in.orig Mon Oct 26 19:34:07 1998
-+++ config.h.in Mon Oct 26 19:34:37 1998
-@@ -206,3 +206,6 @@
-
- /* Define if you have the Kenny library (-lKenny). */
- #undef HAVE_LIBKENNY
-+
-+/* Define if you want the KANJI mode enable. */
-+#define KANJI
diff --git a/x11/eterm/files/patch-ac b/x11/eterm/files/patch-ac
deleted file mode 100644
index e21ee51e5acf..000000000000
--- a/x11/eterm/files/patch-ac
+++ /dev/null
@@ -1,22 +0,0 @@
---- src/Makefile.in.orig Fri Nov 5 13:03:54 1999
-+++ src/Makefile.in Sat Jan 8 19:27:47 2000
-@@ -106,7 +106,7 @@
- libEterm_la_SOURCES = activeconfig.c activeeterm.c activetags.c command.c graphics.c grkelot.c menubar.c misc.c netdisp.c options.c pixmap.c screen.c scrollbar.c system.c threads.c utmp.c
-
- libEterm_la_DEPENDENCIES = $(DIST_ROOT)/libmej/libmej.la feature.h
--libEterm_la_LDFLAGS = -release $(VERSION)
-+libEterm_la_LDFLAGS = -version-info 8:8:8
-
- bin_PROGRAMS = Eterm
- Eterm_SOURCES = main.c
-@@ -117,6 +117,10 @@
- LDADD = $(DIST_ROOT)/libmej/libmej.la -L$(libdir) -L$(prefix)/lib $(LIBS) $(GRLIBS) $(X_LIBS)
-
- EXTRA_DIST = activeconfig.h activeeterm.h activetags.h command.h debug.h eterm_imlib.h eterm_utmp.h feature.h.in graphics.h grkelot.h grx.h main.h menubar.h misc.h options.h pixmap.h profile.h screen.h scrollbar.h system.h threads.h graphics/Makefile.am graphics/Makefile.in graphics/README graphics/data graphics/grxlib.c graphics/grxlib.h graphics/qplot.c Eterm.xpm
-+
-+ifeq ($(PORTOBJFORMAT),elf)
-+LDFLAGS+=-Wl,-rpath,$(X11BASE)/lib
-+endif
-
- mkinstalldirs = $(SHELL) $(top_srcdir)/mkinstalldirs
- CONFIG_HEADER = ../config.h
diff --git a/x11/eterm/files/patch-af b/x11/eterm/files/patch-af
deleted file mode 100644
index c72092e442db..000000000000
--- a/x11/eterm/files/patch-af
+++ /dev/null
@@ -1,66 +0,0 @@
---- themes/Eterm/MAIN.in.orig Sun Jun 13 00:26:37 1999
-+++ themes/Eterm/MAIN.in Sun Jun 13 00:28:40 1999
-@@ -94,7 +94,7 @@
- # scale 100%, 0 to tile, any other number specifies W/H in pixels
- begin pixmaps
- background %random(`cat pixmaps.list 2>/dev/null`)
-- path "./pix/:~/.Eterm/:~/.Eterm/themes/Eterm/pix:~/.Eterm/pix/:@DATADIR@/Eterm/pix/"
-+ path "./pix/:~/.Eterm/:~/.Eterm/themes/Eterm/pix:~/.Eterm/pix/:@DATADIR@/Eterm/pix/:@DATADIR@/Eterm/bg/scale/:@DATADIR@/Eterm/bg/tile/"
-
- # Support for these is forthcoming
- # scroll_up -1 -1 ~/.Eterm/up_arrow.ppm
---- themes/emacs/MAIN.in.orig Sun Jun 13 00:26:37 1999
-+++ themes/emacs/MAIN.in Sun Jun 13 00:29:06 1999
-@@ -94,7 +94,7 @@
- # scale 100%, 0 to tile, any other number specifies W/H in pixels
- begin pixmaps
- background %random(`cat pixmaps.list 2>/dev/null`)
-- path "./pix/:~/.Eterm/:~/.Eterm/themes/Eterm/pix:~/.Eterm/pix/:@DATADIR@/Eterm/pix/"
-+ path "./pix/:~/.Eterm/:~/.Eterm/themes/Eterm/pix:~/.Eterm/pix/:@DATADIR@/Eterm/pix/:@DATADIR@/Eterm/bg/scale/:@DATADIR@/Eterm/bg/tile/"
-
- # Support for these is forthcoming
- # scroll_up -1 -1 ~/.Eterm/up_arrow.ppm
---- themes/irc/MAIN.in.orig Sun Jun 13 00:26:37 1999
-+++ themes/irc/MAIN.in Sun Jun 13 00:29:24 1999
-@@ -94,7 +94,7 @@
- # scale 100%, 0 to tile, any other number specifies W/H in pixels
- begin pixmaps
- background %random(`cat pixmaps.list 2>/dev/null`)
-- path "./pix/:~/.Eterm/:~/.Eterm/themes/Eterm/pix:~/.Eterm/pix/:@DATADIR@/Eterm/pix/"
-+ path "./pix/:~/.Eterm/:~/.Eterm/themes/Eterm/pix:~/.Eterm/pix/:@DATADIR@/Eterm/pix/:@DATADIR@/Eterm/bg/scale/:@DATADIR@/Eterm/bg/tile/"
-
- # Support for these is forthcoming
- # scroll_up -1 -1 ~/.Eterm/up_arrow.ppm
---- themes/mutt/MAIN.in.orig Sun Jun 13 00:26:37 1999
-+++ themes/mutt/MAIN.in Sun Jun 13 00:30:14 1999
-@@ -94,7 +94,7 @@
- # scale 100%, 0 to tile, any other number specifies W/H in pixels
- begin pixmaps
- background %random(`cat pixmaps.list 2>/dev/null`)
-- path "~/.Eterm/:~/.Eterm/themes/Eterm/pix:~/.Eterm/pix/:@DATADIR@/Eterm/pix/"
-+ path "./pix/:~/.Eterm/:~/.Eterm/themes/Eterm/pix:~/.Eterm/pix/:@DATADIR@/Eterm/pix/:@DATADIR@/Eterm/bg/scale/:@DATADIR@/Eterm/bg/tile/"
-
- # Support for these is forthcoming
- # scroll_up -1 -1 ~/.Eterm/up_arrow.ppm
---- themes/tn3270/MAIN.in.orig Sun Jun 13 00:26:37 1999
-+++ themes/tn3270/MAIN.in Sun Jun 13 00:30:36 1999
-@@ -94,7 +94,7 @@
- # scale 100%, 0 to tile, any other number specifies W/H in pixels
- begin pixmaps
- background %random(`cat pixmaps.list 2>/dev/null`)
-- path "~/.Eterm/:~/.Eterm/themes/Eterm/pix:~/.Eterm/pix/:@DATADIR@/Eterm/pix/"
-+ path "./pix/:~/.Eterm/:~/.Eterm/themes/Eterm/pix:~/.Eterm/pix/:@DATADIR@/Eterm/pix/:@DATADIR@/Eterm/bg/scale/:@DATADIR@/Eterm/bg/tile/"
-
- # Support for these is forthcoming
- # scroll_up -1 -1 ~/.Eterm/up_arrow.ppm
---- themes/trans/MAIN.in.orig Sun Jun 13 00:26:37 1999
-+++ themes/trans/MAIN.in Sun Jun 13 00:33:48 1999
-@@ -96,7 +96,7 @@
- # scale 100%, 0 to tile, any other number specifies W/H in pixels
- begin pixmaps
- # background %random(`cat pixmaps.list 2>/dev/null`)
--# path "./pix/:~/.Eterm/:~/.Eterm/themes/Eterm/pix:~/.Eterm/pix/:@DATADIR@/Eterm/pix/"
-+# path "./pix/:~/.Eterm/:~/.Eterm/themes/Eterm/pix:~/.Eterm/pix/:@DATADIR@/Eterm/pix/:@DATADIR@/Eterm/bg/scale/:@DATADIR@/Eterm/bg/tile/"
-
- # Support for these is forthcoming
- # scroll_up -1 -1 ~/.Eterm/up_arrow.ppm
diff --git a/x11/eterm/files/patch-ag b/x11/eterm/files/patch-ag
deleted file mode 100644
index 13ba71fbac01..000000000000
--- a/x11/eterm/files/patch-ag
+++ /dev/null
@@ -1,11 +0,0 @@
---- src/feature.h.in.orig Thu Nov 25 20:50:37 1999
-+++ src/feature.h.in Thu Nov 25 20:50:49 1999
-@@ -380,7 +380,7 @@
- * may seem to be owned by root. But if you define this and don't have them,
- * the utmp and tty stuff could break. Do some testing. DO NOT get this one
- * wrong! */
--/* #define HAVE_SAVED_UIDS */
-+#define HAVE_SAVED_UIDS
-
- /* Use getgrnam() to determine the group id of TTY_GRP_NAME, and chgrp tty
- * device files to that group. This should be ok on SVR4 and Linux systems
diff --git a/x11/eterm/files/patch-ah b/x11/eterm/files/patch-ah
deleted file mode 100644
index 38ee5f054b99..000000000000
--- a/x11/eterm/files/patch-ah
+++ /dev/null
@@ -1,11 +0,0 @@
---- src/main.c.orig Thu Nov 25 20:51:39 1999
-+++ src/main.c Thu Nov 25 20:53:30 1999
-@@ -26,6 +26,8 @@
-
- static const char cvs_ident[] = "$Id: main.c,v 1.35 1999/04/20 00:46:37 mej Exp $";
-
-+#define NEED_LINUX_HACK 1
-+
- /* includes */
- #include "main.h"
- #ifdef USE_ACTIVE_TAGS
diff --git a/x11/eterm/files/patch-ai b/x11/eterm/files/patch-ai
deleted file mode 100644
index 3610a6bf9761..000000000000
--- a/x11/eterm/files/patch-ai
+++ /dev/null
@@ -1,35 +0,0 @@
-*** src/command.c.old Thu Dec 23 01:39:37 1999
---- src/command.c Thu Dec 23 01:42:00 1999
-***************
-*** 40,45 ****
---- 40,47 ----
- #include "feature.h"
- #include "config.h"
-
-+ #undef HAVE_SAVED_UIDS
-+
- /* System Headers */
- #include <stdio.h>
- #include <stdlib.h>
-***************
-*** 120,125 ****
---- 122,128 ----
- #endif
- #ifdef HAVE_TERMIOS_H
- # include <termios.h>
-+ # include <sys/ttydefaults.h>
- #else
- # include <sgtty.h>
- #endif
-***************
-*** 2100,2105 ****
---- 2103,2111 ----
- # endif
- # if VTIME != VEOL
- tio->c_cc[VTIME] = 0;
-+ # endif
-+ # ifdef VSTATUS
-+ tio->c_cc[VSTATUS] = CSTATUS;
- # endif
-
- /* input modes */
diff --git a/x11/eterm/files/patch-aj b/x11/eterm/files/patch-aj
deleted file mode 100644
index 8313be6fe80b..000000000000
--- a/x11/eterm/files/patch-aj
+++ /dev/null
@@ -1,11 +0,0 @@
---- libmej/Makefile.in.orig Sat Jan 8 19:29:13 2000
-+++ libmej/Makefile.in Sat Jan 8 19:29:50 2000
-@@ -107,7 +107,7 @@
-
- INCLUDES = -I. -I$(top_srcdir) -I$(top_srcdir)/src -I.. -I$(includedir) -I$(prefix)/include $(X_CFLAGS)
-
--libmej_la_LDFLAGS = -release $(VERSION)
-+libmej_la_LDFLAGS = -version-info 8:8:8
-
- EXTRA_DIST = debug.h global.h mem.h strings.h strptime.h strptime.c
- mkinstalldirs = $(SHELL) $(top_srcdir)/mkinstalldirs
diff --git a/x11/eterm/files/patch-libmej:Makefile.in b/x11/eterm/files/patch-libmej:Makefile.in
new file mode 100644
index 000000000000..d76485d51e06
--- /dev/null
+++ b/x11/eterm/files/patch-libmej:Makefile.in
@@ -0,0 +1,11 @@
+--- libmej/Makefile.in.orig Mon Feb 7 21:52:12 2000
++++ libmej/Makefile.in Mon Feb 7 21:52:44 2000
+@@ -120,7 +120,7 @@
+
+ INCLUDES = -I. -I.. -I$(includedir) -I$(prefix)/include
+
+-libmej_la_LDFLAGS = -release $(VERSION)
++libmej_la_LDFLAGS = -version-info 9:9:9
+
+ EXTRA_DIST = debug.h global.h mem.h strings.h strptime.h strptime.c
+ mkinstalldirs = $(SHELL) $(top_srcdir)/mkinstalldirs
diff --git a/x11/eterm/files/patch-sec1 b/x11/eterm/files/patch-sec1
deleted file mode 100644
index 3998d625a96d..000000000000
--- a/x11/eterm/files/patch-sec1
+++ /dev/null
@@ -1,27 +0,0 @@
-Index: src/command.c
-===================================================================
-RCS file: /cvs/enlightenment/Eterm/src/command.c,v
-retrieving revision 1.1.1.1.2.7
-diff -u -r1.1.1.1.2.7 command.c
---- src/command.c 1999/11/02 16:34:35 1.1.1.1.2.7
-+++ src/command.c 2000/06/02 02:06:56
-@@ -4694,6 +4694,9 @@
- return; /* Make sure there are 2 args left */
- y = args[++i];
- x = args[++i];
-+ if (x > scr->width || y > scr->height) {
-+ return;
-+ }
- XResizeWindow(Xdisplay, TermWin.parent, x, y);
- break;
- case 5:
-@@ -4713,6 +4716,9 @@
- return; /* Make sure there are 2 args left */
- y = args[++i];
- x = args[++i];
-+ if (x > (scr->width / TermWin.fwidth) || y > (scr->height / TermWin.fheight)) {
-+ return;
-+ }
- XResizeWindow(Xdisplay, TermWin.parent,
- Width2Pixel(x) + 2 * TermWin.internalBorder + (scrollbar_visible()? scrollbar_total_width() : 0),
- Height2Pixel(y) + 2 * TermWin.internalBorder + (menubar_visible()? menuBar_TotalHeight() : 0));
diff --git a/x11/eterm/files/patch-src:Makefile.in b/x11/eterm/files/patch-src:Makefile.in
new file mode 100644
index 000000000000..4b361a26877e
--- /dev/null
+++ b/x11/eterm/files/patch-src:Makefile.in
@@ -0,0 +1,11 @@
+--- src/Makefile.in.orig Mon Feb 7 21:50:25 2000
++++ src/Makefile.in Mon Feb 7 21:51:29 2000
+@@ -120,7 +120,7 @@
+
+
+ libEterm_la_DEPENDENCIES = $(top_builddir)/libmej/libmej.la feature.h
+-libEterm_la_LDFLAGS = -release $(VERSION)
++libEterm_la_LDFLAGS = -version-info 9:9:9
+
+ bin_PROGRAMS = Eterm
+ Eterm_SOURCES = main.c
diff --git a/x11/eterm/files/patch-src:command.c b/x11/eterm/files/patch-src:command.c
new file mode 100644
index 000000000000..c75bc1d31398
--- /dev/null
+++ b/x11/eterm/files/patch-src:command.c
@@ -0,0 +1,21 @@
+--- src/command.c.orig Mon Feb 7 22:20:41 2000
++++ src/command.c Mon Feb 7 22:22:16 2000
+@@ -40,6 +40,8 @@
+ #include "config.h"
+ #include "feature.h"
+
++#undef HAVE_SAVED_UIDS
++
+ /* System Headers */
+ #include <stdio.h>
+ #include <stdlib.h>
+@@ -1560,6 +1562,9 @@
+ # endif
+ # if VTIME != VEOL
+ tio->c_cc[VTIME] = 0;
++# endif
++# ifdef VSTATUS
++ tio->c_cc[VSTATUS] = CSTATUS;
+ # endif
+
+ /* input modes */
diff --git a/x11/eterm/files/patch-src:startup.c b/x11/eterm/files/patch-src:startup.c
new file mode 100644
index 000000000000..1096a87aa40c
--- /dev/null
+++ b/x11/eterm/files/patch-src:startup.c
@@ -0,0 +1,11 @@
+--- src/startup.c.orig Mon Feb 7 22:24:54 2000
++++ src/startup.c Mon Feb 7 22:24:57 2000
+@@ -29,6 +29,8 @@
+ #include "config.h"
+ #include "feature.h"
+
++#define NEED_LINUX_HACK 1
++
+ #include <stdio.h>
+ #include <stdlib.h>
+ #include <string.h>
diff --git a/x11/eterm/files/patch-themes:Makefile.in b/x11/eterm/files/patch-themes:Makefile.in
new file mode 100644
index 000000000000..df28d12363df
--- /dev/null
+++ b/x11/eterm/files/patch-themes:Makefile.in
@@ -0,0 +1,10 @@
+--- themes/Makefile.in.orig Wed Feb 2 05:36:43 2000
++++ themes/Makefile.in Wed Feb 9 03:46:59 2000
+@@ -239,6 +239,7 @@
+ $(CHMOD) 755 $(DESTDIR)$(pkgdatadir)/themes/$$i ; \
+ $(CHMOD) 644 $(DESTDIR)$(pkgdatadir)/themes/$$i/???* ; \
+ rm -f $(DESTDIR)$(pkgdatadir)/themes/$$i/theme.cfg.in ; \
++ rm -f $(DESTDIR)$(pkgdatadir)/themes/$$i/theme.cfg.in.orig ; \
+ else \
+ echo "ALERT! Not overwriting $$i theme in $(DESTDIR)$(pkgdatadir)/themes. You will need to update this theme manually." ; \
+ fi ; \
diff --git a/x11/eterm/pkg-descr b/x11/eterm/pkg-descr
index 5db6d1b0f4a6..79f9cc550713 100644
--- a/x11/eterm/pkg-descr
+++ b/x11/eterm/pkg-descr
@@ -5,9 +5,6 @@ user. It is designed to look good and work well, but takes a
feature-rich approach rather than one of minimalism while still
maintaining speed and efficiency.
-If you want the KANJI feature enable, use
-make -DKANJI install
-
WWW: http://www.eterm.org/
- Murray Stokely
diff --git a/x11/eterm/pkg-plist b/x11/eterm/pkg-plist
index 233772ea3b63..f56fd02b387d 100644
--- a/x11/eterm/pkg-plist
+++ b/x11/eterm/pkg-plist
@@ -1,56 +1,96 @@
bin/Esetroot
bin/Etbg
-bin/Etcolors.sh
+bin/Etcolors
bin/Eterm
@exec chmod 4711 %D/bin/Eterm
-bin/Etmenu.sh
+bin/Ettable
+bin/Etwinop
lib/libEterm.a
lib/libEterm.so
-lib/libEterm.so.8
+lib/libEterm.so.9
lib/libmej.a
lib/libmej.so
-lib/libmej.so.8
-share/Eterm/pix/014.png
-share/Eterm/pix/40.png
-share/Eterm/pix/6.png
+lib/libmej.so.9
+share/Eterm/pix/014.jpg
+share/Eterm/pix/40.jpg
share/Eterm/pix/backwave.jpg
-share/Eterm/pix/circuit.png
+share/Eterm/pix/bar_horizontal_1.png
+share/Eterm/pix/bar_horizontal_2.png
+share/Eterm/pix/bar_horizontal_3.png
+share/Eterm/pix/bar_vertical_1.png
+share/Eterm/pix/bar_vertical_2.png
+share/Eterm/pix/bar_vertical_3.png
+share/Eterm/pix/blackstone.jpg
+share/Eterm/pix/button_arrow_down_1.png
+share/Eterm/pix/button_arrow_down_2.png
+share/Eterm/pix/button_arrow_down_3.png
+share/Eterm/pix/button_arrow_up_1.png
+share/Eterm/pix/button_arrow_up_2.png
+share/Eterm/pix/button_arrow_up_3.png
+share/Eterm/pix/circuit.jpg
share/Eterm/pix/fourthday.jpg
share/Eterm/pix/gaia.jpg
share/Eterm/pix/galleon.jpg
+share/Eterm/pix/menu1.png
+share/Eterm/pix/menu2.png
+share/Eterm/pix/menu3.png
share/Eterm/pix/nebula.jpg
share/Eterm/pix/night_of_the_dragon.jpg
share/Eterm/pix/pixmaps.list
-share/Eterm/themes/Eterm/Eterm.menu
-share/Eterm/themes/Eterm/MAIN
+share/Eterm/pix/scaled-pixmaps.list
+share/Eterm/pix/tiled-pixmaps.list
+share/Eterm/themes/Eterm/menus.cfg
share/Eterm/themes/Eterm/pixmaps.list
-share/Eterm/themes/chooser/MAIN
-share/Eterm/themes/chooser/chooser.menu
+share/Eterm/themes/Eterm/scaled-pixmaps.list
+share/Eterm/themes/Eterm/theme.cfg
+share/Eterm/themes/Eterm/tiled-pixmaps.list
+share/Eterm/themes/auto/menus.cfg
+share/Eterm/themes/auto/pixmaps.list
+share/Eterm/themes/auto/scaled-pixmaps.list
+share/Eterm/themes/auto/theme.cfg
+share/Eterm/themes/auto/tiled-pixmaps.list
+share/Eterm/themes/cEterm/menus.cfg
+share/Eterm/themes/cEterm/pixmaps.list
+share/Eterm/themes/cEterm/scaled-pixmaps.list
+share/Eterm/themes/cEterm/theme.cfg
+share/Eterm/themes/cEterm/tiled-pixmaps.list
+share/Eterm/themes/chooser/menus.cfg
share/Eterm/themes/chooser/pixmaps.list
-share/Eterm/themes/emacs/MAIN
-share/Eterm/themes/emacs/emacs.menu
+share/Eterm/themes/chooser/scaled-pixmaps.list
+share/Eterm/themes/chooser/theme.cfg
+share/Eterm/themes/chooser/tiled-pixmaps.list
+share/Eterm/themes/emacs/menus.cfg
share/Eterm/themes/emacs/pixmaps.list
-share/Eterm/themes/irc/MAIN
-share/Eterm/themes/irc/irc.menu
+share/Eterm/themes/emacs/scaled-pixmaps.list
+share/Eterm/themes/emacs/theme.cfg
+share/Eterm/themes/emacs/tiled-pixmaps.list
+share/Eterm/themes/irc/menus.cfg
share/Eterm/themes/irc/pixmaps.list
-share/Eterm/themes/mutt/MAIN
-share/Eterm/themes/mutt/mutt.menu
+share/Eterm/themes/irc/scaled-pixmaps.list
+share/Eterm/themes/irc/theme.cfg
+share/Eterm/themes/irc/tiled-pixmaps.list
+share/Eterm/themes/mutt/menus.cfg
share/Eterm/themes/mutt/pixmaps.list
-share/Eterm/themes/tn3270/MAIN
-share/Eterm/themes/tn3270/pixmaps.list
-share/Eterm/themes/trans/MAIN
+share/Eterm/themes/mutt/scaled-pixmaps.list
+share/Eterm/themes/mutt/theme.cfg
+share/Eterm/themes/mutt/tiled-pixmaps.list
+share/Eterm/themes/trans/menus.cfg
share/Eterm/themes/trans/pixmaps.list
-share/Eterm/themes/trans/trans.menu
+share/Eterm/themes/trans/scaled-pixmaps.list
+share/Eterm/themes/trans/theme.cfg
+share/Eterm/themes/trans/tiled-pixmaps.list
%%PORTDOCS%%share/doc/Eterm/Eterm.1.html
%%PORTDOCS%%share/doc/Eterm/Eterm.tcap
%%PORTDOCS%%share/doc/Eterm/Eterm.ti
+%%PORTDOCS%%share/doc/Eterm/Eterm_reference.html
%%PORTDOCS%%share/doc/Eterm/ReleaseNotes
@dirrm share/Eterm/themes/trans
-@dirrm share/Eterm/themes/tn3270
@dirrm share/Eterm/themes/mutt
@dirrm share/Eterm/themes/irc
@dirrm share/Eterm/themes/emacs
@dirrm share/Eterm/themes/chooser
+@dirrm share/Eterm/themes/cEterm
+@dirrm share/Eterm/themes/auto
@dirrm share/Eterm/themes/Eterm
@dirrm share/Eterm/pix
@dirrm share/Eterm/themes