aboutsummaryrefslogtreecommitdiff
path: root/x11/fbpanel/Makefile
diff options
context:
space:
mode:
authorBeech Rintoul <beech@FreeBSD.org>2010-11-22 11:35:55 +0000
committerBeech Rintoul <beech@FreeBSD.org>2010-11-22 11:35:55 +0000
commit4c8a065e7f12122ecd7c721a647754b79cb856ed (patch)
tree60a191c2b65d0233c93a5e5c8fc14cbce0d3703e /x11/fbpanel/Makefile
parent7e83a8b75b3753ae4bee40dc9f95f030180600c6 (diff)
downloadports-4c8a065e7f12122ecd7c721a647754b79cb856ed.tar.gz
ports-4c8a065e7f12122ecd7c721a647754b79cb856ed.zip
Notes
Diffstat (limited to 'x11/fbpanel/Makefile')
-rw-r--r--x11/fbpanel/Makefile20
1 files changed, 14 insertions, 6 deletions
diff --git a/x11/fbpanel/Makefile b/x11/fbpanel/Makefile
index 064c06cbfb89..8cf9eb54a3bb 100644
--- a/x11/fbpanel/Makefile
+++ b/x11/fbpanel/Makefile
@@ -6,25 +6,33 @@
#
PORTNAME= fbpanel
-PORTVERSION= 4.12
-PORTREVISION= 6
+PORTVERSION= 6.1
CATEGORIES= x11
MASTER_SITES= SF
-EXTRACT_SUFX= .tgz
+EXTRACT_SUFX= .tbz2
MAINTAINER= corky1951@comcast.net
COMMENT= Desktop panel that includes a taskbar, pager, launchbar and more
+BUILD_DEPENDS= bash:${PORTSDIR}/shells/bash
+
USE_XORG= x11 xmu xpm
USE_GNOME= gtk20
HAS_CONFIGURE= yes
-CONFIGURE_ARGS+= --prefix=${PREFIX}
USE_GMAKE= yes
+#CONFIGURE_ENV+= PREFIX=${PREFIX}
+
MAN1= fbpanel.1
-MANCOMPRESSED= yes
+MANCOMPRESSED= no
post-patch:
- @${REINPLACE_CMD} -e 's|share/man|man|g' ${WRKSRC}/man/Makefile
+ @${REINPLACE_CMD} -e 's|/bin/bash|${LOCALBASE}/bin/bash|' ${WRKSRC}/configure
+ @${REINPLACE_CMD} -e 's|/bin/bash|${LOCALBASE}/bin/bash|' ${WRKSRC}/scripts/rfs-pkg-config
+ @${REINPLACE_CMD} -e 's|/bin/bash|${LOCALBASE}/bin/bash|' ${WRKSRC}/scripts/install.sh
+ @${REINPLACE_CMD} -e 's|@DATADIR@|${DATADIR}|g' ${WRKSRC}/data/man/${PORTNAME}.1.in
+
+post-install:
+ @${INSTALL_MAN} ${WRKSRC}/data/man/${PORTNAME}.1 ${MANPREFIX}/man/man1
.include <bsd.port.mk>