aboutsummaryrefslogtreecommitdiff
path: root/x11/fbpanel
diff options
context:
space:
mode:
authorClive Lin <clive@FreeBSD.org>2004-12-15 06:34:35 +0000
committerClive Lin <clive@FreeBSD.org>2004-12-15 06:34:35 +0000
commit487941771b7330f14c8ae4e8460c2811b2422c34 (patch)
treefef06ca76bdd481a67bb82a4c7dbc21ba6478ee4 /x11/fbpanel
parent5fa4147021d793411d4dfe3a0e0caca3bc24f4be (diff)
downloadports-487941771b7330f14c8ae4e8460c2811b2422c34.tar.gz
ports-487941771b7330f14c8ae4e8460c2811b2422c34.zip
Notes
Diffstat (limited to 'x11/fbpanel')
-rw-r--r--x11/fbpanel/Makefile10
-rw-r--r--x11/fbpanel/distinfo4
-rw-r--r--x11/fbpanel/files/patch-Makefile.common16
-rw-r--r--x11/fbpanel/files/patch-plugins::Makefile11
-rw-r--r--x11/fbpanel/pkg-message1
-rw-r--r--x11/fbpanel/pkg-plist42
6 files changed, 58 insertions, 26 deletions
diff --git a/x11/fbpanel/Makefile b/x11/fbpanel/Makefile
index 47f4ab4435cb..31a83440d0f8 100644
--- a/x11/fbpanel/Makefile
+++ b/x11/fbpanel/Makefile
@@ -6,8 +6,7 @@
#
PORTNAME= fbpanel
-PORTVERSION= 3.12
-PORTREVISION= 1
+PORTVERSION= 3.18
CATEGORIES= x11
MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
MASTER_SITE_SUBDIR= ${PORTNAME}
@@ -19,10 +18,15 @@ COMMENT= A desktop panel that includes a taskbar, pager, launchbar and more
USE_X_PREFIX= yes
USE_GNOME= gtk20
HAS_CONFIGURE= yes
-CONFIGURE_ARGS= --prefix=${PREFIX}
+CONFIGURE_ARGS= --prefix=${PREFIX} --transparency
USE_GMAKE= yes
MAN1= fbpanel.1
MANCOMPRESSED= yes
+post-install:
+ @${ECHO_MSG} ""
+ @${CAT} ${PKGMESSAGE}
+ @${ECHO_MSG} ""
+
.include <bsd.port.mk>
diff --git a/x11/fbpanel/distinfo b/x11/fbpanel/distinfo
index 724cf1ada4ca..f7be3502e0f4 100644
--- a/x11/fbpanel/distinfo
+++ b/x11/fbpanel/distinfo
@@ -1,2 +1,2 @@
-MD5 (fbpanel-3.12.tgz) = 73e4f4d2062c6bca39958166ea7403b5
-SIZE (fbpanel-3.12.tgz) = 73021
+MD5 (fbpanel-3.18.tgz) = 4dcbfb690e230ccb12a2c9cef71b0ef8
+SIZE (fbpanel-3.18.tgz) = 84037
diff --git a/x11/fbpanel/files/patch-Makefile.common b/x11/fbpanel/files/patch-Makefile.common
index 94b33a3a4102..3625cbc91377 100644
--- a/x11/fbpanel/files/patch-Makefile.common
+++ b/x11/fbpanel/files/patch-Makefile.common
@@ -1,14 +1,16 @@
---- Makefile.common.orig Sat Jun 26 14:00:42 2004
-+++ Makefile.common Sat Jun 26 14:03:02 2004
-@@ -15,10 +15,9 @@
+--- Makefile.common.orig Tue Dec 14 18:52:32 2004
++++ Makefile.common Tue Dec 14 18:53:15 2004
+@@ -15,12 +15,10 @@
endif
endif
-CC = gcc
+CC ?= gcc
LIBS = $(shell pkg-config --libs gtk+-2.0 gdk-pixbuf-2.0 gdk-pixbuf-xlib-2.0) -L/usr/X11R6/lib -lXmu
- INCS = $(shell pkg-config --cflags gtk+-2.0 gdk-pixbuf-2.0 gdk-pixbuf-xlib-2.0)
--CFLAGS = -O2 # overwriten by command line or env. variable
- CFLAGS += -Wall # always nice to have
+ INCS2 = $(shell pkg-config --cflags gtk+-2.0 gdk-pixbuf-2.0 gdk-pixbuf-xlib-2.0)
+ INCS := $(INCS2:-I%=-isystem%)
+-# first = may be overwriten by command line or env. variable
+-CFLAGS = -O2
+ # this one always applays
+ CFLAGS += -Wall
ifneq (,$(DEVEL))
- CFLAGS := -g -Wall
diff --git a/x11/fbpanel/files/patch-plugins::Makefile b/x11/fbpanel/files/patch-plugins::Makefile
new file mode 100644
index 000000000000..f475b4dca68c
--- /dev/null
+++ b/x11/fbpanel/files/patch-plugins::Makefile
@@ -0,0 +1,11 @@
+--- plugins/Makefile.orig Tue Dec 14 19:59:15 2004
++++ plugins/Makefile Tue Dec 14 19:59:23 2004
+@@ -7,7 +7,7 @@
+ INCS += -I../
+ SRC = image.c menu.c separator.c taskbar.c wincmd.c \
+ dclock.c launchbar.c pager.c space.c test.c \
+- icons.c cpu.c deskno.c
++ icons.c deskno.c
+
+ SOBJ = $(SRC:%.c=%.so)
+ OBJ = $(SRC:%.c=%.o)
diff --git a/x11/fbpanel/pkg-message b/x11/fbpanel/pkg-message
new file mode 100644
index 000000000000..224f0522d339
--- /dev/null
+++ b/x11/fbpanel/pkg-message
@@ -0,0 +1 @@
+Please note that the cpu plugin has not been built due to compatibility reasons.
diff --git a/x11/fbpanel/pkg-plist b/x11/fbpanel/pkg-plist
index 0f94d5ea6db8..3fcb73da4893 100644
--- a/x11/fbpanel/pkg-plist
+++ b/x11/fbpanel/pkg-plist
@@ -1,15 +1,29 @@
bin/fbpanel
-share/fbpanel/default
-share/fbpanel/pager
-share/fbpanel/images/Desktop2.png
-share/fbpanel/images/Editor.png
-share/fbpanel/images/Emacs.png
-share/fbpanel/images/GNOME-Terminal.png
-share/fbpanel/images/Menu.png
-share/fbpanel/images/Networking.png
-share/fbpanel/images/bottom-left.xpm
-share/fbpanel/images/bottom-right.xpm
-share/fbpanel/images/top-left.xpm
-share/fbpanel/images/top-right.xpm
-@dirrm share/fbpanel/images
-@dirrm share/fbpanel
+%%DATADIR%%/default
+%%DATADIR%%/images/Desktop2.png
+%%DATADIR%%/images/Editor.png
+%%DATADIR%%/images/Emacs.png
+%%DATADIR%%/images/GNOME-Terminal.png
+%%DATADIR%%/images/Menu.png
+%%DATADIR%%/images/Networking.png
+%%DATADIR%%/images/bottom-left.xpm
+%%DATADIR%%/images/bottom-right.xpm
+%%DATADIR%%/images/top-left.xpm
+%%DATADIR%%/images/top-right.xpm
+%%DATADIR%%/pager
+%%DATADIR%%/plugins/dclock.so
+%%DATADIR%%/plugins/deskno.so
+%%DATADIR%%/plugins/icons.so
+%%DATADIR%%/plugins/image.so
+%%DATADIR%%/plugins/launchbar.so
+%%DATADIR%%/plugins/menu.so
+%%DATADIR%%/plugins/pager.so
+%%DATADIR%%/plugins/separator.so
+%%DATADIR%%/plugins/space.so
+%%DATADIR%%/plugins/taskbar.so
+%%DATADIR%%/plugins/test.so
+%%DATADIR%%/plugins/tray.so
+%%DATADIR%%/plugins/wincmd.so
+@dirrm %%DATADIR%%/images
+@dirrm %%DATADIR%%/plugins
+@dirrm %%DATADIR%%