aboutsummaryrefslogtreecommitdiff
path: root/x11/fbpanel
diff options
context:
space:
mode:
authorRong-En Fan <rafan@FreeBSD.org>2007-06-22 06:34:08 +0000
committerRong-En Fan <rafan@FreeBSD.org>2007-06-22 06:34:08 +0000
commit3102f0363f81bfda1b984aaecd2b0096042cd3c0 (patch)
treed8334b9eff33b5911b330425fe9606dacc2c426e /x11/fbpanel
parent72909bd9e21ab3bce7b6ccd91c73e355b211fb94 (diff)
downloadports-3102f0363f81bfda1b984aaecd2b0096042cd3c0.tar.gz
ports-3102f0363f81bfda1b984aaecd2b0096042cd3c0.zip
Notes
Diffstat (limited to 'x11/fbpanel')
-rw-r--r--x11/fbpanel/Makefile3
-rw-r--r--x11/fbpanel/distinfo6
-rw-r--r--x11/fbpanel/files/patch-Makefile.common35
-rw-r--r--x11/fbpanel/files/patch-bg.c10
-rw-r--r--x11/fbpanel/pkg-plist22
5 files changed, 44 insertions, 32 deletions
diff --git a/x11/fbpanel/Makefile b/x11/fbpanel/Makefile
index 15e2ff0057a9..4e82cdf31dd9 100644
--- a/x11/fbpanel/Makefile
+++ b/x11/fbpanel/Makefile
@@ -6,8 +6,7 @@
#
PORTNAME= fbpanel
-PORTVERSION= 4.3
-PORTREVISION= 4
+PORTVERSION= 4.9
CATEGORIES= x11
MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
MASTER_SITE_SUBDIR= ${PORTNAME}
diff --git a/x11/fbpanel/distinfo b/x11/fbpanel/distinfo
index f7d3b7abf389..d210ca12a371 100644
--- a/x11/fbpanel/distinfo
+++ b/x11/fbpanel/distinfo
@@ -1,3 +1,3 @@
-MD5 (fbpanel-4.3.tgz) = 2d2f3713cf3c17b71997064f39d4c888
-SHA256 (fbpanel-4.3.tgz) = e4db7a6305ffe2333fae08c940ded8f7e5b02999e0917b0ea4ef3764c80f58c8
-SIZE (fbpanel-4.3.tgz) = 95702
+MD5 (fbpanel-4.9.tgz) = 67a2a442a038ba80094c8cc06784dd08
+SHA256 (fbpanel-4.9.tgz) = 6d7f445885644988820119f51fb0728fbd2b8df0c26ca8d010c267b535d129de
+SIZE (fbpanel-4.9.tgz) = 169637
diff --git a/x11/fbpanel/files/patch-Makefile.common b/x11/fbpanel/files/patch-Makefile.common
index d98f8d1ceed7..3c555ce62b2f 100644
--- a/x11/fbpanel/files/patch-Makefile.common
+++ b/x11/fbpanel/files/patch-Makefile.common
@@ -1,27 +1,32 @@
---- Makefile.common.orig Tue May 31 17:39:18 2005
-+++ Makefile.common Sun Apr 2 16:30:37 2006
+--- Makefile.common.orig Tue Apr 24 15:45:43 2007
++++ Makefile.common Thu Jun 21 06:58:50 2007
@@ -53,7 +53,7 @@
- DEVEL ?= 0
- CHATTY ?= $(DEVEL)
--STATIC_PLUGINS ?= 0
-+STATIC_PLUGINS ?= 1
+ DEVEL = 0
+ CHATTY = $(DEVEL)
+-STATIC_PLUGINS = 0
++STATIC_PLUGINS = 1
#$(warning CHATTY=$(CHATTY) DEVEL=$(DEVEL))
ifeq (1,$(CHATTY))
Q :=
-@@ -83,13 +83,11 @@
- # compile flags
-
- RM = rm -f
--CC = gcc
-+CC ?= gcc
+@@ -89,10 +89,8 @@
+ CC ?= gcc
AR = ar
- LIBS = $(shell pkg-config --libs gtk+-2.0 gdk-pixbuf-2.0 gdk-pixbuf-xlib-2.0) -L/usr/X11R6/lib -lXmu
--INCS2 = $(shell pkg-config --cflags gtk+-2.0 gdk-pixbuf-2.0 gdk-pixbuf-xlib-2.0)
+ LIBS = $(shell pkg-config --libs glib-2.0 gmodule-2.0 gthread-2.0 gtk+-2.0 gdk-pixbuf-2.0 gdk-pixbuf-xlib-2.0) -L/usr/X11R6/lib -lXmu
+-INCS2 = $(shell pkg-config --cflags glib-2.0 gmodule-2.0 gthread-2.0 gtk+-2.0 gdk-pixbuf-2.0 gdk-pixbuf-xlib-2.0)
-INCS := $(INCS2:-I%=-isystem %)
+INCS = $(shell pkg-config --cflags gtk+-2.0 gdk-pixbuf-2.0 gdk-pixbuf-xlib-2.0)
--CFLAGS = -O2
+-CFLAGS ?= -O2 -Wall
ifeq (1,$(DEVEL))
override CFLAGS += -g
endif
+@@ -113,7 +111,7 @@
+
+ %.dep : %.c
+ $(call summary,DEP ,$@)
+- $(Q)$(CC) $(CPPFLAGS) $(INCS) -MM $< | sed 's/\($*\).o[ :]*/\1.o $@ :/' > $@
++ $(Q)$(CC) $(CPPFLAGS) $(INCS) -MM $< | sed 's/\($*\)\.o[ :]*/\1.o $@ :/' > $@
+
+
+ #########################################
diff --git a/x11/fbpanel/files/patch-bg.c b/x11/fbpanel/files/patch-bg.c
index 4ee24b855786..60643a171d3f 100644
--- a/x11/fbpanel/files/patch-bg.c
+++ b/x11/fbpanel/files/patch-bg.c
@@ -1,9 +1,9 @@
---- bg.c~ Sat Dec 18 17:41:41 2004
-+++ bg.c Sat Dec 18 17:43:04 2004
-@@ -196,7 +196,7 @@
- ENTER;
+--- bg.c.orig Tue Apr 24 15:45:43 2007
++++ bg.c Wed Jun 20 17:02:10 2007
+@@ -237,7 +237,7 @@
win = GDK_WINDOW_XWINDOW(widget->window);
- if (!XGetGeometry(bg->dpy, win, &dummy, &x, &y, &width, &height, &border, &depth)) {
+ if (!XGetGeometry(bg->dpy, win, &dummy, &x, &y, &width, &height, &border,
+ &depth)) {
- DBG2("XGetGeometry failed\n");
+ DBG("XGetGeometry failed\n");
RET(NULL);
diff --git a/x11/fbpanel/pkg-plist b/x11/fbpanel/pkg-plist
index b7bcc9c986c3..67a903f600cc 100644
--- a/x11/fbpanel/pkg-plist
+++ b/x11/fbpanel/pkg-plist
@@ -1,15 +1,23 @@
bin/fbpanel
%%DATADIR%%/default
-%%DATADIR%%/images/Desktop2.png
-%%DATADIR%%/images/Editor.png
-%%DATADIR%%/images/Emacs.png
-%%DATADIR%%/images/GNOME-Terminal.png
-%%DATADIR%%/images/Menu.png
-%%DATADIR%%/images/Networking.png
%%DATADIR%%/images/bottom-left.xpm
%%DATADIR%%/images/bottom-right.xpm
%%DATADIR%%/images/default.xpm
-%%DATADIR%%/images/settings.png
+%%DATADIR%%/images/gnome-applications.png
+%%DATADIR%%/images/gnome-devel.svg
+%%DATADIR%%/images/gnome-emacs.svg
+%%DATADIR%%/images/gnome-fs-desktop.svg
+%%DATADIR%%/images/gnome-fs-home.svg
+%%DATADIR%%/images/gnome-globe.svg
+%%DATADIR%%/images/gnome-graphics.png
+%%DATADIR%%/images/gnome-joystick.svg
+%%DATADIR%%/images/gnome-multimedia.svg
+%%DATADIR%%/images/gnome-settings.svg
+%%DATADIR%%/images/gnome-system.png
+%%DATADIR%%/images/gnome-util.svg
+%%DATADIR%%/images/gnome_terminal.svg
+%%DATADIR%%/images/mozilla-firefox.svg
+%%DATADIR%%/images/star.png
%%DATADIR%%/images/top-left.xpm
%%DATADIR%%/images/top-right.xpm
%%DATADIR%%/pager