aboutsummaryrefslogtreecommitdiff
path: root/x11/gcb
diff options
context:
space:
mode:
authorEmanuel Haupt <ehaupt@FreeBSD.org>2006-04-06 11:25:20 +0000
committerEmanuel Haupt <ehaupt@FreeBSD.org>2006-04-06 11:25:20 +0000
commit8cffe2cd4ec54b5d034c04de9f707a0bc948d162 (patch)
tree773f04a27e7ecacdc942c440f48ce5ce46f55d40 /x11/gcb
parent7d2ec338bd47e706f74ff614e2f3b48f400bfed7 (diff)
downloadports-8cffe2cd4ec54b5d034c04de9f707a0bc948d162.tar.gz
ports-8cffe2cd4ec54b5d034c04de9f707a0bc948d162.zip
Notes
Diffstat (limited to 'x11/gcb')
-rw-r--r--x11/gcb/Makefile43
-rw-r--r--x11/gcb/distinfo3
-rw-r--r--x11/gcb/files/gcb.desktop8
-rw-r--r--x11/gcb/pkg-descr20
-rw-r--r--x11/gcb/pkg-plist5
5 files changed, 79 insertions, 0 deletions
diff --git a/x11/gcb/Makefile b/x11/gcb/Makefile
new file mode 100644
index 000000000000..3e2e23f08b80
--- /dev/null
+++ b/x11/gcb/Makefile
@@ -0,0 +1,43 @@
+# New ports collection makefile for: gcb
+# Date Created: 30 January 2006
+# Whom: Nosov Artem <chip-set@mail.ru>
+#
+# $FreeBSD$
+#
+
+PORTNAME= gcb
+PORTVERSION= 0.2.8
+CATEGORIES= x11
+MASTER_SITES= http://ccbsd9.csie.nctu.edu.tw/~cp76/gcb/
+
+MAINTAINER= chip-set@mail.ru
+COMMENT= A GTK+ tool for managing x11 cut-buffers
+
+HAS_CONFIGURE= yes
+USE_BZIP2= yes
+USE_X_PREFIX= yes
+USE_GNOME= gtk20
+
+.include <bsd.port.pre.mk>
+
+.if ${OSVERSION} < 500000
+BROKEN= Does not compile on FreeBSD 4.x
+.endif
+
+post-patch:
+ @${REINPLACE_CMD} -e 's|#!/bin/bash|#!${SH}|' \
+ ${WRKSRC}/configure
+ @${REINPLACE_CMD} -e 's|/usr/local|${PREFIX}|; \
+ s|^\(CFLAGS\)=\(.*\)-g\ -O\(.*\)|\1+=\2 \3|' \
+ ${WRKSRC}/Makefile
+
+do-install:
+ ${INSTALL_PROGRAM} ${WRKSRC}/${PORTNAME} ${PREFIX}/bin
+ ${INSTALL_DATA} ${WRKSRC}/${PORTNAME}.png ${PREFIX}/share/icons
+ ${MKDIR} ${PREFIX}/share/applications
+ ${INSTALL_DATA} ${FILESDIR}/${PORTNAME}.desktop \
+ ${PREFIX}/share/applications
+ ${MKDIR} ${PREFIX}/share/pixmaps
+ ${INSTALL_DATA} ${WRKSRC}/${PORTNAME}.png ${PREFIX}/share/pixmaps
+
+.include <bsd.port.post.mk>
diff --git a/x11/gcb/distinfo b/x11/gcb/distinfo
new file mode 100644
index 000000000000..ed7a5788de94
--- /dev/null
+++ b/x11/gcb/distinfo
@@ -0,0 +1,3 @@
+MD5 (gcb-0.2.8.tar.bz2) = 2d33538093bb05e463ecaf0e8aade00a
+SHA256 (gcb-0.2.8.tar.bz2) = 9bdc96d13902ce70317696706a36f9ea5aeccf89eb0e43c6a33d5b6059eed3f6
+SIZE (gcb-0.2.8.tar.bz2) = 9979
diff --git a/x11/gcb/files/gcb.desktop b/x11/gcb/files/gcb.desktop
new file mode 100644
index 000000000000..f69df61371a9
--- /dev/null
+++ b/x11/gcb/files/gcb.desktop
@@ -0,0 +1,8 @@
+[Desktop Entry]
+Encoding=UTF-8
+Name=Gtk Copy-paste Buffer
+Comment=A GTK+ tool for managing x11 cut-buffers
+Icon=gcb.png
+Exec=gcb -B
+Type=Application
+Categories=GNOME;Application;System
diff --git a/x11/gcb/pkg-descr b/x11/gcb/pkg-descr
new file mode 100644
index 000000000000..22411b8ba150
--- /dev/null
+++ b/x11/gcb/pkg-descr
@@ -0,0 +1,20 @@
+Gtk Copy-paste Buffer
+
+It is something like 'xcb'. It has multiple buttons to store strings of paste
+buffer. You click a button to put the content into paste-buffer/clipboard.
+
+Advantages over xcb:
+- Use right button to assign the button as a snooper. It is more
+ straightforward than xcb.
+- It has tool-tip to display the complete content.
+- It is written in Gtk, so by default it has i18 display capability.
+- It can watch the clipboard of gtk (mozilla).
+- History of changes of paste buffer
+- By default, it is sticky on Gnome/Gtk. You can also specify option to turn
+ window decoration off (borderless). No more tedius desktop setup to install
+ it.
+
+WWW: http://www.gnomefiles.org/app.php?soft_id=322
+
+- Nosov Artem
+chip-set@mail.ru
diff --git a/x11/gcb/pkg-plist b/x11/gcb/pkg-plist
new file mode 100644
index 000000000000..3d2662970866
--- /dev/null
+++ b/x11/gcb/pkg-plist
@@ -0,0 +1,5 @@
+bin/gcb
+share/icons/gcb.png
+share/applications/gcb.desktop
+share/pixmaps/gcb.png
+@dirrmtry share/applications