aboutsummaryrefslogtreecommitdiff
path: root/x11/gdm/Makefile
diff options
context:
space:
mode:
authorPav Lucistnik <pav@FreeBSD.org>2005-01-24 23:26:24 +0000
committerPav Lucistnik <pav@FreeBSD.org>2005-01-24 23:26:24 +0000
commit432cd995b5f29d52c4f85180e72658f87dcaf5f1 (patch)
treecf599dc901c2b9f0247ded16aacd1e324d55d847 /x11/gdm/Makefile
parent68c99ea9b3c73a9f6f06ac3389ba44273446fe12 (diff)
downloadports-432cd995b5f29d52c4f85180e72658f87dcaf5f1.tar.gz
ports-432cd995b5f29d52c4f85180e72658f87dcaf5f1.zip
Notes
Diffstat (limited to 'x11/gdm/Makefile')
-rw-r--r--x11/gdm/Makefile73
1 files changed, 73 insertions, 0 deletions
diff --git a/x11/gdm/Makefile b/x11/gdm/Makefile
new file mode 100644
index 000000000000..d0f7e38ebf9b
--- /dev/null
+++ b/x11/gdm/Makefile
@@ -0,0 +1,73 @@
+# New ports collection makefile for: gdm2
+# Date created: 20 May 2002
+# Whom: Joe Marcus Clarke <marcus@FreeBSD.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= gdm
+PORTVERSION= 2.6.0.6
+PORTREVISION= 1
+CATEGORIES= x11 gnome
+MASTER_SITES= ${MASTER_SITE_GNOME}
+MASTER_SITE_SUBDIR= sources/${PORTNAME:S/2$//}/2.6
+DIST_SUBDIR= gnome2
+
+MAINTAINER= gnome@FreeBSD.org
+COMMENT= GNOME 2 version of xdm display manager
+
+USE_BZIP2= yes
+USE_X_PREFIX= yes
+INSTALLS_OMF= yes
+USE_GMAKE= yes
+USE_GNOME= gnomeprefix gnomehack intlhack gnomehier libgnomeui librsvg2
+USE_LIBTOOL_VER=15
+USE_REINPLACE= yes
+CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include -I${X11BASE}/include" \
+ LDFLAGS="-L${LOCALBASE}/lib"
+
+GDMDIR?= ${PREFIX}/etc/gdm
+PKGMESSAGE= ${WRKDIR}/pkg-message
+
+MAN1= gdm.1
+
+PLIST_SUB= VERSION="2.6"
+
+OPTIONS= IPV6 "Enable IPv6 support (This disables IPv4 support)" off
+
+.include <bsd.port.pre.mk>
+
+.if exists(/usr/include/security/pam_misc.h)
+PLIST_SUB+= PAM_MISC=""
+.else
+PLIST_SUB+= PAM_MISC="@comment "
+.endif
+
+.if defined(WITH_IPV6)
+CONFIGURE_ARGS+= --enable-ipv6
+.else
+CONFIGURE_ARGS+= --disable-ipv6
+.endif
+
+post-extract:
+ @${SED} -e "s,%%PREFIX%%,${PREFIX},g" \
+ ${FILESDIR}/gdm.sh.sample > ${WRKSRC}/gdm.sh.sample
+
+post-patch:
+.if ${OSVERSION} < 600006
+.for po in zh_CN.po
+ @${REINPLACE_CMD} -e 's|%-|%|g' ${WRKSRC}/po/${po}
+.endfor
+.endif
+
+post-install:
+.if !defined(PACKAGE_BUILDING)
+ @${SETENV} PKG_PREFIX=${PREFIX} ${SH} ${PKGINSTALL} ${PKGNAME} POST-INSTALL
+.endif
+ @${MKDIR} ${PREFIX}/etc/gdm/Sessions
+ @${INSTALL_SCRIPT} ${WRKSRC}/gdm.sh.sample ${PREFIX}/etc/rc.d
+ @${SED} -e 's|%%PREFIX%%|${PREFIX}|g' < ${PKGDIR}/pkg-message \
+ | /usr/bin/fmt 75 79 > ${PKGMESSAGE}
+ @${CAT} ${PKGMESSAGE}
+
+.include <bsd.port.post.mk>