aboutsummaryrefslogtreecommitdiff
path: root/x11/gdm2
diff options
context:
space:
mode:
authorJoe Marcus Clarke <marcus@FreeBSD.org>2004-04-05 03:11:39 +0000
committerJoe Marcus Clarke <marcus@FreeBSD.org>2004-04-05 03:11:39 +0000
commitc4851e78e4f63338fe9a4883e5b7a0370dce27f7 (patch)
tree3910aa2e83f782cec94f15b4547dadb741cd29ce /x11/gdm2
parentf82c84522b047dd99c6f9d85ce3e07217ccce7df (diff)
Notes
Diffstat (limited to 'x11/gdm2')
-rw-r--r--x11/gdm2/Makefile17
-rw-r--r--x11/gdm2/distinfo4
-rw-r--r--x11/gdm2/files/patch-ab26
-rw-r--r--x11/gdm2/files/patch-config_locale.alias84
-rw-r--r--x11/gdm2/pkg-descr5
-rw-r--r--x11/gdm2/pkg-install10
-rw-r--r--x11/gdm2/pkg-message21
-rw-r--r--x11/gdm2/pkg-plist101
8 files changed, 179 insertions, 89 deletions
diff --git a/x11/gdm2/Makefile b/x11/gdm2/Makefile
index 99b9aec6880d..1a6eadf946e4 100644
--- a/x11/gdm2/Makefile
+++ b/x11/gdm2/Makefile
@@ -6,11 +6,11 @@
#
PORTNAME= gdm2
-PORTVERSION= 2.4.4.7
-PORTREVISION= 2
+PORTVERSION= 2.6.0.0
+PORTREVISION= 1
CATEGORIES= x11 gnome
MASTER_SITES= ${MASTER_SITE_GNOME}
-MASTER_SITE_SUBDIR= sources/${PORTNAME:S/2$//}/2.4
+MASTER_SITE_SUBDIR= sources/${PORTNAME:S/2$//}/2.6
DISTNAME= gdm-${PORTVERSION}
DIST_SUBDIR= gnome2
@@ -19,14 +19,14 @@ COMMENT= GNOME 2 version of xdm display manager
USE_BZIP2= yes
USE_X_PREFIX= yes
-USE_REINPLACE= yes
USE_GMAKE= yes
-USE_GNOME= gnomeprefix intlhack gnomehack gnomehier libgnomeui librsvg2
+USE_GNOME= gnomeprefix gnomehack intlhack gnomehier libgnomeui librsvg2
GNU_CONFIGURE= yes
CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include -I${X11BASE}/include" \
LDFLAGS="-L${LOCALBASE}/lib"
GDMDIR?= ${PREFIX}/etc/gdm
+PKGMESSAGE= ${WRKDIR}/pkg-message
MAN1= gdm.1
@@ -42,16 +42,13 @@ post-extract:
@${SED} -e "s,%%PREFIX%%,${PREFIX},g" \
${FILESDIR}/gdm.sh.sample > ${WRKSRC}/gdm.sh.sample
-post-patch:
-.if ${OSVERSION} >= 450002 && ${OSVERSION} < 500000 || ${OSVERSION} >= 500020
- @${REINPLACE_CMD} -E -e 's/(..)\.EUC/\1.euc\1/' ${WRKSRC}/config/locale.alias
-.endif
-
post-install:
.if !defined(PACKAGE_BUILDING)
@${SETENV} PKG_PREFIX=${PREFIX} ${SH} ${PKGINSTALL} ${PKGNAME} POST-INSTALL
.endif
@${INSTALL_SCRIPT} ${WRKSRC}/gdm.sh.sample ${PREFIX}/etc/rc.d
+ @${SED} -e 's|%%PREFIX%%|${PREFIX}|g' < ${PKGDIR}/pkg-message \
+ | /usr/bin/fmt 75 79 > ${PKGMESSAGE}
@${CAT} ${PKGMESSAGE}
.include <bsd.port.post.mk>
diff --git a/x11/gdm2/distinfo b/x11/gdm2/distinfo
index 015a197fff22..43b847b7a871 100644
--- a/x11/gdm2/distinfo
+++ b/x11/gdm2/distinfo
@@ -1,2 +1,2 @@
-MD5 (gnome2/gdm-2.4.4.7.tar.bz2) = a3d2f243c4f42e2542bda8cb5fb9a7c5
-SIZE (gnome2/gdm-2.4.4.7.tar.bz2) = 2430455
+MD5 (gnome2/gdm-2.6.0.0.tar.bz2) = 3dbf4074a4ec78627a5d099d30126d45
+SIZE (gnome2/gdm-2.6.0.0.tar.bz2) = 2850702
diff --git a/x11/gdm2/files/patch-ab b/x11/gdm2/files/patch-ab
index 11f4da7ee56b..cc11b86e69c2 100644
--- a/x11/gdm2/files/patch-ab
+++ b/x11/gdm2/files/patch-ab
@@ -1,6 +1,6 @@
---- config/gdm.conf.in.orig Fri Oct 10 16:57:25 2003
-+++ config/gdm.conf.in Thu Oct 16 14:33:28 2003
-@@ -73,7 +73,7 @@
+--- config/gdm.conf.in.orig Thu Feb 12 14:22:36 2004
++++ config/gdm.conf.in Sat Mar 6 17:22:29 2004
+@@ -77,7 +77,7 @@
# To try to kill all clients started at greeter time or in the Init script.
# doesn't always work, only if those clients have a window of their own
#KillInitClients=true
@@ -9,7 +9,7 @@
# You should probably never change this value unless you have a weird setup
PidFile=/var/run/gdm.pid
# Note that a post login script is run before a PreSession script.
-@@ -93,7 +93,7 @@
+@@ -97,7 +97,7 @@
# Reboot, Halt and suspend commands, you can add different commands
# separated by a semicolon and gdm will use the first one it can find
#RebootCommand=/usr/bin/reboot;/sbin/reboot;/sbin/shutdown -r now;/usr/sbin/shutdown -r now
@@ -18,7 +18,7 @@
#SuspendCommand=
# Probably should not touch the below this is the standard setup
ServAuthDir=@EXPANDED_AUTHDIR@
-@@ -127,7 +127,7 @@
+@@ -136,7 +136,7 @@
# we force X to use specific vts. turn VTAllocation to false if this
# is causing problems.
#FirstVT=7
@@ -27,16 +27,16 @@
# Should double login be treated with a warning (and possibility to change
# vts on linux systems for console logins)
#DoubleLoginWarning=true
-@@ -211,7 +211,7 @@
- # The 'theme'. By default we're using the default gtk theme
- # Of course assuming that gtk got installed in the same prefix,
- # if not change this.
+@@ -232,7 +232,7 @@
+ # The specific gtkrc file we use. It should be the full path to the gtkrc
+ # that we need. Unless you need a specific gtkrc that doesn't correspond to
+ # a specific theme, then just use the GtkTheme key
-#GtkRC=@EXPANDED_DATADIR@/themes/Default/gtk/gtkrc
+GtkRC=@EXPANDED_DATADIR@/../themes/Default/gtk-2.0/gtkrc
- # Maximum size of an icon, larger icons are scaled down
- #MaxIconWidth=128
- #MaxIconHeight=128
-@@ -364,7 +364,7 @@
+
+ # The GTK+ theme to use for the gui
+ #GtkTheme=Default
+@@ -415,7 +415,7 @@
# Definition of the standard X server.
[server-Standard]
name=Standard server
diff --git a/x11/gdm2/files/patch-config_locale.alias b/x11/gdm2/files/patch-config_locale.alias
index 8ac5400b0567..7e944b8d2900 100644
--- a/x11/gdm2/files/patch-config_locale.alias
+++ b/x11/gdm2/files/patch-config_locale.alias
@@ -1,6 +1,6 @@
---- config/locale.alias.orig Thu May 15 22:56:46 2003
-+++ config/locale.alias Mon Sep 15 23:41:05 2003
-@@ -14,76 +14,36 @@
+--- config/locale.alias.orig Sun Feb 29 12:56:10 2004
++++ config/locale.alias Sat Mar 6 17:45:16 2004
+@@ -14,79 +14,43 @@
#
# - George
@@ -25,6 +25,7 @@
-English(American) en_US.UTF-8,en_US
-English(Australian) en_AU.UTF-8,en_AU
-English(British) en_GB.UTF-8,en_GB
+-English(Canadian) en_CA.UTF-8,en_CA
-English(Ireland) en_IE.UTF-8,en_IE
-Estonian et_EE.UTF-8,et_EE
-Finnish fi_FI.UTF-8,fi_FI
@@ -61,7 +62,9 @@
-Portuguese pt_PT.UTF-8,pt_PT
-Romanian ro_RO.UTF-8,ro_RO
-Russian ru_RU.UTF-8,ru_RU
--Serbian sr_YU.UTF-8,sr_YU
+-Serbian sr_CS.UTF-8,sr_CS,sr_YU@cyrillic,sr_YU
+-Serbian(Latin) sr_CS.UTF-8@Latn,sr_CS@Latn,sr_YU@Latn
+-Serbian(Jekavian) sr_CS.UTF-8@ije,sr_CS@ije,sr_YU@ije
-Slovak sk_SK.UTF-8,sk_SK
-Slovenian sl_SI.UTF-8,sl_SI
-Spanish es_ES.UTF-8,es_ES
@@ -77,36 +80,43 @@
-Walloon wa_BE.UTF-8,wa_BE
-Welsh cy_GB.UTF-8,cy_GB
-Yiddish yi.UTF-8,yi
-+Bulgarian bg_BG.UTF-8,bg_BG.CP1251
-+Chinese(simplified) zh_CN.UTF-8,zh_CN.EUC
-+Chinese(traditional) zh_TW.UTF-8,zh_TW.Big5
-+Croatian hr_HR.UTF-8,hr_HR.ISO8859-2
-+Czech cs_CZ.UTF-8,cs_CZ.ISO8859-2
-+Danish da_DK.UTF-8,da_DK.ISO8859-1
-+Dutch nl_NL.UTF-8,nl_NL.ISO8859-15
-+Estonian et_EE.UTF-8,et_EE.ISO8859-15
-+English(American) en_US.UTF-8,en_US.ISO8859-1
-+English(Australian) en_AU.UTF-8,en_AU.ISO8859-1
-+English(British) en_GB.UTF-8,en_GB.ISO8859-1
-+Finnish fi_FI.UTF-8,fi_FI.ISO8859-15
-+French fr_FR.UTF-8,fr_FR.ISO8859-15
-+German de_DE.UTF-8,de_DE.ISO8859-15
-+Greek el_GR.UTF-8,el_GR.ISO8859-7
-+Hungarian hu_HU.UTF-8,hu_HU.ISO8859-2
-+Icelandic is_IS.UTF-8,is_IS.ISO8859-1
-+Italian it_IT.UTF-8,it_IT.ISO8859-15
-+Japanese ja_JP.UTF-8,ja_JP.EUC
-+Korean ko_KR.UTF-8,ko_KR.EUC
-+Lithuanian lt_LT.UTF-8,lt_LT.ISO8859-4
-+Norwegian(bokmal) no_NO.UTF-8,no_NO.ISO8859-1
-+Polish pl_PL.UTF-8,pl_PL.ISO8859-2
-+Portuguese pt_PT.UTF-8,pt_PT.ISO8859-15
-+Portuguese(Brazilian) pt_BR.UTF-8,pt_BR.ISO8859-1
-+Romanian ro_RO.UTF-8,ro_RO.ISO8859-2
-+Russian ru_RU.UTF-8,ru_RU.ISO8859-5
-+Slovak sk_SK.UTF-8,sk_SK.ISO8859-2
-+Slovenian sl_SI.UTF-8,sl_SI.ISO8859-2
-+Spanish es_ES.UTF-8,es_ES.ISO8859-15
-+Swedish sv_SE.UTF-8,sv_SE.ISO8859-1
-+Turkish tr_TR.UTF-8,tr_TR.ISO8859-9
-+Ukrainian uk_UA.UTF-8,uk_UA.ISO8859-5
++Afrikaans af_ZA.ISO8859-15,af_ZA.ISO8859-1
++Amharic am_ET.UTF-8
++Byelorussian be_BY.CP1131,be_BY.CP1251,be_BY.ISO8859-5
++Bulgarian bg_BG.CP1251
++Catalan ca_ES.ISO8859-15,ca_ES.ISO8859-1
++Chinese(simplified) zh_CN.EUC,zh_CN.eucCN
++Chinese(traditional) zh_TW.Big5
++Croatian hr_HR.ISO8859-2
++Czech cs_CZ.ISO8859-2
++Danish da_DK.ISO8859-15,da_DK.ISO8859-1
++Dutch nl_NL.ISO8859-15,nl_NL.ISO8859-1
++English(American) en_US.ISO8859-1,en_US.ISO8859-15
++English(Australian) en_AU.ISO8859-1,en_AU.ISO8859-15
++English(British) en_GB.ISO8859-1,en_GB.ISO8859-15
++English(Canadian) en_CA.ISO8859-1,en_CA.ISO8859-15
++Estonian et_EE.ISO8859-15
++Finnish fi_FI.ISO8859-15,fi_FI.ISO8859-1
++French fr_FR.ISO8859-15,fr_FR.ISO8859-1
++German de_DE.ISO8859-15,de_DE.ISO8859-1
++Greek el_GR.ISO8859-7
++Hindi hi_IN.ISCII-DEV
++Hungarian hu_HU.ISO8859-2
++Icelandic is_IS.ISO8859-1,is_IS.ISO8859-15
++Italian it_IT.ISO8859-15,it_IT.ISO8859-1
++Italian(Swiss) it_CH.ISO8859-15,it_CH.ISO8859-1
++Japanese ja_JP.EUC,ja_JP.eucJP
++Korean ko_KR.EUC,ko_KR.eucKR
++Lithuanian lt_LT.ISO8859-4,lt_LT.ISO8859-13
++Norwegian(bokmal) no_NO.ISO8859-1,no_NO.ISO8859-15
++Polish pl_PL.ISO8859-2
++Portuguese pt_PT.ISO8859-15,pt_PT.ISO8859-1
++Portuguese(Brazilian) pt_BR.ISO8859-1
++Romanian ro_RO.ISO8859-2
++Russian ru_RU.ISO8859-5
++Slovak sk_SK.ISO8859-2
++Slovenian sl_SI.ISO8859-2
++Spanish es_ES.ISO8859-15,es_ES.ISO8859-1
++Swedish sv_SE.ISO8859-1
++Turkish tr_TR.ISO8859-9
++Ukrainian uk_UA.ISO8859-5
diff --git a/x11/gdm2/pkg-descr b/x11/gdm2/pkg-descr
index 85c150c4c6f2..2485dadfecef 100644
--- a/x11/gdm2/pkg-descr
+++ b/x11/gdm2/pkg-descr
@@ -1,3 +1,2 @@
-The GNOME 2.0 version of the xdm display manager. It has support for
-face pixmaps, multiple sessions plus clean shutdowns from the login
-menu.
+The GNOME 2.0 version of the xdm display manager. It supports user
+icons, multiple sessions, and clean system shutdowns.
diff --git a/x11/gdm2/pkg-install b/x11/gdm2/pkg-install
index b8f29b328edf..13e26f4bfba2 100644
--- a/x11/gdm2/pkg-install
+++ b/x11/gdm2/pkg-install
@@ -1,10 +1,7 @@
#!/bin/sh
-if [ -n "${PACKAGE_BUILDING}" ]; then
- exit 0
-fi
-
-if [ "$2" = "POST-INSTALL" ]; then
+case $2 in
+POST-INSTALL)
USER=gdm
GROUP=${USER}
UID=92
@@ -39,4 +36,5 @@ if [ "$2" = "POST-INSTALL" ]; then
${CHOWN} -R ${USER}:${GROUP} ${PKG_PREFIX}/share/gnome/gdm ${PKG_PREFIX}/etc/gdm
${CHMOD} 0750 ${PKG_PREFIX}/share/gnome/gdm
exit 0
-fi
+ ;;
+esac
diff --git a/x11/gdm2/pkg-message b/x11/gdm2/pkg-message
index 03665d14d573..b2e15c7ab690 100644
--- a/x11/gdm2/pkg-message
+++ b/x11/gdm2/pkg-message
@@ -1,25 +1,26 @@
GDM is installed.
-Do _NOT_ use /etc/ttys to start gdm at boot time. This will result in gdm
-hanging or restarting constantly. Instead, copy the included gdm.sh.sample
-script to gdm.sh, and restart. This script is found, by default, in
-/usr/X11R6/etc/rc.d.
+Do _NOT_ use /etc/ttys to start gdm at boot time. This will result in gdm
+hanging or restarting constantly. Instead, copy the included gdm.sh.sample
+script to gdm.sh, and restart. This script is found in
+%%PREFIX%%/etc/rc.d.
GDM uses its own locale.alias file to determine its language and especially
-the GNOME-2 fontencoding. This file is located, by default, in
-/usr/X11R6/etc/gdm/locale.alias. By default, the character set for every
-county using the EURO currency is set to ISO8859-15 in order to enable the
-EURO sign. If you don't feel comfortable with this, edit this file according
+the GNOME 2 fontencoding. This file is located in
+%%PREFIX%%/etc/gdm/locale.alias. By default, the character set for every
+county using the EURO currency is set to ISO8859-15 in order to enable the
+EURO sign. If you do not feel comfortable with this, edit this file according
to your preferences.
-If you are running 5.x and you are running 5.1-RELEASE or earlier, GDM will
+If you are running 5.X and you are running 5.1-RELEASE or earlier, GDM will
fail to work due to a bug in OpenPAM. You can download a patch from
http://www.FreeBSD.org/~marcus/pam_get_user.c.diff. You must also have the
FreeBSD src tree on your system. Do the following to apply the patch:
# cd /usr
+
# patch -p < /path/to/pam_get_user.c.diff
Then rebuild and install world. Note, this bug does _NOT_ affect FreeBSD
-4.x.
+4.X.
diff --git a/x11/gdm2/pkg-plist b/x11/gdm2/pkg-plist
index d585f33133d2..0c5d3bcc764c 100644
--- a/x11/gdm2/pkg-plist
+++ b/x11/gdm2/pkg-plist
@@ -9,7 +9,6 @@ bin/gdmlogin
bin/gdmphotosetup
bin/gdmsetup
bin/gdmthemetester
-etc/dm/Sessions/default.desktop
etc/gdm/Init/Default
etc/gdm/PostLogin/Default.sample
etc/gdm/PostSession/Default
@@ -39,8 +38,16 @@ share/gnome/applications/gdmflexiserver-xnest.desktop
share/gnome/applications/gdmflexiserver.desktop
share/gnome/applications/gdmsetup.desktop
share/gnome/capplets/gdmphotosetup.desktop
+share/gnome/gdm/BuiltInSessions/default.desktop
share/gnome/gdm/gdmchooser.glade
share/gnome/gdm/gdmsetup.glade
+share/gnome/gdm/themes/circles/GdmGreeterTheme.desktop
+share/gnome/gdm/themes/circles/background.svg
+share/gnome/gdm/themes/circles/circles.xml
+share/gnome/gdm/themes/circles/flower.png
+share/gnome/gdm/themes/circles/help.png
+share/gnome/gdm/themes/circles/options.png
+share/gnome/gdm/themes/circles/screenshot.png
share/gnome/gdm/themes/happygnome-list/GdmGreeterTheme.desktop
share/gnome/gdm/themes/happygnome-list/background.svg
share/gnome/gdm/themes/happygnome-list/disconnect.png
@@ -59,17 +66,60 @@ share/gnome/gdm/themes/happygnome/options.png
share/gnome/gdm/themes/happygnome/screenshot.png
share/gnome/gdm/themes/happygnome/session.png
share/gnome/gdm/themes/happygnome/system.png
-share/gnome/gdm/themes/circles/GdmGreeterTheme.desktop
-share/gnome/gdm/themes/circles/background.svg
-share/gnome/gdm/themes/circles/circles.xml
-share/gnome/gdm/themes/circles/flower.png
-share/gnome/gdm/themes/circles/help.png
-share/gnome/gdm/themes/circles/options.png
-share/gnome/gdm/themes/circles/screenshot.png
share/gnome/help/gdm/C/gdm.xml
share/gnome/help/gdm/C/legal.xml
+share/gnome/help/gdm/de/figures/gdm_window.png
+share/gnome/help/gdm/de/gdm.xml
+share/gnome/help/gdm/de/legal.xml
+share/gnome/help/gdm/es/figures/gdm_window.png
+share/gnome/help/gdm/es/gdm.xml
+share/gnome/help/gdm/es/legal.xml
+share/gnome/help/gdm/fr/figures/gdm_window.png
+share/gnome/help/gdm/fr/gdm.xml
+share/gnome/help/gdm/fr/legal.xml
+share/gnome/help/gdm/it/figures/gdm_window.png
+share/gnome/help/gdm/it/gdm.xml
+share/gnome/help/gdm/it/legal.xml
+share/gnome/help/gdm/ja/figures/gdm_window.png
+share/gnome/help/gdm/ja/gdm.xml
+share/gnome/help/gdm/ja/legal.xml
+share/gnome/help/gdm/ko/figures/gdm_window.png
+share/gnome/help/gdm/ko/gdm.xml
+share/gnome/help/gdm/ko/legal.xml
+share/gnome/help/gdm/sv/figures/gdm_window.png
+share/gnome/help/gdm/sv/gdm.xml
+share/gnome/help/gdm/sv/legal.xml
+share/gnome/help/gdm/zh_CN/figures/gdm_window.png
+share/gnome/help/gdm/zh_CN/gdm.xml
+share/gnome/help/gdm/zh_CN/legal.xml
+share/gnome/help/gdm/zh_HK/figures/gdm_window.png
+share/gnome/help/gdm/zh_HK/gdm.xml
+share/gnome/help/gdm/zh_HK/legal.xml
+share/gnome/help/gdm/zh_TW/figures/gdm_window.png
+share/gnome/help/gdm/zh_TW/gdm.xml
+share/gnome/help/gdm/zh_TW/legal.xml
share/gnome/omf/gdm/gdm-C.omf
@exec scrollkeeper-install -q %D/share/gnome/omf/gdm/gdm-C.omf 2>/dev/null || /usr/bin/true
+share/gnome/omf/gdm/gdm-de.omf
+@exec scrollkeeper-install -q %D/share/gnome/omf/gdm/gdm-de.omf 2>/dev/null || /usr/bin/true
+share/gnome/omf/gdm/gdm-es.omf
+@exec scrollkeeper-install -q %D/share/gnome/omf/gdm/gdm-es.omf 2>/dev/null || /usr/bin/true
+share/gnome/omf/gdm/gdm-fr.omf
+@exec scrollkeeper-install -q %D/share/gnome/omf/gdm/gdm-fr.omf 2>/dev/null || /usr/bin/true
+share/gnome/omf/gdm/gdm-it.omf
+@exec scrollkeeper-install -q %D/share/gnome/omf/gdm/gdm-it.omf 2>/dev/null || /usr/bin/true
+share/gnome/omf/gdm/gdm-ja.omf
+@exec scrollkeeper-install -q %D/share/gnome/omf/gdm/gdm-ja.omf 2>/dev/null || /usr/bin/true
+share/gnome/omf/gdm/gdm-ko.omf
+@exec scrollkeeper-install -q %D/share/gnome/omf/gdm/gdm-ko.omf 2>/dev/null || /usr/bin/true
+share/gnome/omf/gdm/gdm-sv.omf
+@exec scrollkeeper-install -q %D/share/gnome/omf/gdm/gdm-sv.omf 2>/dev/null || /usr/bin/true
+share/gnome/omf/gdm/gdm-zh_CN.omf
+@exec scrollkeeper-install -q %D/share/gnome/omf/gdm/gdm-zh_CN.omf 2>/dev/null || /usr/bin/true
+share/gnome/omf/gdm/gdm-zh_HK.omf
+@exec scrollkeeper-install -q %D/share/gnome/omf/gdm/gdm-zh_HK.omf 2>/dev/null || /usr/bin/true
+share/gnome/omf/gdm/gdm-zh_TW.omf
+@exec scrollkeeper-install -q %D/share/gnome/omf/gdm/gdm-zh_TW.omf 2>/dev/null || /usr/bin/true
share/gnome/pixmaps/gdm-foot-logo.png
share/gnome/pixmaps/gdm.png
share/gnome/pixmaps/login-photo.png
@@ -88,6 +138,7 @@ share/locale/cy/LC_MESSAGES/gdm-2.4.mo
share/locale/da/LC_MESSAGES/gdm-2.4.mo
share/locale/de/LC_MESSAGES/gdm-2.4.mo
share/locale/el/LC_MESSAGES/gdm-2.4.mo
+share/locale/en_CA/LC_MESSAGES/gdm-2.4.mo
share/locale/es/LC_MESSAGES/gdm-2.4.mo
share/locale/et/LC_MESSAGES/gdm-2.4.mo
share/locale/eu/LC_MESSAGES/gdm-2.4.mo
@@ -98,6 +149,7 @@ share/locale/ga/LC_MESSAGES/gdm-2.4.mo
share/locale/gl/LC_MESSAGES/gdm-2.4.mo
share/locale/he/LC_MESSAGES/gdm-2.4.mo
share/locale/hi/LC_MESSAGES/gdm-2.4.mo
+share/locale/hr/LC_MESSAGES/gdm-2.4.mo
share/locale/hu/LC_MESSAGES/gdm-2.4.mo
share/locale/id/LC_MESSAGES/gdm-2.4.mo
share/locale/is/LC_MESSAGES/gdm-2.4.mo
@@ -134,15 +186,48 @@ share/locale/zh_CN/LC_MESSAGES/gdm-2.4.mo
share/locale/zh_TW/LC_MESSAGES/gdm-2.4.mo
@dirrm share/gnome/xsessions
@dirrm share/gnome/omf/gdm
+@dirrm share/gnome/help/gdm/zh_TW/figures
+@dirrm share/gnome/help/gdm/zh_TW
+@dirrm share/gnome/help/gdm/zh_HK/figures
+@dirrm share/gnome/help/gdm/zh_HK
+@dirrm share/gnome/help/gdm/zh_CN/figures
+@dirrm share/gnome/help/gdm/zh_CN
+@dirrm share/gnome/help/gdm/sv/figures
+@dirrm share/gnome/help/gdm/sv
+@dirrm share/gnome/help/gdm/ko/figures
+@dirrm share/gnome/help/gdm/ko
+@dirrm share/gnome/help/gdm/ja/figures
+@dirrm share/gnome/help/gdm/ja
+@dirrm share/gnome/help/gdm/it/figures
+@dirrm share/gnome/help/gdm/it
+@dirrm share/gnome/help/gdm/fr/figures
+@dirrm share/gnome/help/gdm/fr
+@dirrm share/gnome/help/gdm/es/figures
+@dirrm share/gnome/help/gdm/es
+@dirrm share/gnome/help/gdm/de/figures
+@dirrm share/gnome/help/gdm/de
@dirrm share/gnome/help/gdm/C
@dirrm share/gnome/help/gdm
@dirrm share/gnome/gdm/themes/happygnome
@dirrm share/gnome/gdm/themes/happygnome-list
@dirrm share/gnome/gdm/themes/circles
@dirrm share/gnome/gdm/themes
+@dirrm share/gnome/gdm/BuiltInSessions
@dirrm etc/pam.d
@dirrm etc/gdm/modules
@dirrm etc/gdm/PostLogin
@unexec /bin/rmdir %D/etc/dm/Sessions 2>/dev/null || /usr/bin/true
@unexec /bin/rmdir %D/etc/dm 2>/dev/null || /usr/bin/true
+@unexec /bin/rmdir %D/share/gnome/log/gdm 2>/dev/null || /usr/bin/true
+@unexec /bin/rmdir %D/share/gnome/log 2>/dev/null || /usr/bin/true
@unexec scrollkeeper-uninstall -q %D/share/gnome/omf/gdm/gdm-C.omf 2>/dev/null || /usr/bin/true
+@unexec scrollkeeper-uninstall -q %D/share/gnome/omf/gdm/gdm-de.omf 2>/dev/null || /usr/bin/true
+@unexec scrollkeeper-uninstall -q %D/share/gnome/omf/gdm/gdm-es.omf 2>/dev/null || /usr/bin/true
+@unexec scrollkeeper-uninstall -q %D/share/gnome/omf/gdm/gdm-fr.omf 2>/dev/null || /usr/bin/true
+@unexec scrollkeeper-uninstall -q %D/share/gnome/omf/gdm/gdm-it.omf 2>/dev/null || /usr/bin/true
+@unexec scrollkeeper-uninstall -q %D/share/gnome/omf/gdm/gdm-ja.omf 2>/dev/null || /usr/bin/true
+@unexec scrollkeeper-uninstall -q %D/share/gnome/omf/gdm/gdm-ko.omf 2>/dev/null || /usr/bin/true
+@unexec scrollkeeper-uninstall -q %D/share/gnome/omf/gdm/gdm-sv.omf 2>/dev/null || /usr/bin/true
+@unexec scrollkeeper-uninstall -q %D/share/gnome/omf/gdm/gdm-zh_CN.omf 2>/dev/null || /usr/bin/true
+@unexec scrollkeeper-uninstall -q %D/share/gnome/omf/gdm/gdm-zh_HK.omf 2>/dev/null || /usr/bin/true
+@unexec scrollkeeper-uninstall -q %D/share/gnome/omf/gdm/gdm-zh_TW.omf 2>/dev/null || /usr/bin/true