aboutsummaryrefslogtreecommitdiff
path: root/x11/gdm2
diff options
context:
space:
mode:
authorJoe Marcus Clarke <marcus@FreeBSD.org>2003-05-11 06:31:55 +0000
committerJoe Marcus Clarke <marcus@FreeBSD.org>2003-05-11 06:31:55 +0000
commitda8e6d479254199ad445a74f9d3074d31f554d8c (patch)
tree96eafc69cc10dd81bdb847c1e05fa36dde767259 /x11/gdm2
parent1306ff7f07919f0efab59f1a1364eb65d1b8be19 (diff)
downloadports-da8e6d479254199ad445a74f9d3074d31f554d8c.tar.gz
ports-da8e6d479254199ad445a74f9d3074d31f554d8c.zip
Notes
Diffstat (limited to 'x11/gdm2')
-rw-r--r--x11/gdm2/Makefile1
-rw-r--r--x11/gdm2/files/patch-ltmain.sh51
2 files changed, 52 insertions, 0 deletions
diff --git a/x11/gdm2/Makefile b/x11/gdm2/Makefile
index a1b0ae3038b3..e3fe64b509bc 100644
--- a/x11/gdm2/Makefile
+++ b/x11/gdm2/Makefile
@@ -7,6 +7,7 @@
PORTNAME= gdm2
PORTVERSION= 2.4.1.4
+PORTREVISION= 1
CATEGORIES= x11 gnome
MASTER_SITES= ${MASTER_SITE_GNOME}
MASTER_SITE_SUBDIR= sources/${PORTNAME:S/2$//}/2.4
diff --git a/x11/gdm2/files/patch-ltmain.sh b/x11/gdm2/files/patch-ltmain.sh
new file mode 100644
index 000000000000..8afc42e3986c
--- /dev/null
+++ b/x11/gdm2/files/patch-ltmain.sh
@@ -0,0 +1,51 @@
+--- ltmain.sh.orig Fri Apr 25 15:18:44 2003
++++ ltmain.sh Sun May 11 02:27:13 2003
+@@ -1061,7 +1061,7 @@
+ esac
+ elif test "X$arg" = "X-lc_r"; then
+ case $host in
+- *-*-openbsd* | *-*-freebsd*)
++ *-*-openbsd* | *-*-freebsd4*)
+ # Do not include libc_r directly, use -pthread flag.
+ continue
+ ;;
+@@ -1071,8 +1071,16 @@
+ continue
+ ;;
+
++ -pthread)
++ compile_command="$compile_command -pthread"
++ finalize_command="$finalize_command -pthread"
++ compiler_flags="$compiler_flags -pthread"
++ continue
++ ;;
++
+ -module)
+ module=yes
++ build_old_libs=no
+ continue
+ ;;
+
+@@ -2471,6 +2479,9 @@
+ *-*-openbsd* | *-*-freebsd*)
+ # Do not include libc due to us having libc/libc_r.
+ ;;
++ *-*-freebsd*)
++ # FreeBSD doesn't need this...
++ ;;
+ *)
+ # Add libc to deplibs on all other systems if necessary.
+ if test $build_libtool_need_lc = "yes"; then
+@@ -4280,10 +4291,12 @@
+ fi
+
+ # Install the pseudo-library for information purposes.
++ if /usr/bin/false; then
+ name=`$echo "X$file" | $Xsed -e 's%^.*/%%'`
+ instname="$dir/$name"i
+ $show "$install_prog $instname $destdir/$name"
+ $run eval "$install_prog $instname $destdir/$name" || exit $?
++ fi
+
+ # Maybe install the static library, too.
+ test -n "$old_library" && staticlibs="$staticlibs $dir/$old_library"