aboutsummaryrefslogtreecommitdiff
path: root/x11/gdm
diff options
context:
space:
mode:
authorMaxim Sobolev <sobomax@FreeBSD.org>2002-03-14 00:07:41 +0000
committerMaxim Sobolev <sobomax@FreeBSD.org>2002-03-14 00:07:41 +0000
commit34f0ba70ac6a077ee3ea87445e93b609fdd8d4b0 (patch)
treef5875e6580258e5de9e5f9a77f783df427aa63ff /x11/gdm
parent7d4d84fe9a9c60db1fff4df3c798d105e06904c1 (diff)
downloadports-34f0ba70ac6a077ee3ea87445e93b609fdd8d4b0.tar.gz
ports-34f0ba70ac6a077ee3ea87445e93b609fdd8d4b0.zip
Notes
Diffstat (limited to 'x11/gdm')
-rw-r--r--x11/gdm/Makefile5
-rw-r--r--x11/gdm/distinfo2
-rw-r--r--x11/gdm/files/patch-at26
-rw-r--r--x11/gdm/files/patch-configure89
-rw-r--r--x11/gdm/files/patch-docs::Makefile.in14
-rw-r--r--x11/gdm/pkg-plist74
6 files changed, 141 insertions, 69 deletions
diff --git a/x11/gdm/Makefile b/x11/gdm/Makefile
index dbfe47978472..7a72bb1729fb 100644
--- a/x11/gdm/Makefile
+++ b/x11/gdm/Makefile
@@ -6,14 +6,15 @@
#
PORTNAME= gdm
-PORTVERSION= 2.2.5.4
-PORTREVISION= 3
+PORTVERSION= 2.2.5.5
CATEGORIES= x11 gnome
MASTER_SITES= ${MASTER_SITE_GNOME}
MASTER_SITE_SUBDIR= stable/sources/gdm
+DIST_SUBDIR= gnome
MAINTAINER= gnome@FreeBSD.org
+USE_BZIP2= yes
USE_X_PREFIX= yes
USE_GMAKE= yes
USE_GNOME= yes
diff --git a/x11/gdm/distinfo b/x11/gdm/distinfo
index a8d4876a1a5d..b5072879b419 100644
--- a/x11/gdm/distinfo
+++ b/x11/gdm/distinfo
@@ -1 +1 @@
-MD5 (gdm-2.2.5.4.tar.gz) = 5e11652d2e2e80319403a0efbc74f4bb
+MD5 (gnome/gdm-2.2.5.5.tar.bz2) = 32085157d128caab9b53c110a9818d61
diff --git a/x11/gdm/files/patch-at b/x11/gdm/files/patch-at
index a965d5f38d3e..fe089e70b8c8 100644
--- a/x11/gdm/files/patch-at
+++ b/x11/gdm/files/patch-at
@@ -1,11 +1,15 @@
---- utils/Makefile.in.orig Mon Oct 1 12:42:50 2001
-+++ utils/Makefile.in Mon Oct 1 12:43:00 2001
-@@ -161,7 +161,7 @@
- gdmopen_SOURCES = gdmopen.c
-
-
--gdmaskpass_LDADD = $(GNOME_LIBDIR) $(INTLLIBS) -lpam -lpam_misc
-+gdmaskpass_LDADD = $(GNOME_LIBDIR) $(INTLLIBS) -lpam
-
-
- gdmopen_LDADD = $(GNOME_LIBDIR) $(INTLLIBS)
+
+$FreeBSD$
+
+--- utils/Makefile.in.orig Wed Mar 13 17:52:05 2002
++++ utils/Makefile.in Wed Mar 13 17:52:32 2002
+@@ -195,8 +195,7 @@
+ gdmaskpass_LDADD = \
+ $(GNOME_LIBDIR) \
+ $(INTLLIBS) \
+- -lpam \
+- -lpam_misc
++ -lpam
+
+
+ gdmopen_LDADD = \
diff --git a/x11/gdm/files/patch-configure b/x11/gdm/files/patch-configure
index b298305f5e40..c543ff09aa19 100644
--- a/x11/gdm/files/patch-configure
+++ b/x11/gdm/files/patch-configure
@@ -1,61 +1,58 @@
---- configure.orig Thu Jan 10 10:45:20 2002
-+++ configure Thu Jan 10 10:55:39 2002
-@@ -11066,6 +11066,58 @@
-
+
+$FreeBSD$
+
+--- configure 2002/03/13 23:11:57 1.3
++++ configure 2002/03/13 23:16:32
+@@ -8575,6 +8575,52 @@
fi
-+for ac_header in sys/types.h login_cap.h
+
++for ac_hdr in sys/types.h login_cap.h
+do
-+as_ac_Header=`echo "ac_cv_header_$ac_header" | $as_tr_sh`
-+echo "$as_me:11072: checking for $ac_header" >&5
-+echo $ECHO_N "checking for $ac_header... $ECHO_C" >&6
-+if eval "test \"\${$as_ac_Header+set}\" = set"; then
-+ echo $ECHO_N "(cached) $ECHO_C" >&6
++ac_safe=`echo "$ac_hdr" | sed 'y%./+-%__p_%'`
++echo $ac_n "checking for $ac_hdr""... $ac_c" 1>&6
++echo "configure:8583: checking for $ac_hdr" >&5
++if eval "test \"`echo '$''{'ac_cv_header_$ac_safe'+set}'`\" = set"; then
++ echo $ac_n "(cached) $ac_c" 1>&6
+else
-+ cat >conftest.$ac_ext <<_ACEOF
-+#line 11078 "configure"
++ cat > conftest.$ac_ext <<EOF
++#line 8588 "configure"
+#include "confdefs.h"
-+#include <$ac_header>
-+_ACEOF
-+if { (eval echo "$as_me:11082: \"$ac_cpp conftest.$ac_ext\"") >&5
-+ (eval $ac_cpp conftest.$ac_ext) 2>conftest.er1
-+ ac_status=$?
-+ egrep -v '^ *\+' conftest.er1 >conftest.err
-+ rm -f conftest.er1
-+ cat conftest.err >&5
-+ echo "$as_me:11088: \$? = $ac_status" >&5
-+ (exit $ac_status); } >/dev/null; then
-+ if test -s conftest.err; then
-+ ac_cpp_err=$ac_c_preproc_warn_flag
-+ else
-+ ac_cpp_err=
-+ fi
-+else
-+ ac_cpp_err=yes
-+fi
-+if test -z "$ac_cpp_err"; then
-+ eval "$as_ac_Header=yes"
++#include <$ac_hdr>
++EOF
++ac_try="$ac_cpp conftest.$ac_ext >/dev/null 2>conftest.out"
++{ (eval echo configure:8593: \"$ac_try\") 1>&5; (eval $ac_try) 2>&5; }
++ac_err=`grep -v '^ *+' conftest.out | grep -v "^conftest.${ac_ext}\$"`
++if test -z "$ac_err"; then
++ rm -rf conftest*
++ eval "ac_cv_header_$ac_safe=yes"
+else
-+ echo "$as_me: failed program was:" >&5
-+ cat conftest.$ac_ext >&5
-+ eval "$as_ac_Header=no"
++ echo "$ac_err" >&5
++ echo "configure: failed program was:" >&5
++ cat conftest.$ac_ext >&5
++ rm -rf conftest*
++ eval "ac_cv_header_$ac_safe=no"
+fi
-+rm -f conftest.err conftest.$ac_ext
++rm -f conftest*
+fi
-+echo "$as_me:11107: result: `eval echo '${'$as_ac_Header'}'`" >&5
-+echo "${ECHO_T}`eval echo '${'$as_ac_Header'}'`" >&6
-+if test `eval echo '${'$as_ac_Header'}'` = yes; then
-+ cat >>confdefs.h <<EOF
-+#define `echo "HAVE_$ac_header" | $as_tr_cpp` 1
++if eval "test \"`echo '$ac_cv_header_'$ac_safe`\" = yes"; then
++ echo "$ac_t""yes" 1>&6
++ ac_tr_hdr=HAVE_`echo $ac_hdr | sed 'y%abcdefghijklmnopqrstuvwxyz./-%ABCDEFGHIJKLMNOPQRSTUVWXYZ___%'`
++ cat >> confdefs.h <<EOF
++#define $ac_tr_hdr 1
+EOF
-+
-+ LIBS="$LIBS -lutil"
-+ cat >>confdefs.h <<\EOF
++
++ LIBS="$LIBS -lutil"
++ cat >> confdefs.h <<\EOF
+#define HAVE_LOGINCAP 1
+EOF
++
++else
++ echo "$ac_t""no" 1>&6
+fi
+done
+
++
if test x$enable_authentication_scheme = xpam -a x$have_pam = xno ; then
- { { echo "$as_me:11070: error: PAM support requested but not available" >&5
- echo "$as_me: error: PAM support requested but not available" >&2;}
+ { echo "configure: error: PAM support requested but not available" 1>&2; exit 1; }
+ fi
diff --git a/x11/gdm/files/patch-docs::Makefile.in b/x11/gdm/files/patch-docs::Makefile.in
new file mode 100644
index 000000000000..91ccdd36565e
--- /dev/null
+++ b/x11/gdm/files/patch-docs::Makefile.in
@@ -0,0 +1,14 @@
+
+$FreeBSD$
+
+--- docs/Makefile.in 2002/03/13 23:43:57 1.1
++++ docs/Makefile.in 2002/03/13 23:44:08
+@@ -147,7 +147,7 @@
+ XPM_LIBS = @XPM_LIBS@
+ ZVT_LIBS = @ZVT_LIBS@
+
+-SUBDIRS = C eu gdmconfig
++SUBDIRS = C gdmconfig
+
+ EXTRA_DIST = sgmldocs.make
+ mkinstalldirs = $(SHELL) $(top_srcdir)/mkinstalldirs
diff --git a/x11/gdm/pkg-plist b/x11/gdm/pkg-plist
index 1b866ea8a6da..7e1e4f4f9c3d 100644
--- a/x11/gdm/pkg-plist
+++ b/x11/gdm/pkg-plist
@@ -7,24 +7,17 @@ bin/gdmlogin
bin/gdmmktemp
bin/gdmphotosetup
etc/gdm/Init/Default
-@unexec rm -f %D/etc/gdm/Init/Default.orig :: true
etc/gdm/PostSession/Default
-@unexec rm -f %D/etc/gdm/PostSession/Default.orig :: true
etc/gdm/PreSession/Default
-@unexec rm -f %D/etc/gdm/PreSession/Default.orig :: true
etc/gdm/Sessions/Gnome
-@unexec rm -f %D/etc/gdm/Sessions/Gnome.orig :: true
etc/gdm/Sessions/Xsession
-@unexec rm -f %D/etc/gdm/Sessions/Xsession.orig :: true
etc/gdm/XKeepsCrashing
etc/gdm/factory-gdm.conf
etc/gdm/gdm.conf
etc/gdm/gnomerc
etc/gdm/locale.alias
-@unexec rm -f %D/etc/gdm/locale.alias.orig :: true
sbin/gdm-restart
sbin/gdm-safe-restart
-sbin/gdmaskpass
share/gnome/apps/Settings/gdmphotosetup.desktop
share/gnome/apps/System/gdmconfig.desktop
share/gnome/apps/System/gdmflexiserver-xnest.desktop
@@ -33,15 +26,19 @@ share/gnome/gdm/gdmchooser.glade
share/gnome/gdm/gdmconfig.glade
share/gnome/help/gdm/C/configuration.html
share/gnome/help/gdm/C/daemonov.html
+share/gnome/help/gdm/C/docbook.css
share/gnome/help/gdm/C/f39.html
share/gnome/help/gdm/C/gdm.html
share/gnome/help/gdm/C/index.html
share/gnome/help/gdm/C/intro.html
-share/gnome/help/gdm/C/ln33.html
share/gnome/help/gdm/C/x156.html
share/gnome/help/gdm/C/x80.html
share/gnome/help/gdm/C/x89.html
+share/gnome/help/gdmconfig/C/authors.html
share/gnome/help/gdmconfig/C/basic.html
+share/gnome/help/gdmconfig/C/bugs.html
+share/gnome/help/gdmconfig/C/docbook.css
+share/gnome/help/gdmconfig/C/expert.html
share/gnome/help/gdmconfig/C/figures/GDM_auto_login.png
share/gnome/help/gdmconfig/C/figures/GDM_background.png
share/gnome/help/gdmconfig/C/figures/GDM_chooser.png
@@ -59,14 +56,63 @@ share/gnome/help/gdmconfig/C/figures/GDM_xdmcp.png
share/gnome/help/gdmconfig/C/figures/GDM_xserv_setup.png
share/gnome/help/gdmconfig/C/gdmconfig.sgml
share/gnome/help/gdmconfig/C/index.html
+share/gnome/help/gdmconfig/C/license.html
share/gnome/help/gdmconfig/C/ln7.html
+share/gnome/help/gdmconfig/C/stylesheet-images/caution.gif
+share/gnome/help/gdmconfig/C/stylesheet-images/home.gif
+share/gnome/help/gdmconfig/C/stylesheet-images/important.gif
+share/gnome/help/gdmconfig/C/stylesheet-images/next.gif
+share/gnome/help/gdmconfig/C/stylesheet-images/note.gif
+share/gnome/help/gdmconfig/C/stylesheet-images/prev.gif
+share/gnome/help/gdmconfig/C/stylesheet-images/tip.gif
+share/gnome/help/gdmconfig/C/stylesheet-images/toc-blank.gif
+share/gnome/help/gdmconfig/C/stylesheet-images/toc-minus.gif
+share/gnome/help/gdmconfig/C/stylesheet-images/toc-plus.gif
+share/gnome/help/gdmconfig/C/stylesheet-images/up.gif
+share/gnome/help/gdmconfig/C/stylesheet-images/warning.gif
+share/gnome/help/gdmconfig/C/system.html
share/gnome/help/gdmconfig/C/topic.dat
share/gnome/help/gdmconfig/C/usage.html
+share/gnome/help/gdmconfig/eu/basic.html
+share/gnome/help/gdmconfig/eu/figures/GDM_auto_login.png
+share/gnome/help/gdmconfig/eu/figures/GDM_background.png
+share/gnome/help/gdmconfig/eu/figures/GDM_chooser.png
+share/gnome/help/gdmconfig/eu/figures/GDM_enviro.png
+share/gnome/help/gdmconfig/eu/figures/GDM_face_brow.png
+share/gnome/help/gdmconfig/eu/figures/GDM_full.png
+share/gnome/help/gdmconfig/eu/figures/GDM_login_appear.png
+share/gnome/help/gdmconfig/eu/figures/GDM_login_behav.png
+share/gnome/help/gdmconfig/eu/figures/GDM_login_sessions.png
+share/gnome/help/gdmconfig/eu/figures/GDM_menubar.png
+share/gnome/help/gdmconfig/eu/figures/GDM_misc.png
+share/gnome/help/gdmconfig/eu/figures/GDM_paths.png
+share/gnome/help/gdmconfig/eu/figures/GDM_security.png
+share/gnome/help/gdmconfig/eu/figures/GDM_xdmcp.png
+share/gnome/help/gdmconfig/eu/figures/GDM_xserv_setup.png
+share/gnome/help/gdmconfig/eu/gdmconfig.sgml
+share/gnome/help/gdmconfig/eu/index.html
+share/gnome/help/gdmconfig/eu/ln10.html
+share/gnome/help/gdmconfig/eu/stylesheet-images/caution.gif
+share/gnome/help/gdmconfig/eu/stylesheet-images/home.gif
+share/gnome/help/gdmconfig/eu/stylesheet-images/important.gif
+share/gnome/help/gdmconfig/eu/stylesheet-images/next.gif
+share/gnome/help/gdmconfig/eu/stylesheet-images/note.gif
+share/gnome/help/gdmconfig/eu/stylesheet-images/prev.gif
+share/gnome/help/gdmconfig/eu/stylesheet-images/tip.gif
+share/gnome/help/gdmconfig/eu/stylesheet-images/toc-blank.gif
+share/gnome/help/gdmconfig/eu/stylesheet-images/toc-minus.gif
+share/gnome/help/gdmconfig/eu/stylesheet-images/toc-plus.gif
+share/gnome/help/gdmconfig/eu/stylesheet-images/up.gif
+share/gnome/help/gdmconfig/eu/stylesheet-images/warning.gif
+share/gnome/help/gdmconfig/eu/topic.dat
+share/gnome/help/gdmconfig/eu/usage.html
share/gnome/omf/gdm/gdmconfig-C.omf
+share/gnome/omf/gdm/gdmconfig-eu.omf
share/gnome/pixmaps/gdm.xpm
share/gnome/pixmaps/nobody.png
share/gnome/pixmaps/nohost.png
share/locale/az/LC_MESSAGES/gdm.mo
+share/locale/bg/LC_MESSAGES/gdm.mo
share/locale/ca/LC_MESSAGES/gdm.mo
share/locale/cs/LC_MESSAGES/gdm.mo
share/locale/da/LC_MESSAGES/gdm.mo
@@ -74,6 +120,7 @@ share/locale/de/LC_MESSAGES/gdm.mo
share/locale/el/LC_MESSAGES/gdm.mo
share/locale/es/LC_MESSAGES/gdm.mo
share/locale/et/LC_MESSAGES/gdm.mo
+share/locale/eu/LC_MESSAGES/gdm.mo
share/locale/fi/LC_MESSAGES/gdm.mo
share/locale/fr/LC_MESSAGES/gdm.mo
share/locale/ga/LC_MESSAGES/gdm.mo
@@ -99,9 +146,18 @@ share/locale/sv/LC_MESSAGES/gdm.mo
share/locale/ta/LC_MESSAGES/gdm.mo
share/locale/tr/LC_MESSAGES/gdm.mo
share/locale/uk/LC_MESSAGES/gdm.mo
-share/locale/zh_CN.GB2312/LC_MESSAGES/gdm.mo
+share/locale/zh_CN/LC_MESSAGES/gdm.mo
share/locale/zh_TW/LC_MESSAGES/gdm.mo
+@unexec rm -f %D/etc/gdm/Init/Default.orig :: true
+@unexec rm -f %D/etc/gdm/PostSession/Default.orig :: true
+@unexec rm -f %D/etc/gdm/PreSession/Default.orig :: true
+@unexec rm -f %D/etc/gdm/Sessions/Gnome.orig :: true
+@unexec rm -f %D/etc/gdm/Sessions/Xsession.orig :: true
+@unexec rm -f %D/etc/gdm/locale.alias.orig :: true
@dirrm share/gnome/omf/gdm
+@dirrm share/gnome/help/gdmconfig/eu/stylesheet-images
+@dirrm share/gnome/help/gdmconfig/eu/figures
+@dirrm share/gnome/help/gdmconfig/eu
@dirrm share/gnome/help/gdmconfig/C/stylesheet-images
@dirrm share/gnome/help/gdmconfig/C/figures
@dirrm share/gnome/help/gdmconfig/C