aboutsummaryrefslogtreecommitdiff
path: root/x11/gdm
diff options
context:
space:
mode:
authorMaxim Sobolev <sobomax@FreeBSD.org>2002-07-18 10:46:51 +0000
committerMaxim Sobolev <sobomax@FreeBSD.org>2002-07-18 10:46:51 +0000
commitdfed6770732d72ed8cd324aafdc8d1a7f23bdcbd (patch)
tree4f101e8649e2cd0c45565078691d338ade6fea6f /x11/gdm
parentefd269a0460e77933d454463c22853252db34c31 (diff)
downloadports-dfed6770732d72ed8cd324aafdc8d1a7f23bdcbd.tar.gz
ports-dfed6770732d72ed8cd324aafdc8d1a7f23bdcbd.zip
Notes
Diffstat (limited to 'x11/gdm')
-rw-r--r--x11/gdm/Makefile12
-rw-r--r--x11/gdm/files/patch-aq11
-rw-r--r--x11/gdm/files/patch-configure24
-rw-r--r--x11/gdm/files/patch-ltmain.sh28
-rw-r--r--x11/gdm/pkg-plist6
5 files changed, 21 insertions, 60 deletions
diff --git a/x11/gdm/Makefile b/x11/gdm/Makefile
index 7a72bb1729fb..0a95c9608c1f 100644
--- a/x11/gdm/Makefile
+++ b/x11/gdm/Makefile
@@ -17,8 +17,9 @@ MAINTAINER= gnome@FreeBSD.org
USE_BZIP2= yes
USE_X_PREFIX= yes
USE_GMAKE= yes
-USE_GNOME= yes
-GNU_CONFIGURE= yes
+USE_GNOMENG= yes
+USE_GNOME= gnomeprefix gnomehack gnomelibs gdkpixbuf
+USE_LIBTOOL= yes
CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include" \
LIBS="-L${LOCALBASE}/lib"
CONFIGURE_TARGET= --target=${MACHINE_ARCH}-unknown-freebsd${OSREL}
@@ -34,12 +35,9 @@ pre-fetch:
${SH} ${PKGINSTALL} ${PKGNAME} PRE-INSTALL
.endif
-pre-patch:
- @${PERL} -pi -e 's|-lpthread|${PTHREAD_LIBS}|g ; \
+post-patch:
+ @${REINPLACE_CMD} -e 's|-lpthread|${PTHREAD_LIBS}|g ; \
s|DATADIRNAME=lib|DATADIRNAME=share|g' ${WRKSRC}/configure
- @find ${WRKSRC} -name "Makefile.in" | xargs ${PERL} -pi -e \
- 's|\$\(datadir\)/gnome/|\$\(datadir\)/|g ; \
- s|\$\(datadir\)/locale|\$\(prefix\)/share/locale|g'
post-install:
.if !defined(BATCH) && !defined(PACKAGE_BUILDING)
diff --git a/x11/gdm/files/patch-aq b/x11/gdm/files/patch-aq
deleted file mode 100644
index ac696b53c1e9..000000000000
--- a/x11/gdm/files/patch-aq
+++ /dev/null
@@ -1,11 +0,0 @@
---- po/Makefile.in.in.orig Thu Aug 16 16:02:46 2001
-+++ po/Makefile.in.in Thu Aug 16 16:02:59 2001
-@@ -23,7 +23,7 @@
- prefix = @prefix@
- exec_prefix = @exec_prefix@
- datadir = @datadir@
--localedir = $(datadir)/locale
-+localedir = $(prefix)/share/locale
- gettextsrcdir = $(datadir)/gettext/po
-
- INSTALL = @INSTALL@
diff --git a/x11/gdm/files/patch-configure b/x11/gdm/files/patch-configure
index c543ff09aa19..1ec92cff826d 100644
--- a/x11/gdm/files/patch-configure
+++ b/x11/gdm/files/patch-configure
@@ -1,12 +1,22 @@
$FreeBSD$
---- configure 2002/03/13 23:11:57 1.3
-+++ configure 2002/03/13 23:16:32
-@@ -8575,6 +8575,52 @@
- fi
+--- configure.orig Wed Mar 13 00:58:30 2002
++++ configure Thu Jul 18 13:27:09 2002
+@@ -5874,6 +5874,7 @@
+
+ # This can be used to rebuild libtool when needed
+ LIBTOOL_DEPS="$ac_aux_dir/ltmain.sh"
++$ac_aux_dir/ltconfig $LIBTOOL_DEPS
+ # Always use our own libtool.
+ LIBTOOL='$(SHELL) $(top_builddir)/libtool'
+@@ -8575,6 +8576,52 @@
+ done
+ fi
++
++
+for ac_hdr in sys/types.h login_cap.h
+do
+ac_safe=`echo "$ac_hdr" | sed 'y%./+-%__p_%'`
@@ -51,8 +61,6 @@ $FreeBSD$
+ echo "$ac_t""no" 1>&6
+fi
+done
-+
-+
+
+
if test x$enable_authentication_scheme = xpam -a x$have_pam = xno ; then
- { echo "configure: error: PAM support requested but not available" 1>&2; exit 1; }
- fi
diff --git a/x11/gdm/files/patch-ltmain.sh b/x11/gdm/files/patch-ltmain.sh
deleted file mode 100644
index 98cb05e4ddb3..000000000000
--- a/x11/gdm/files/patch-ltmain.sh
+++ /dev/null
@@ -1,28 +0,0 @@
-
-$FreeBSD$
-
---- ltmain.sh 2001/08/27 09:51:26 1.1
-+++ ltmain.sh 2001/08/27 09:51:42
-@@ -2408,6 +2408,9 @@
- *-*-netbsd*)
- # Don't link with libc until the a.out ld.so is fixed.
- ;;
-+ *-*-freebsd*)
-+ # FreeBSD doesn't need this...
-+ ;;
- *)
- # Add libc to deplibs on all other systems if necessary.
- if test "$build_libtool_need_lc" = "yes"; then
-@@ -4175,10 +4178,12 @@
- fi
-
- # Install the pseudo-library for information purposes.
-+ if /usr/bin/false; then
- name=`$echo "X$file" | $Xsed -e 's%^.*/%%'`
- instname="$dir/$name"i
- $show "$install_prog $instname $destdir/$name"
- $run eval "$install_prog $instname $destdir/$name" || exit $?
-+ fi
-
- # Maybe install the static library, too.
- test -n "$old_library" && staticlibs="$staticlibs $dir/$old_library"
diff --git a/x11/gdm/pkg-plist b/x11/gdm/pkg-plist
index e31ce00ba3fd..c624f4a19c65 100644
--- a/x11/gdm/pkg-plist
+++ b/x11/gdm/pkg-plist
@@ -166,10 +166,4 @@ share/locale/zh_TW/LC_MESSAGES/gdm.mo
@dirrm share/gnome/help/gdm/C/images
@dirrm share/gnome/help/gdm/C
@dirrm share/gnome/help/gdm
-@dirrm share/gnome/gdm
@dirrm etc/pam.d
-@dirrm etc/gdm/Sessions
-@dirrm etc/gdm/PreSession
-@dirrm etc/gdm/PostSession
-@dirrm etc/gdm/Init
-@dirrm etc/gdm