aboutsummaryrefslogtreecommitdiff
path: root/x11/gnome-applets/Makefile
diff options
context:
space:
mode:
authorMichael Johnson <ahze@FreeBSD.org>2006-05-27 03:52:11 +0000
committerMichael Johnson <ahze@FreeBSD.org>2006-05-27 03:52:11 +0000
commitcfa3bb1e0a326f63ca6496a6f534b2c96d72553d (patch)
treed75984e8ea68b53fc669dd5a4dd875564fec870f /x11/gnome-applets/Makefile
parent9bc429ab3b873297d585aedf25018e084d537008 (diff)
Notes
Diffstat (limited to 'x11/gnome-applets/Makefile')
-rw-r--r--x11/gnome-applets/Makefile10
1 files changed, 10 insertions, 0 deletions
diff --git a/x11/gnome-applets/Makefile b/x11/gnome-applets/Makefile
index 4e6cd0755f3b..cf84f04a3b2e 100644
--- a/x11/gnome-applets/Makefile
+++ b/x11/gnome-applets/Makefile
@@ -45,6 +45,8 @@ GCONF_SCHEMAS= charpick.schemas drivemount.schemas geyes.schemas \
mixer.schemas multiload.schemas \
stickynotes.schemas
+OPTIONS= MINI_COMMANDER "Enable mini-commander applet" off
+
FREEBSD_SYS?= /usr/src/sys
.include <bsd.port.pre.mk>
@@ -69,6 +71,14 @@ PLIST_SUB+= CPUFREQ=""
GCONF_SCHEMAS+= cpufreq-applet.schemas
.endif
+.if defined(WITH_MINI_COMMANDER)
+CONFIGURE_ARGS+= --enable-mini-commander
+GCONF_SCHEMAS+= mini-commander-global.schemas mini-commander.schemas
+PLIST_SUB+= COMMANDER=""
+.else
+PLIST_SUB+= COMMANDER="@comment "
+.endif
+
post-patch:
@${REINPLACE_CMD} -e 's|malloc.h|stdlib.h|g' \
${WRKSRC}/libgweather/weather-met.c