aboutsummaryrefslogtreecommitdiff
path: root/x11/gnome-applets/Makefile
diff options
context:
space:
mode:
authorJoe Marcus Clarke <marcus@FreeBSD.org>2006-04-30 00:47:21 +0000
committerJoe Marcus Clarke <marcus@FreeBSD.org>2006-04-30 00:47:21 +0000
commit798e9bed2a389dce8a970e15b68176fd49f442db (patch)
tree9dc5597aab073298ec381964f72cd853b3dd366c /x11/gnome-applets/Makefile
parent48b92584b0722f7f6ca412e6cfe16f1381e043cc (diff)
downloadports-798e9bed2a389dce8a970e15b68176fd49f442db.tar.gz
ports-798e9bed2a389dce8a970e15b68176fd49f442db.zip
Notes
Diffstat (limited to 'x11/gnome-applets/Makefile')
-rw-r--r--x11/gnome-applets/Makefile25
1 files changed, 18 insertions, 7 deletions
diff --git a/x11/gnome-applets/Makefile b/x11/gnome-applets/Makefile
index e2b745126db9..4e6cd0755f3b 100644
--- a/x11/gnome-applets/Makefile
+++ b/x11/gnome-applets/Makefile
@@ -3,14 +3,14 @@
# Whom: Joe Marcus Clarke <marcus@FreeBSD.org>
#
# $FreeBSD$
-# $MCom: ports/x11/gnomeapplets2/Makefile,v 1.94 2005/10/08 19:41:40 marcus Exp $
+# $MCom: ports/x11/gnomeapplets2/Makefile,v 1.111 2006/04/13 07:52:40 bland Exp $
#
PORTNAME= gnomeapplets2
-PORTVERSION= 2.12.3
+PORTVERSION= 2.14.1
CATEGORIES= x11 gnome
MASTER_SITES= ${MASTER_SITE_GNOME}
-MASTER_SITE_SUBDIR= sources/gnome-applets/2.12
+MASTER_SITE_SUBDIR= sources/gnome-applets/${PORTVERSION:C/^([0-9]+\.[0-9]+).*/\1/}
DISTNAME= gnome-applets-${PORTVERSION}
DIST_SUBDIR= gnome2
@@ -18,28 +18,30 @@ MAINTAINER= gnome@FreeBSD.org
COMMENT= Applets components for the Gnome 2 Desktop Environment
BUILD_DEPENDS= ${X11BASE}/libdata/pkgconfig/gnome-system-tools.pc:${PORTSDIR}/sysutils/gnomesystemtools
-LIB_DEPENDS= gtop-2.0:${PORTSDIR}/devel/libgtop2 \
+LIB_DEPENDS= gtop-2.0.7:${PORTSDIR}/devel/libgtop2 \
xklavier.10:${PORTSDIR}/x11/libxklavier \
gucharmap.4:${PORTSDIR}/deskutils/gucharmap
RUN_DEPENDS= ${X11BASE}/libdata/pkgconfig/system-tools-backends.pc:${PORTSDIR}/sysutils/gnomesystemtools
+USE_GETTEXT= yes
USE_BZIP2= yes
USE_X_PREFIX= yes
USE_GMAKE= yes
GNOME_DESKTOP_VERSION=2
INSTALLS_OMF= yes
INSTALLS_ICONS= yes
+INSTALLS_SHLIB= yes
USE_GNOME= gnomeprefix gnomehack intlhack gnomepanel \
gail gnomedocutils
USE_GSTREAMER= yes
GNU_CONFIGURE= yes
-CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include" \
- LDFLAGS="-L${LOCALBASE}/lib" \
+CONFIGURE_ARGS= --with-gstreamer=0.10
+CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include ${PTHREAD_CFLAGS}" \
+ LDFLAGS="-L${LOCALBASE}/lib ${PTHREAD_LIBS}" \
FREEBSD_SYS=${FREEBSD_SYS}
GCONF_SCHEMAS= charpick.schemas drivemount.schemas geyes.schemas \
gswitchit.schemas gtik.schemas gweather.schemas \
- mini-commander-global.schemas mini-commander.schemas \
mixer.schemas multiload.schemas \
stickynotes.schemas
@@ -47,6 +49,11 @@ FREEBSD_SYS?= /usr/src/sys
.include <bsd.port.pre.mk>
+.if exists(${LOCALBASE}/libdata/pkgconfig/libnotify.pc) || \
+ defined(WITH_LIBNOTIFY)
+LIB_DEPENDS+= notify:${PORTSDIR}/devel/libnotify
+.endif
+
.if ${ARCH} != "i386" && ${ARCH} != "amd64"
CONFIGURE_ENV+= CFLAGS="${CFLAGS} -fPIC"
PLIST_SUB= BATTERY="@comment "
@@ -62,4 +69,8 @@ PLIST_SUB+= CPUFREQ=""
GCONF_SCHEMAS+= cpufreq-applet.schemas
.endif
+post-patch:
+ @${REINPLACE_CMD} -e 's|malloc.h|stdlib.h|g' \
+ ${WRKSRC}/libgweather/weather-met.c
+
.include <bsd.port.post.mk>