aboutsummaryrefslogtreecommitdiff
path: root/x11/gnome-panel/Makefile
diff options
context:
space:
mode:
authorJean-Yves Lefort <jylefort@FreeBSD.org>2006-05-11 02:14:35 +0000
committerJean-Yves Lefort <jylefort@FreeBSD.org>2006-05-11 02:14:35 +0000
commit047cf975af43b1465d97b2ff1a457eb262c8f712 (patch)
tree5485fff4f30ffdf71bc737c3c86dc6fec6fbd3a9 /x11/gnome-panel/Makefile
parenteb8425d65f66b19bc64c2c9130c8f78a9e366fa4 (diff)
Notes
Diffstat (limited to 'x11/gnome-panel/Makefile')
-rw-r--r--x11/gnome-panel/Makefile14
1 files changed, 11 insertions, 3 deletions
diff --git a/x11/gnome-panel/Makefile b/x11/gnome-panel/Makefile
index 06d7aebc679d..34a93db968ca 100644
--- a/x11/gnome-panel/Makefile
+++ b/x11/gnome-panel/Makefile
@@ -17,16 +17,22 @@ DIST_SUBDIR= gnome2
MAINTAINER= gnome@FreeBSD.org
COMMENT= Panel component for the GNOME 2 Desktop
+USE_BZIP2= yes
+PREFIX?= ${X11BASE}
+
+.if !defined(REFERENCE_PORT)
+
+PORTREVISION= 1
+
RUN_DEPENDS= gnome-menu-editor:${PORTSDIR}/deskutils/gnome-menu-editor
USE_GETTEXT= yes
-USE_BZIP2= yes
INSTALLS_OMF= yes
INSTALLS_SHLIB= yes
INSTALLS_ICONS= yes
-USE_X_PREFIX= yes
+USE_XLIB= yes
USE_GNOME= gnomeprefix gnomehack intlhack gnomedesktop \
- libwnck gnomemenus gnomedocutils ltverhack
+ libwnck gnomemenus gnomedocutils ltverhack referencehack
WANT_GNOME= yes
GNOME_DESKTOP_VERSION=2
USE_GMAKE= yes
@@ -66,3 +72,5 @@ post-patch:
.endif
.include <bsd.port.post.mk>
+
+.endif