aboutsummaryrefslogtreecommitdiff
path: root/x11/gnome-panel
diff options
context:
space:
mode:
authorJoe Marcus Clarke <marcus@FreeBSD.org>2008-03-24 03:52:36 +0000
committerJoe Marcus Clarke <marcus@FreeBSD.org>2008-03-24 03:52:36 +0000
commit6f32add9a75efb180e462ffbdb0b080bc88088e3 (patch)
tree0fc7af36e22fc0dc7c1dc8aacabf6fe117e881da /x11/gnome-panel
parentb8d245fedd5842fb6d68d0bdc6539885555a84e3 (diff)
downloadports-6f32add9a75efb180e462ffbdb0b080bc88088e3.tar.gz
ports-6f32add9a75efb180e462ffbdb0b080bc88088e3.zip
Notes
Diffstat (limited to 'x11/gnome-panel')
-rw-r--r--x11/gnome-panel/Makefile25
-rw-r--r--x11/gnome-panel/distinfo6
-rw-r--r--x11/gnome-panel/files/iso3166.tab268
-rw-r--r--x11/gnome-panel/files/patch-applets_clock_clock-location.c59
-rw-r--r--x11/gnome-panel/files/patch-applets_clock_clock-zonetable.c14
-rw-r--r--x11/gnome-panel/files/patch-applets_clock_clock.c11
-rw-r--r--x11/gnome-panel/files/patch-applets_clock_gweather-xml.c11
-rw-r--r--x11/gnome-panel/files/patch-po_ko.po31
-rw-r--r--x11/gnome-panel/pkg-plist32
9 files changed, 426 insertions, 31 deletions
diff --git a/x11/gnome-panel/Makefile b/x11/gnome-panel/Makefile
index f4b9b720b80e..49487cf3f0a7 100644
--- a/x11/gnome-panel/Makefile
+++ b/x11/gnome-panel/Makefile
@@ -3,15 +3,14 @@
# Whom: Joe Marcus Clarke <marcus@FreeBSD.org>
#
# $FreeBSD$
-# $MCom: ports-stable/x11/gnome-panel/Makefile,v 1.1 2007/12/02 00:54:55 marcus Exp $
+# $MCom: ports/x11/gnome-panel/Makefile,v 1.177 2008/03/23 06:13:12 marcus Exp $
#
PORTNAME= gnome-panel
-PORTVERSION= 2.20.3
-PORTREVISION?= 0
+PORTVERSION= 2.22.0
+PORTREVISION?= 2
CATEGORIES= x11 gnome
-MASTER_SITES= ${MASTER_SITE_GNOME}
-MASTER_SITE_SUBDIR= sources/gnome-panel/${PORTVERSION:C/^([0-9]+\.[0-9]+).*/\1/}
+MASTER_SITES= GNOME
DIST_SUBDIR= gnome2
MAINTAINER= gnome@FreeBSD.org
@@ -21,19 +20,24 @@ USE_BZIP2= yes
.if !defined(REFERENCE_PORT)
+LIB_DEPENDS= gweather.0:${PORTSDIR}/net/libgweather \
+ polkit-gnome.0:${PORTSDIR}/sysutils/policykit-gnome
+
USE_GETTEXT= yes
USE_XLIB= yes
INSTALLS_OMF= yes
USE_LDCONFIG= yes
INSTALLS_ICONS= yes
-USE_GNOME= gnomeprefix gnomehack intlhack gnomedesktop \
+USE_GNOME= gnomeprefix gnomehack intlhack gnomedesktop librsvg2 \
libwnck gnomemenus gnomedocutils ltverhack referencehack
WANT_GNOME= yes
GNOME_DESKTOP_VERSION=2
USE_GMAKE= yes
USE_AUTOTOOLS= libtool:15
CONFIGURE_ARGS= --with-kde-datadir=${LOCALBASE}/share \
- --with-kde-docdir=${LOCALBASE}/share/doc
+ --with-kde-docdir=${LOCALBASE}/share/doc \
+ --disable-network-manager \
+ --enable-polkit
CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include" \
LDFLAGS="-L${LOCALBASE}/lib"
@@ -64,6 +68,8 @@ post-patch:
@${FIND} ${WRKSRC} -type f | \
${XARGS} -n 10 ${REINPLACE_CMD} -e \
's|"applications.menu"|"gnome-applications.menu"|'
+ @${REINPLACE_CMD} -e 's|/usr/local|${LOCALBASE}|' \
+ ${WRKSRC}/applets/clock/gweather-xml.c
.if ( ${OSVERSION} > 600000 && ${OSVERSION} < 600006 ) || \
( ${OSVERSION} < 503101 )
.for po in da.po it.po zh_CN.po zh_TW.po
@@ -71,6 +77,11 @@ post-patch:
.endfor
.endif
+post-install:
+ ${MKDIR} ${PREFIX}/share/gnome-panel
+ ${INSTALL_DATA} ${FILESDIR}/iso3166.tab \
+ ${PREFIX}/share/gnome-panel/iso3166.tab
+
.include <bsd.port.post.mk>
.endif
diff --git a/x11/gnome-panel/distinfo b/x11/gnome-panel/distinfo
index 761f01205b24..57f37c4c59d5 100644
--- a/x11/gnome-panel/distinfo
+++ b/x11/gnome-panel/distinfo
@@ -1,3 +1,3 @@
-MD5 (gnome2/gnome-panel-2.20.3.tar.bz2) = 0ddf04cea0859570216319d6f1f8c4d8
-SHA256 (gnome2/gnome-panel-2.20.3.tar.bz2) = fa76158e659ab5d36f016ba9a5117c4d03680e7c94aa174fdcc03200fe2444c9
-SIZE (gnome2/gnome-panel-2.20.3.tar.bz2) = 2829469
+MD5 (gnome2/gnome-panel-2.22.0.tar.bz2) = fe10c920c1f182a2bd5dba98863c786c
+SHA256 (gnome2/gnome-panel-2.22.0.tar.bz2) = 8b2152b35e3d82a640c383b29e99a322595dca23269450ad8d3182bdd94b308a
+SIZE (gnome2/gnome-panel-2.22.0.tar.bz2) = 3267787
diff --git a/x11/gnome-panel/files/iso3166.tab b/x11/gnome-panel/files/iso3166.tab
new file mode 100644
index 000000000000..22ff82083588
--- /dev/null
+++ b/x11/gnome-panel/files/iso3166.tab
@@ -0,0 +1,268 @@
+# $OpenBSD: iso3166.tab,v 1.17 2007/02/02 20:26:51 millert Exp $
+# ISO 3166 alpha-2 country codes
+#
+# @(#)iso3166.tab 8.4
+#
+# From Paul Eggert (2006-09-27):
+#
+# This file contains a table with the following columns:
+# 1. ISO 3166-1 alpha-2 country code, current as of
+# ISO 3166-1 Newsletter No. V-12 (2006-09-26). See:
+# <a href="http://www.iso.org/iso/en/prods-services/iso3166ma/index.html">
+# ISO 3166 Maintenance agency (ISO 3166/MA)
+# </a>.
+# 2. The usual English name for the country,
+# chosen so that alphabetic sorting of subsets produces helpful lists.
+# This is not the same as the English name in the ISO 3166 tables.
+#
+# Columns are separated by a single tab.
+# The table is sorted by country code.
+#
+# Lines beginning with `#' are comments.
+#
+#country-
+#code country name
+AD Andorra
+AE United Arab Emirates
+AF Afghanistan
+AG Antigua & Barbuda
+AI Anguilla
+AL Albania
+AM Armenia
+AN Netherlands Antilles
+AO Angola
+AQ Antarctica
+AR Argentina
+AS Samoa (American)
+AT Austria
+AU Australia
+AW Aruba
+AX Aaland Islands
+AZ Azerbaijan
+BA Bosnia & Herzegovina
+BB Barbados
+BD Bangladesh
+BE Belgium
+BF Burkina Faso
+BG Bulgaria
+BH Bahrain
+BI Burundi
+BJ Benin
+BM Bermuda
+BN Brunei
+BO Bolivia
+BR Brazil
+BS Bahamas
+BT Bhutan
+BV Bouvet Island
+BW Botswana
+BY Belarus
+BZ Belize
+CA Canada
+CC Cocos (Keeling) Islands
+CD Congo (Dem. Rep.)
+CF Central African Rep.
+CG Congo (Rep.)
+CH Switzerland
+CI Cote d'Ivoire
+CK Cook Islands
+CL Chile
+CM Cameroon
+CN China
+CO Colombia
+CR Costa Rica
+CU Cuba
+CV Cape Verde
+CX Christmas Island
+CY Cyprus
+CZ Czech Republic
+DE Germany
+DJ Djibouti
+DK Denmark
+DM Dominica
+DO Dominican Republic
+DZ Algeria
+EC Ecuador
+EE Estonia
+EG Egypt
+EH Western Sahara
+ER Eritrea
+ES Spain
+ET Ethiopia
+FI Finland
+FJ Fiji
+FK Falkland Islands
+FM Micronesia
+FO Faroe Islands
+FR France
+GA Gabon
+GB Britain (UK)
+GD Grenada
+GE Georgia
+GF French Guiana
+GG Guernsey
+GH Ghana
+GI Gibraltar
+GL Greenland
+GM Gambia
+GN Guinea
+GP Guadeloupe
+GQ Equatorial Guinea
+GR Greece
+GS South Georgia & the South Sandwich Islands
+GT Guatemala
+GU Guam
+GW Guinea-Bissau
+GY Guyana
+HK Hong Kong
+HM Heard Island & McDonald Islands
+HN Honduras
+HR Croatia
+HT Haiti
+HU Hungary
+ID Indonesia
+IE Ireland
+IL Israel
+IM Isle of Man
+IN India
+IO British Indian Ocean Territory
+IQ Iraq
+IR Iran
+IS Iceland
+IT Italy
+JE Jersey
+JM Jamaica
+JO Jordan
+JP Japan
+KE Kenya
+KG Kyrgyzstan
+KH Cambodia
+KI Kiribati
+KM Comoros
+KN St Kitts & Nevis
+KP Korea (North)
+KR Korea (South)
+KW Kuwait
+KY Cayman Islands
+KZ Kazakhstan
+LA Laos
+LB Lebanon
+LC St Lucia
+LI Liechtenstein
+LK Sri Lanka
+LR Liberia
+LS Lesotho
+LT Lithuania
+LU Luxembourg
+LV Latvia
+LY Libya
+MA Morocco
+MC Monaco
+MD Moldova
+ME Montenegro
+MG Madagascar
+MH Marshall Islands
+MK Macedonia
+ML Mali
+MM Myanmar (Burma)
+MN Mongolia
+MO Macau
+MP Northern Mariana Islands
+MQ Martinique
+MR Mauritania
+MS Montserrat
+MT Malta
+MU Mauritius
+MV Maldives
+MW Malawi
+MX Mexico
+MY Malaysia
+MZ Mozambique
+NA Namibia
+NC New Caledonia
+NE Niger
+NF Norfolk Island
+NG Nigeria
+NI Nicaragua
+NL Netherlands
+NO Norway
+NP Nepal
+NR Nauru
+NU Niue
+NZ New Zealand
+OM Oman
+PA Panama
+PE Peru
+PF French Polynesia
+PG Papua New Guinea
+PH Philippines
+PK Pakistan
+PL Poland
+PM St Pierre & Miquelon
+PN Pitcairn
+PR Puerto Rico
+PS Palestine
+PT Portugal
+PW Palau
+PY Paraguay
+QA Qatar
+RE Reunion
+RO Romania
+RS Serbia
+RU Russia
+RW Rwanda
+SA Saudi Arabia
+SB Solomon Islands
+SC Seychelles
+SD Sudan
+SE Sweden
+SG Singapore
+SH St Helena
+SI Slovenia
+SJ Svalbard & Jan Mayen
+SK Slovakia
+SL Sierra Leone
+SM San Marino
+SN Senegal
+SO Somalia
+SR Suriname
+ST Sao Tome & Principe
+SV El Salvador
+SY Syria
+SZ Swaziland
+TC Turks & Caicos Is
+TD Chad
+TF French Southern & Antarctic Lands
+TG Togo
+TH Thailand
+TJ Tajikistan
+TK Tokelau
+TL East Timor
+TM Turkmenistan
+TN Tunisia
+TO Tonga
+TR Turkey
+TT Trinidad & Tobago
+TV Tuvalu
+TW Taiwan
+TZ Tanzania
+UA Ukraine
+UG Uganda
+UM US minor outlying islands
+US United States
+UY Uruguay
+UZ Uzbekistan
+VA Vatican City
+VC St Vincent
+VE Venezuela
+VG Virgin Islands (UK)
+VI Virgin Islands (US)
+VN Vietnam
+VU Vanuatu
+WF Wallis & Futuna
+WS Samoa (western)
+YE Yemen
+YT Mayotte
+ZA South Africa
+ZM Zambia
+ZW Zimbabwe
diff --git a/x11/gnome-panel/files/patch-applets_clock_clock-location.c b/x11/gnome-panel/files/patch-applets_clock_clock-location.c
new file mode 100644
index 000000000000..1bb485f32586
--- /dev/null
+++ b/x11/gnome-panel/files/patch-applets_clock_clock-location.c
@@ -0,0 +1,59 @@
+--- applets/clock/clock-location.c.orig 2008-03-22 21:14:45.000000000 -0400
++++ applets/clock/clock-location.c 2008-03-23 02:11:34.000000000 -0400
+@@ -28,6 +28,8 @@
+ #include "set-timezone.h"
+ #include "gweather-xml.h"
+
++#define daylight 1
++
+ G_DEFINE_TYPE (ClockLocation, clock_location, G_TYPE_OBJECT)
+
+ typedef struct {
+@@ -62,6 +64,7 @@ static void clock_location_unset_tz (Clo
+ static void setup_weather_updates (ClockLocation *loc);
+ static void add_to_network_monitor (ClockLocation *loc);
+ static void remove_from_network_monitor (ClockLocation *loc);
++static gchar *clock_location_guess_zone (ClockZoneTable *zones);
+
+ #define PRIVATE(o) (G_TYPE_INSTANCE_GET_PRIVATE ((o), CLOCK_LOCATION_TYPE, ClockLocationPrivate))
+
+@@ -271,7 +274,6 @@ parse_etc_sysconfig_clock (void)
+ }
+ }
+ }
+-
+ out:
+ if (lines)
+ g_strfreev (lines);
+@@ -298,7 +300,11 @@ zone_from_etc_sysconfig_clock (void)
+
+ parse_etc_sysconfig_clock ();
+
++#ifndef __FreeBSD__
+ file = g_file_new_for_path ("/etc/sysconfig/clock");
++#else
++ file = g_file_new_for_path ("/etc/localtime");
++#endif
+
+ monitor = g_file_monitor_file (file, G_FILE_MONITOR_NONE,
+ NULL, NULL);
+@@ -632,10 +638,17 @@ gboolean
+ clock_location_is_current (ClockLocation *loc)
+ {
+ ClockLocationPrivate *priv = PRIVATE (loc);
+- const char *zone;
++ ClockZoneTable *zones;
++ char *zone;
+
+- if ((zone = zone_from_etc_sysconfig_clock ()))
++ zones = clock_zonetable_new (SYSTEM_ZONEINFODIR);
++
++ if ((zone = clock_location_guess_zone (zones))) {
++ g_object_unref (zones);
+ return strcmp (zone, priv->timezone) == 0;
++ }
++
++ g_object_unref (zones);
+
+ return clock_location_get_offset (loc) == 0;
+ }
diff --git a/x11/gnome-panel/files/patch-applets_clock_clock-zonetable.c b/x11/gnome-panel/files/patch-applets_clock_clock-zonetable.c
new file mode 100644
index 000000000000..0df281fd941d
--- /dev/null
+++ b/x11/gnome-panel/files/patch-applets_clock_clock-zonetable.c
@@ -0,0 +1,14 @@
+--- applets/clock/clock-zonetable.c.orig 2008-01-20 13:32:13.000000000 -0500
++++ applets/clock/clock-zonetable.c 2008-01-20 13:35:34.000000000 -0500
+@@ -124,7 +124,10 @@ clock_zonetable_new (gchar *zoneinfodir)
+ priv = PRIVATE (this);
+
+ priv->zonetab = g_build_filename (zoneinfodir, "zone.tab", NULL);
+- priv->iso3166 = g_build_filename (zoneinfodir, "iso3166.tab", NULL);
++ /*priv->iso3166 = g_build_filename (zoneinfodir, "iso3166.tab", NULL);*/
++ /* FreeBSD doesn't include iso3166.tab, so we install it especially
++ * for this clock. */
++ priv->iso3166 = g_build_filename (DATADIR, "gnome-panel", "iso3166.tab", NULL);
+
+ #ifdef CLOCK_TEXTDOMAIN
+ /* this is used when clock is embedded in the gnome-panel
diff --git a/x11/gnome-panel/files/patch-applets_clock_clock.c b/x11/gnome-panel/files/patch-applets_clock_clock.c
new file mode 100644
index 000000000000..5acc58b408c6
--- /dev/null
+++ b/x11/gnome-panel/files/patch-applets_clock_clock.c
@@ -0,0 +1,11 @@
+--- applets/clock/clock.c.orig 2008-02-26 14:17:49.000000000 +0100
++++ applets/clock/clock.c 2008-02-26 18:01:17.000000000 +0100
+@@ -84,6 +84,8 @@
+
+ #define FALLBACK_CONFIG_TOOL "time-admin"
+
++#define daylight 1
++
+ static const char *clock_config_tools [] = {
+ CLOCK_TIME_UTILITY,
+ FALLBACK_CONFIG_TOOL
diff --git a/x11/gnome-panel/files/patch-applets_clock_gweather-xml.c b/x11/gnome-panel/files/patch-applets_clock_gweather-xml.c
new file mode 100644
index 000000000000..7ae87fdd360f
--- /dev/null
+++ b/x11/gnome-panel/files/patch-applets_clock_gweather-xml.c
@@ -0,0 +1,11 @@
+--- applets/clock/gweather-xml.c.orig 2008-01-23 00:51:33.000000000 -0500
++++ applets/clock/gweather-xml.c 2008-01-23 00:52:35.000000000 -0500
+@@ -359,7 +359,7 @@ gweather_xml_load_locations( GtkTreeView
+ #ifdef GWEATHER_XML_LOCATION
+ xml = xmlNewTextReaderFilename (GWEATHER_XML_LOCATION "Locations.xml");
+ #else
+- xml = xmlNewTextReaderFilename ("/usr/share/gnome-applets/gweather/Locations.xml");
++ xml = xmlNewTextReaderFilename ("/usr/local/share/libgweather/Locations.xml");
+ #endif
+ if( xml == NULL )
+ goto error_out;
diff --git a/x11/gnome-panel/files/patch-po_ko.po b/x11/gnome-panel/files/patch-po_ko.po
index 45d98a92c0be..7de508a0eba4 100644
--- a/x11/gnome-panel/files/patch-po_ko.po
+++ b/x11/gnome-panel/files/patch-po_ko.po
@@ -1,38 +1,29 @@
---- po/ko.po.orig Sun Jul 8 18:23:19 2007
-+++ po/ko.po Sun Jul 8 18:26:46 2007
-@@ -88,7 +88,7 @@
+--- po/ko.po.orig 2008-02-26 18:15:58.000000000 +0100
++++ po/ko.po 2008-02-26 18:16:31.000000000 +0100
+@@ -95,7 +95,7 @@ msgstr "%H:%M"
#. * possible.
- #: ../applets/clock/calendar-window.c:233
+ #: ../applets/clock/calendar-window.c:250
msgid "%b %d"
-msgstr "%b %e일"
+msgstr "%B %e일"
- #: ../applets/clock/calendar-window.c:741
- msgid "_Tasks"
-@@ -129,7 +129,7 @@
+ #: ../applets/clock/calendar-window.c:765
+ msgid "Tasks"
+@@ -146,7 +146,7 @@ msgstr "%H:%M:%S"
#.
- #: ../applets/clock/clock.c:367
+ #: ../applets/clock/clock.c:443
msgid "%a %b %e"
-msgstr "%b %e일 (%a)"
+msgstr "%B %e일 (%a)"
#. translators: reverse the order of these arguments
#. * if the time should come before the
-@@ -156,7 +156,7 @@
- #. Show date in tooltip
- #: ../applets/clock/clock.c:520
- msgid "%A %B %d"
--msgstr "%b %e일 %A"
-+msgstr "%B %e일 %A"
+@@ -207,7 +207,7 @@ msgstr "%p %I:%M"
- #: ../applets/clock/clock.c:534
- msgid "Click to hide your appointments and tasks"
-@@ -188,7 +188,7 @@
-
- #: ../applets/clock/clock.c:1073
+ #: ../applets/clock/clock.c:1590
msgid "%A, %B %d %Y"
-msgstr "%Y년 %b %e일 %A"
+msgstr "%Y년 %B %e일 %A"
- #: ../applets/clock/clock.c:1148
+ #: ../applets/clock/clock.c:1665
#, c-format
diff --git a/x11/gnome-panel/pkg-plist b/x11/gnome-panel/pkg-plist
index 1613aea9ffd5..776e004791d3 100644
--- a/x11/gnome-panel/pkg-plist
+++ b/x11/gnome-panel/pkg-plist
@@ -1,6 +1,7 @@
bin/gnome-desktop-item-edit
bin/gnome-panel
bin/panel-test-applets
+etc/dbus-1/system.d/org.gnome.ClockApplet.Mechanism.conf
@unexec gconftool-2 --direct --config-source=xml::%D/etc/gconf/gconf.xml.defaults --unload %D/etc/gconf/schemas/panel-default-setup.entries /apps/panel > /dev/null || /usr/bin/true
@unexec gconftool-2 --direct --config-source=xml::%D/etc/gconf/gconf.xml.defaults --unload %D/etc/gconf/schemas/panel-default-setup.entries > /dev/null || /usr/bin/true
etc/gconf/schemas/panel-default-setup.entries
@@ -22,9 +23,12 @@ libdata/bonobo/servers/GNOME_Wncklet_Factory.server
libdata/pkgconfig/libpanelapplet-2.0.pc
libexec/clock-applet
libexec/fish-applet-2
+libexec/gnome-clock-applet-mechanism
libexec/notification-area-applet
libexec/wnck-applet
+share/PolicyKit/policy/gnome-clock-applet-mechanism.policy
share/applications/gnome-panel.desktop
+share/dbus-1/system-services/org.gnome.ClockApplet.Mechanism.service
share/gnome-2.0/ui/GNOME_ClockApplet.xml
share/gnome-2.0/ui/GNOME_FishApplet.xml
share/gnome-2.0/ui/GNOME_NotificationAreaApplet.xml
@@ -33,6 +37,7 @@ share/gnome-2.0/ui/GNOME_ShowDesktopApplet.xml
share/gnome-2.0/ui/GNOME_WindowListApplet.xml
share/gnome-2.0/ui/GNOME_WindowMenuApplet.xml
share/gnome-2.0/ui/GNOME_WorkspaceSwitcherApplet.xml
+%%DATADIR%%/glade/clock.glade
%%DATADIR%%/glade/fish.glade
%%DATADIR%%/glade/panel-properties-dialog.glade
%%DATADIR%%/glade/panel-run-dialog.glade
@@ -40,6 +45,18 @@ share/gnome-2.0/ui/GNOME_WorkspaceSwitcherApplet.xml
%%DATADIR%%/glade/timezone.glade
%%DATADIR%%/glade/window-list.glade
%%DATADIR%%/glade/workspace-switcher.glade
+%%DATADIR%%/iso3166.tab
+%%DATADIR%%/pixmaps/clock-calendar-icon.png
+%%DATADIR%%/pixmaps/clock-face-large.svg
+%%DATADIR%%/pixmaps/clock-face-small-day.svg
+%%DATADIR%%/pixmaps/clock-face-small-evening.svg
+%%DATADIR%%/pixmaps/clock-face-small-morning.svg
+%%DATADIR%%/pixmaps/clock-face-small-night.svg
+%%DATADIR%%/pixmaps/clock-face-small.svg
+%%DATADIR%%/pixmaps/clock-map-location-current.png
+%%DATADIR%%/pixmaps/clock-map-location-hilight.png
+%%DATADIR%%/pixmaps/clock-map-location-marker.png
+%%DATADIR%%/pixmaps/clock-map.png
%%DATADIR%%/pixmaps/fishanim.png
%%DATADIR%%/pixmaps/footguy.png
%%DATADIR%%/pixmaps/gnome-gegl2-2.png
@@ -153,6 +170,7 @@ share/gnome/help/fish/uk/fish.xml
share/gnome/help/fish/uk/legal.xml
share/gnome/help/window-list/C/window-list.xml
share/gnome/help/window-list/ca/window-list.xml
+share/gnome/help/window-list/da/window-list.xml
share/gnome/help/window-list/de/figures/window_list_applet.png
share/gnome/help/window-list/de/figures/window_list_group.png
share/gnome/help/window-list/de/figures/window_list_group_applet.png
@@ -180,6 +198,7 @@ share/gnome/help/window-list/zh_TW/legal.xml
share/gnome/help/window-list/zh_TW/window-list.xml
share/gnome/help/workspace-switcher/C/workspace-switcher.xml
share/gnome/help/workspace-switcher/ca/workspace-switcher.xml
+share/gnome/help/workspace-switcher/da/workspace-switcher.xml
share/gnome/help/workspace-switcher/de/figures/workspace_switcher_applet.png
share/gnome/help/workspace-switcher/de/figures/workspacelist_applet.png
share/gnome/help/workspace-switcher/de/legal.xml
@@ -251,6 +270,7 @@ share/icons/hicolor/32x32/apps/gnome-panel-window-list.png
share/icons/hicolor/32x32/apps/gnome-panel-window-menu.png
share/icons/hicolor/32x32/apps/gnome-panel-workspace-switcher.png
share/icons/hicolor/32x32/apps/gnome-panel.png
+share/icons/hicolor/48x48/apps/gnome-panel.png
share/icons/hicolor/scalable/apps/gnome-panel-clock.svg
share/icons/hicolor/scalable/apps/gnome-panel-drawer.svg
share/icons/hicolor/scalable/apps/gnome-panel-fish.svg
@@ -266,6 +286,7 @@ share/idl/gnome-panel-2.0/GNOME_Panel.idl
share/locale/af/LC_MESSAGES/gnome-panel-2.0.mo
share/locale/am/LC_MESSAGES/gnome-panel-2.0.mo
share/locale/ar/LC_MESSAGES/gnome-panel-2.0.mo
+share/locale/as/LC_MESSAGES/gnome-panel-2.0.mo
share/locale/az/LC_MESSAGES/gnome-panel-2.0.mo
share/locale/be/LC_MESSAGES/gnome-panel-2.0.mo
share/locale/be@latin/LC_MESSAGES/gnome-panel-2.0.mo
@@ -325,6 +346,7 @@ share/locale/oc/LC_MESSAGES/gnome-panel-2.0.mo
share/locale/or/LC_MESSAGES/gnome-panel-2.0.mo
share/locale/pa/LC_MESSAGES/gnome-panel-2.0.mo
share/locale/pl/LC_MESSAGES/gnome-panel-2.0.mo
+share/locale/ps/LC_MESSAGES/gnome-panel-2.0.mo
share/locale/pt/LC_MESSAGES/gnome-panel-2.0.mo
share/locale/pt_BR/LC_MESSAGES/gnome-panel-2.0.mo
share/locale/ro/LC_MESSAGES/gnome-panel-2.0.mo
@@ -395,6 +417,7 @@ share/omf/gnome-panel/workspace-switcher-zh_CN.omf
share/omf/gnome-panel/workspace-switcher-zh_TW.omf
share/omf/window-list/window-list-C.omf
share/omf/window-list/window-list-ca.omf
+share/omf/window-list/window-list-da.omf
share/omf/window-list/window-list-de.omf
share/omf/window-list/window-list-el.omf
share/omf/window-list/window-list-es.omf
@@ -409,6 +432,7 @@ share/omf/window-list/window-list-uk.omf
share/omf/window-list/window-list-zh_CN.omf
share/omf/workspace-switcher/workspace-switcher-C.omf
share/omf/workspace-switcher/workspace-switcher-ca.omf
+share/omf/workspace-switcher/workspace-switcher-da.omf
share/omf/workspace-switcher/workspace-switcher-de.omf
share/omf/workspace-switcher/workspace-switcher-el.omf
share/omf/workspace-switcher/workspace-switcher-es.omf
@@ -448,6 +472,7 @@ share/omf/workspace-switcher/workspace-switcher-vi.omf
@dirrm share/gnome/help/workspace-switcher/el
@dirrm share/gnome/help/workspace-switcher/de/figures
@dirrm share/gnome/help/workspace-switcher/de
+@dirrm share/gnome/help/workspace-switcher/da
@dirrm share/gnome/help/workspace-switcher/ca
@dirrm share/gnome/help/workspace-switcher/C
@dirrm share/gnome/help/workspace-switcher
@@ -468,6 +493,7 @@ share/omf/workspace-switcher/workspace-switcher-vi.omf
@dirrm share/gnome/help/window-list/el
@dirrm share/gnome/help/window-list/de/figures
@dirrm share/gnome/help/window-list/de
+@dirrm share/gnome/help/window-list/da
@dirrm share/gnome/help/window-list/ca
@dirrm share/gnome/help/window-list/C
@dirrm share/gnome/help/window-list
@@ -543,6 +569,7 @@ share/omf/workspace-switcher/workspace-switcher-vi.omf
@dirrm %%DATADIR%%/pixmaps
@dirrm %%DATADIR%%/glade
@dirrm %%DATADIR%%
+@dirrmtry share/applications
@dirrm include/panel-2.0
@dirrmtry share/locale/zu/LC_MESSAGES
@dirrmtry share/locale/zu
@@ -562,6 +589,8 @@ share/omf/workspace-switcher/workspace-switcher-vi.omf
@dirrmtry share/locale/si
@dirrmtry share/locale/rw/LC_MESSAGES
@dirrmtry share/locale/rw
+@dirrmtry share/locale/ps/LC_MESSAGES
+@dirrmtry share/locale/ps
@dirrmtry share/locale/oc/LC_MESSAGES
@dirrmtry share/locale/oc
@dirrmtry share/locale/nso/LC_MESSAGES
@@ -584,4 +613,5 @@ share/omf/workspace-switcher/workspace-switcher-vi.omf
@dirrmtry share/locale/bn_IN
@dirrmtry share/locale/be@latin/LC_MESSAGES
@dirrmtry share/locale/be@latin
-@dirrmtry share/applications
+@dirrmtry share/locale/as/LC_MESSAGES
+@dirrmtry share/locale/as