aboutsummaryrefslogtreecommitdiff
path: root/x11/gnome-panel
diff options
context:
space:
mode:
authorKoop Mast <kwm@FreeBSD.org>2013-03-19 10:40:22 +0000
committerKoop Mast <kwm@FreeBSD.org>2013-03-19 10:40:22 +0000
commit2a3357182d8cb640f374f8c60b71b6c99ec43843 (patch)
tree7a5f4c1c91d14d9fcab2b30589db732cde4a3725 /x11/gnome-panel
parent92fdeef4740a0893f904a81b5150a5e3f5604b10 (diff)
downloadports-2a3357182d8cb640f374f8c60b71b6c99ec43843.tar.gz
ports-2a3357182d8cb640f374f8c60b71b6c99ec43843.zip
Notes
Diffstat (limited to 'x11/gnome-panel')
-rw-r--r--x11/gnome-panel/Makefile35
1 files changed, 17 insertions, 18 deletions
diff --git a/x11/gnome-panel/Makefile b/x11/gnome-panel/Makefile
index 96b627b3a43f..4ffd81761c35 100644
--- a/x11/gnome-panel/Makefile
+++ b/x11/gnome-panel/Makefile
@@ -3,12 +3,12 @@
# Whom: Joe Marcus Clarke <marcus@FreeBSD.org>
#
# $FreeBSD$
-# $MCom: ports/x11/gnome-panel/Makefile,v 1.230 2010/11/17 13:01:32 kwm Exp $
+# $MCom: ports/x11/gnome-panel/Makefile,v 1.237 2012/10/25 09:21:00 kwm Exp $
#
PORTNAME= gnome-panel
PORTVERSION= 2.32.1
-PORTREVISION?= 1
+PORTREVISION?= 2
CATEGORIES= x11 gnome
MASTER_SITES= GNOME
DIST_SUBDIR= gnome2
@@ -20,9 +20,11 @@ USE_BZIP2= yes
.if !defined(REFERENCE_PORT)
-LIB_DEPENDS= gweather.1:${PORTSDIR}/net/libgweather \
- dbus-glib-1.2:${PORTSDIR}/devel/dbus-glib \
- canberra-gtk.0:${PORTSDIR}/audio/libcanberra
+LIB_DEPENDS= gweather:${PORTSDIR}/net/libgweather \
+ dbus-glib-1:${PORTSDIR}/devel/dbus-glib \
+ canberra-gtk:${PORTSDIR}/audio/libcanberra
+
+CONFLICTS= gnome-panel-3.[0-9]* mate-panel-*
USE_GETTEXT= yes
USE_XORG= ice sm x11 xau xrandr
@@ -30,9 +32,9 @@ USE_PYTHON= yes
INSTALLS_OMF= yes
USE_LDCONFIG= yes
INSTALLS_ICONS= yes
-USE_GNOME= gnomeprefix gnomehack intlhack gnomedesktop libwnck gnomemenus \
+USES= pathfix
+USE_GNOME= gnomeprefix intlhack gnomedesktop libwnck gnomemenus \
gnomedocutils ltverhack referencehack librsvg2
-WANT_GNOME= yes
USE_GMAKE= yes
USE_AUTOTOOLS= libtool
CONFIGURE_ARGS= --disable-network-manager
@@ -46,24 +48,21 @@ GCONF_SCHEMAS= clock.schemas fish.schemas \
panel-toplevel.schemas window-list.schemas \
workspace-switcher.schemas
-OPTIONS= EVOLUTION "use the Evolution calendar if installed" on \
- BONOBO "Support for bonobo applets aka Gnome 2 applets" on
-
-.if defined(PACKAGE_BUILDING)
-.undef WITHOUT_GNOME
-WITH_GNOME= yes
-.endif
+OPTIONS_DEFINE= EVOLUTION BONOBO
+OPTIONS_DEFAULT=EVOLUTION BONOBO
+EVOLUTION_DESC= Use the Evolution calendar
+BONOBO_DESC= Support for bonobo applets aka Gnome 2 applets
-.include <bsd.port.pre.mk>
+.include <bsd.port.options.mk>
-.if !defined(WITHOUT_EVOLUTION) && ${HAVE_GNOME:Mevolutiondataserver}!=""
+.if ${PORT_OPTIONS:MEVOLUTION}
USE_GNOME+= evolutiondataserver
#CONFIGURE_ARGS+=--enable-eds
.else
CONFIGURE_ARGS+=--disable-eds
.endif
-.if defined(WITH_BONOBO)
+.if ${PORT_OPTIONS:MBONOBO}
USE_GNOME+= libbonoboui
CONFIGURE_ARGS+=--enable-bonobo
PLIST_SUB+= BONOBO=""
@@ -86,6 +85,6 @@ post-install:
@${MKDIR} ${PREFIX}/lib/gnome-panel/modules
-${LOCALBASE}/bin/gio-querymodules ${PREFIX}/lib/gnome-panel/modules
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>
.endif