aboutsummaryrefslogtreecommitdiff
path: root/x11/gnome-panel
diff options
context:
space:
mode:
authorJoe Marcus Clarke <marcus@FreeBSD.org>2009-11-28 20:06:37 +0000
committerJoe Marcus Clarke <marcus@FreeBSD.org>2009-11-28 20:06:37 +0000
commitf76d32b8e89fed7c0e459c1a7fe7a4b57661b01c (patch)
treead29e6808ff698f84e08dab8e047f0ae72838df9 /x11/gnome-panel
parent873cae3ab41a109b6f9cf9f4149f101d6d996235 (diff)
downloadports-f76d32b8e89fed7c0e459c1a7fe7a4b57661b01c.tar.gz
ports-f76d32b8e89fed7c0e459c1a7fe7a4b57661b01c.zip
Notes
Diffstat (limited to 'x11/gnome-panel')
-rw-r--r--x11/gnome-panel/Makefile17
-rw-r--r--x11/gnome-panel/distinfo6
-rw-r--r--x11/gnome-panel/files/patch-applets_clock_clock.c16
-rw-r--r--x11/gnome-panel/files/patch-config.h.in11
-rw-r--r--x11/gnome-panel/files/patch-configure68
-rw-r--r--x11/gnome-panel/files/patch-gnome-panel_panel-multiscreen.c59
-rw-r--r--x11/gnome-panel/pkg-plist155
7 files changed, 146 insertions, 186 deletions
diff --git a/x11/gnome-panel/Makefile b/x11/gnome-panel/Makefile
index cf428bd304e2..d535db2a1adb 100644
--- a/x11/gnome-panel/Makefile
+++ b/x11/gnome-panel/Makefile
@@ -3,11 +3,11 @@
# Whom: Joe Marcus Clarke <marcus@FreeBSD.org>
#
# $FreeBSD$
-# $MCom: ports-stable/x11/gnome-panel/Makefile,v 1.3 2009/04/16 08:01:26 kwm Exp $
+# $MCom: ports/x11/gnome-panel/Makefile,v 1.208 2009/10/12 13:36:46 avl Exp $
#
PORTNAME= gnome-panel
-PORTVERSION= 2.26.3
+PORTVERSION= 2.28.0
PORTREVISION?= 1
CATEGORIES= x11 gnome
MASTER_SITES= GNOME
@@ -21,21 +21,20 @@ USE_BZIP2= yes
.if !defined(REFERENCE_PORT)
LIB_DEPENDS= gweather.1:${PORTSDIR}/net/libgweather \
- polkit-gnome.0:${PORTSDIR}/sysutils/policykit-gnome
+ polkit-gnome.0:${PORTSDIR}/sysutils/policykit-gnome
USE_GETTEXT= yes
INSTALLS_OMF= yes
USE_LDCONFIG= yes
INSTALLS_ICONS= yes
USE_GNOME= gnomeprefix gnomehack intlhack gnomedesktop librsvg2 \
- libwnck gnomemenus gnomedocutils ltverhack referencehack
+ libwnck gnomemenus gnomedocutils ltverhack referencehack \
+ libgnomeui
WANT_GNOME= yes
GNOME_DESKTOP_VERSION=2
USE_GMAKE= yes
USE_AUTOTOOLS= libtool:22
-CONFIGURE_ARGS= --with-kde-datadir=${LOCALBASE}/share \
- --with-kde-docdir=${LOCALBASE}/share/doc \
- --disable-network-manager \
+CONFIGURE_ARGS= --disable-network-manager \
--enable-polkit
CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include" \
LDFLAGS="-L${LOCALBASE}/lib"
@@ -69,9 +68,7 @@ post-patch:
's|"applications.menu"|"gnome-applications.menu"|'
@${REINPLACE_CMD} -e 's|xsltproc -o| xsltproc --nonet -o|g' \
${WRKSRC}/help/clock/Makefile.in \
- ${WRKSRC}/help/fish/Makefile.in \
- ${WRKSRC}/help/window-list/Makefile.in \
- ${WRKSRC}/help/workspace-switcher/Makefile.in
+ ${WRKSRC}/help/fish/Makefile.in
.include <bsd.port.post.mk>
diff --git a/x11/gnome-panel/distinfo b/x11/gnome-panel/distinfo
index d6092bc525e8..74972b3b2ea9 100644
--- a/x11/gnome-panel/distinfo
+++ b/x11/gnome-panel/distinfo
@@ -1,3 +1,3 @@
-MD5 (gnome2/gnome-panel-2.26.3.tar.bz2) = 38de69896976d57abb4f4720fef62fcf
-SHA256 (gnome2/gnome-panel-2.26.3.tar.bz2) = b50fa78df3e94327e6478fbf8d0addfc0dde1f2022ffc39066bb46040ad3778e
-SIZE (gnome2/gnome-panel-2.26.3.tar.bz2) = 2988811
+MD5 (gnome2/gnome-panel-2.28.0.tar.bz2) = 9f0ea283d44bbcce67dc2e8a02fe9fad
+SHA256 (gnome2/gnome-panel-2.28.0.tar.bz2) = c1168c0c8f84692002557d60870c782f4831635080d2c52cd2a3665fb7718465
+SIZE (gnome2/gnome-panel-2.28.0.tar.bz2) = 2976766
diff --git a/x11/gnome-panel/files/patch-applets_clock_clock.c b/x11/gnome-panel/files/patch-applets_clock_clock.c
index 5acc58b408c6..a9b459b74091 100644
--- a/x11/gnome-panel/files/patch-applets_clock_clock.c
+++ b/x11/gnome-panel/files/patch-applets_clock_clock.c
@@ -1,11 +1,11 @@
---- applets/clock/clock.c.orig 2008-02-26 14:17:49.000000000 +0100
-+++ applets/clock/clock.c 2008-02-26 18:01:17.000000000 +0100
-@@ -84,6 +84,8 @@
-
- #define FALLBACK_CONFIG_TOOL "time-admin"
+--- applets/clock/clock.c.orig 2009-07-01 15:06:23.000000000 +0200
++++ applets/clock/clock.c 2009-07-19 15:59:26.000000000 +0200
+@@ -71,6 +71,8 @@
+ #include "set-timezone.h"
+ #include "system-timezone.h"
+#define daylight 1
+
- static const char *clock_config_tools [] = {
- CLOCK_TIME_UTILITY,
- FALLBACK_CONFIG_TOOL
+ #define INTERNETSECOND (864)
+ #define INTERNETBEAT (86400)
+
diff --git a/x11/gnome-panel/files/patch-config.h.in b/x11/gnome-panel/files/patch-config.h.in
deleted file mode 100644
index 8a59166a57b7..000000000000
--- a/x11/gnome-panel/files/patch-config.h.in
+++ /dev/null
@@ -1,11 +0,0 @@
---- config.h.in.orig Thu Jan 2 19:50:41 2003
-+++ config.h.in Mon Jan 6 13:11:12 2003
-@@ -96,6 +96,8 @@
- /* Define to 1 if you have the <stdlib.h> header file. */
- #undef HAVE_STDLIB_H
-
-+#undef HAVE_LANGINFO_H
-+
- /* Define to 1 if you have the <strings.h> header file. */
- #undef HAVE_STRINGS_H
-
diff --git a/x11/gnome-panel/files/patch-configure b/x11/gnome-panel/files/patch-configure
index 732f3a86022c..1d73358932d3 100644
--- a/x11/gnome-panel/files/patch-configure
+++ b/x11/gnome-panel/files/patch-configure
@@ -1,11 +1,61 @@
---- configure.orig Wed Jan 14 15:54:42 2004
-+++ configure Wed Jan 14 15:55:13 2004
-@@ -5536,7 +5536,7 @@
+--- configure.orig 2009-10-04 17:26:08.000000000 -0400
++++ configure 2009-10-04 17:31:11.000000000 -0400
+@@ -14954,12 +14955,12 @@ if test -n "$CLOCK_CFLAGS"; then
+ pkg_cv_CLOCK_CFLAGS="$CLOCK_CFLAGS"
+ elif test -n "$PKG_CONFIG"; then
+ if test -n "$PKG_CONFIG" && \
+- { ($as_echo "$as_me:$LINENO: \$PKG_CONFIG --exists --print-errors \"pango >= \$PANGO_REQUIRED gtk+-2.0 >= \$GTK_REQUIRED glib-2.0 >= \$GLIB_REQUIRED gio-2.0 >= \$GLIB_REQUIRED \$LIBECAL_REQUIREMENT librsvg-2.0 dbus-glib-1 gweather >= \$GWEATHER_REQUIRED\"") >&5
+- ($PKG_CONFIG --exists --print-errors "pango >= $PANGO_REQUIRED gtk+-2.0 >= $GTK_REQUIRED glib-2.0 >= $GLIB_REQUIRED gio-2.0 >= $GLIB_REQUIRED $LIBECAL_REQUIREMENT librsvg-2.0 dbus-glib-1 gweather >= $GWEATHER_REQUIRED") 2>&5
++ { ($as_echo "$as_me:$LINENO: \$PKG_CONFIG --exists --print-errors \"pango >= \$PANGO_REQUIRED gtk+-2.0 >= \$GTK_REQUIRED glib-2.0 >= \$GLIB_REQUIRED gio-2.0 >= \$GLIB_REQUIRED \$LIBECAL_REQUIREMENT librsvg-2.0 dbus-glib-1 gweather >= \$GWEATHER_REQUIRED gnome-desktop-2.0 >= \$LIBGNOME_DESKTOP_REQUIRED\"") >&5
++ ($PKG_CONFIG --exists --print-errors "pango >= $PANGO_REQUIRED gtk+-2.0 >= $GTK_REQUIRED glib-2.0 >= $GLIB_REQUIRED gio-2.0 >= $GLIB_REQUIRED $LIBECAL_REQUIREMENT librsvg-2.0 dbus-glib-1 gweather >= $GWEATHER_REQUIRED gnome-desktop-2.0 >= $LIBGNOME_DESKTOP_REQUIRED") 2>&5
+ ac_status=$?
+ $as_echo "$as_me:$LINENO: \$? = $ac_status" >&5
+ (exit $ac_status); }; then
+- pkg_cv_CLOCK_CFLAGS=`$PKG_CONFIG --cflags "pango >= $PANGO_REQUIRED gtk+-2.0 >= $GTK_REQUIRED glib-2.0 >= $GLIB_REQUIRED gio-2.0 >= $GLIB_REQUIRED $LIBECAL_REQUIREMENT librsvg-2.0 dbus-glib-1 gweather >= $GWEATHER_REQUIRED" 2>/dev/null`
++ pkg_cv_CLOCK_CFLAGS=`$PKG_CONFIG --cflags "pango >= $PANGO_REQUIRED gtk+-2.0 >= $GTK_REQUIRED glib-2.0 >= $GLIB_REQUIRED gio-2.0 >= $GLIB_REQUIRED $LIBECAL_REQUIREMENT librsvg-2.0 dbus-glib-1 gweather >= $GWEATHER_REQUIRED gnome-desktop-2.0 >= $LIBGNOME_DESKTOP_REQUIRED" 2>/dev/null`
+ else
+ pkg_failed=yes
+ fi
+@@ -14970,12 +14971,12 @@ if test -n "$CLOCK_LIBS"; then
+ pkg_cv_CLOCK_LIBS="$CLOCK_LIBS"
+ elif test -n "$PKG_CONFIG"; then
+ if test -n "$PKG_CONFIG" && \
+- { ($as_echo "$as_me:$LINENO: \$PKG_CONFIG --exists --print-errors \"pango >= \$PANGO_REQUIRED gtk+-2.0 >= \$GTK_REQUIRED glib-2.0 >= \$GLIB_REQUIRED gio-2.0 >= \$GLIB_REQUIRED \$LIBECAL_REQUIREMENT librsvg-2.0 dbus-glib-1 gweather >= \$GWEATHER_REQUIRED\"") >&5
+- ($PKG_CONFIG --exists --print-errors "pango >= $PANGO_REQUIRED gtk+-2.0 >= $GTK_REQUIRED glib-2.0 >= $GLIB_REQUIRED gio-2.0 >= $GLIB_REQUIRED $LIBECAL_REQUIREMENT librsvg-2.0 dbus-glib-1 gweather >= $GWEATHER_REQUIRED") 2>&5
++ { ($as_echo "$as_me:$LINENO: \$PKG_CONFIG --exists --print-errors \"pango >= \$PANGO_REQUIRED gtk+-2.0 >= \$GTK_REQUIRED glib-2.0 >= \$GLIB_REQUIRED gio-2.0 >= \$GLIB_REQUIRED \$LIBECAL_REQUIREMENT librsvg-2.0 dbus-glib-1 gweather >= \$GWEATHER_REQUIRED gnome-desktop-2.0 >= \$LIBGNOME_DESKTOP_REQUIRED\"") >&5
++ ($PKG_CONFIG --exists --print-errors "pango >= $PANGO_REQUIRED gtk+-2.0 >= $GTK_REQUIRED glib-2.0 >= $GLIB_REQUIRED gio-2.0 >= $GLIB_REQUIRED $LIBECAL_REQUIREMENT librsvg-2.0 dbus-glib-1 gweather >= $GWEATHER_REQUIRED gnome-desktop-2.0 >= $LIBGNOME_DESKTOP_REQUIRED") 2>&5
+ ac_status=$?
+ $as_echo "$as_me:$LINENO: \$? = $ac_status" >&5
+ (exit $ac_status); }; then
+- pkg_cv_CLOCK_LIBS=`$PKG_CONFIG --libs "pango >= $PANGO_REQUIRED gtk+-2.0 >= $GTK_REQUIRED glib-2.0 >= $GLIB_REQUIRED gio-2.0 >= $GLIB_REQUIRED $LIBECAL_REQUIREMENT librsvg-2.0 dbus-glib-1 gweather >= $GWEATHER_REQUIRED" 2>/dev/null`
++ pkg_cv_CLOCK_LIBS=`$PKG_CONFIG --libs "pango >= $PANGO_REQUIRED gtk+-2.0 >= $GTK_REQUIRED glib-2.0 >= $GLIB_REQUIRED gio-2.0 >= $GLIB_REQUIRED $LIBECAL_REQUIREMENT librsvg-2.0 dbus-glib-1 gweather >= $GWEATHER_REQUIRED gnome-desktop-2.0 >= $LIBGNOME_DESKTOP_REQUIRED" 2>/dev/null`
+ else
+ pkg_failed=yes
+ fi
+@@ -14993,14 +14994,14 @@ else
+ _pkg_short_errors_supported=no
+ fi
+ if test $_pkg_short_errors_supported = yes; then
+- CLOCK_PKG_ERRORS=`$PKG_CONFIG --short-errors --print-errors "pango >= $PANGO_REQUIRED gtk+-2.0 >= $GTK_REQUIRED glib-2.0 >= $GLIB_REQUIRED gio-2.0 >= $GLIB_REQUIRED $LIBECAL_REQUIREMENT librsvg-2.0 dbus-glib-1 gweather >= $GWEATHER_REQUIRED" 2>&1`
++ CLOCK_PKG_ERRORS=`$PKG_CONFIG --short-errors --print-errors "pango >= $PANGO_REQUIRED gtk+-2.0 >= $GTK_REQUIRED glib-2.0 >= $GLIB_REQUIRED gio-2.0 >= $GLIB_REQUIRED $LIBECAL_REQUIREMENT librsvg-2.0 dbus-glib-1 gweather >= $GWEATHER_REQUIRED gnome-desktop-2.0 >= $LIBGNOME_DESKTOP_REQUIRED" 2>&1`
+ else
+- CLOCK_PKG_ERRORS=`$PKG_CONFIG --print-errors "pango >= $PANGO_REQUIRED gtk+-2.0 >= $GTK_REQUIRED glib-2.0 >= $GLIB_REQUIRED gio-2.0 >= $GLIB_REQUIRED $LIBECAL_REQUIREMENT librsvg-2.0 dbus-glib-1 gweather >= $GWEATHER_REQUIRED" 2>&1`
++ CLOCK_PKG_ERRORS=`$PKG_CONFIG --print-errors "pango >= $PANGO_REQUIRED gtk+-2.0 >= $GTK_REQUIRED glib-2.0 >= $GLIB_REQUIRED gio-2.0 >= $GLIB_REQUIRED $LIBECAL_REQUIREMENT librsvg-2.0 dbus-glib-1 gweather >= $GWEATHER_REQUIRED gnome-desktop-2.0 >= $LIBGNOME_DESKTOP_REQUIRED" 2>&1`
+ fi
+ # Put the nasty error message in config.log where it belongs
+ echo "$CLOCK_PKG_ERRORS" >&5
+- { { $as_echo "$as_me:$LINENO: error: Package requirements (pango >= $PANGO_REQUIRED gtk+-2.0 >= $GTK_REQUIRED glib-2.0 >= $GLIB_REQUIRED gio-2.0 >= $GLIB_REQUIRED $LIBECAL_REQUIREMENT librsvg-2.0 dbus-glib-1 gweather >= $GWEATHER_REQUIRED) were not met:
++ { { $as_echo "$as_me:$LINENO: error: Package requirements (pango >= $PANGO_REQUIRED gtk+-2.0 >= $GTK_REQUIRED glib-2.0 >= $GLIB_REQUIRED gio-2.0 >= $GLIB_REQUIRED $LIBECAL_REQUIREMENT librsvg-2.0 dbus-glib-1 gweather >= $GWEATHER_REQUIRED gnome-desktop-2.0 >= $LIBGNOME_DESKTOP_REQUIRED) were not met:
+
+ $CLOCK_PKG_ERRORS
+
+@@ -15011,7 +15012,7 @@ Alternatively, you may set the environme
+ and CLOCK_LIBS to avoid the need to call pkg-config.
+ See the pkg-config man page for more details.
+ " >&5
+-$as_echo "$as_me: error: Package requirements (pango >= $PANGO_REQUIRED gtk+-2.0 >= $GTK_REQUIRED glib-2.0 >= $GLIB_REQUIRED gio-2.0 >= $GLIB_REQUIRED $LIBECAL_REQUIREMENT librsvg-2.0 dbus-glib-1 gweather >= $GWEATHER_REQUIRED) were not met:
++$as_echo "$as_me: error: Package requirements (pango >= $PANGO_REQUIRED gtk+-2.0 >= $GTK_REQUIRED glib-2.0 >= $GLIB_REQUIRED gio-2.0 >= $GLIB_REQUIRED $LIBECAL_REQUIREMENT librsvg-2.0 dbus-glib-1 gweather >= $GWEATHER_REQUIRED gnome-desktop-2.0 >= $LIBGNOME_DESKTOP_REQUIRED) were not met:
+
+ $CLOCK_PKG_ERRORS
- for ac_header in sys/types.h sys/stat.h stdlib.h string.h memory.h strings.h \
-- inttypes.h stdint.h unistd.h
-+ inttypes.h stdint.h unistd.h langinfo.h
- do
- as_ac_Header=`echo "ac_cv_header_$ac_header" | $as_tr_sh`
- echo "$as_me:$LINENO: checking for $ac_header" >&5
diff --git a/x11/gnome-panel/files/patch-gnome-panel_panel-multiscreen.c b/x11/gnome-panel/files/patch-gnome-panel_panel-multiscreen.c
new file mode 100644
index 000000000000..50ef12367570
--- /dev/null
+++ b/x11/gnome-panel/files/patch-gnome-panel_panel-multiscreen.c
@@ -0,0 +1,59 @@
+--- gnome-panel/panel-multiscreen.c.orig 2009-10-12 22:57:08.000000000 +1000
++++ gnome-panel/panel-multiscreen.c 2009-10-12 22:57:08.000000000 +1000
+@@ -136,9 +136,17 @@
+ xroot = GDK_WINDOW_XWINDOW (gdk_screen_get_root_window (screen));
+
+ #if (RANDR_MAJOR > 1 || (RANDR_MAJOR == 1 && RANDR_MINOR >= 3))
+- if (have_randr_1_3)
++ if (have_randr_1_3) {
+ resources = XRRGetScreenResourcesCurrent (xdisplay, xroot);
+- else
++ if (resources->noutput == 0) {
++ /* This might happen if nothing tried to get randr
++ * resources from the server before, so we need an
++ * active probe. See comment #27 in
++ * https://bugzilla.gnome.org/show_bug.cgi?id=597101 */
++ XRRFreeScreenResources (resources);
++ resources = XRRGetScreenResources (xdisplay, xroot);
++ }
++ } else
+ resources = XRRGetScreenResources (xdisplay, xroot);
+ #else
+ resources = XRRGetScreenResources (xdisplay, xroot);
+@@ -205,6 +213,17 @@
+ return FALSE;
+ }
+
++ if (geometries->len == 0) {
++ /* This can happen in at least one case:
++ * https://bugzilla.novell.com/show_bug.cgi?id=543876 where all
++ * monitors appear disconnected (possibly because the screen
++ * is behing a KVM switch) -- see comment #8.
++ * There might be other cases too, so we stay on the safe side.
++ */
++ g_array_free (geometries, TRUE);
++ return FALSE;
++ }
++
+ *monitors_ret = geometries->len;
+ *geometries_ret = (GdkRectangle *) g_array_free (geometries, FALSE);
+
+@@ -238,9 +257,15 @@
+ int *monitors_ret,
+ GdkRectangle **geometries_ret)
+ {
+- if (panel_multiscreen_get_randr_monitors_for_screen (screen,
+- monitors_ret,
+- geometries_ret))
++ gboolean res;
++
++ *monitors_ret = 0;
++ *geometries_ret = NULL;
++
++ res = panel_multiscreen_get_randr_monitors_for_screen (screen,
++ monitors_ret,
++ geometries_ret);
++ if (res && *monitors_ret > 0)
+ return;
+
+ panel_multiscreen_get_gdk_monitors_for_screen (screen,
diff --git a/x11/gnome-panel/pkg-plist b/x11/gnome-panel/pkg-plist
index 16ed214475df..72143630613a 100644
--- a/x11/gnome-panel/pkg-plist
+++ b/x11/gnome-panel/pkg-plist
@@ -23,9 +23,9 @@ libdata/pkgconfig/libpanelapplet-2.0.pc
libexec/clock-applet
libexec/fish-applet-2
libexec/gnome-clock-applet-mechanism
+libexec/gnome-panel-add
libexec/notification-area-applet
libexec/wnck-applet
-share/PolicyKit/policy/org.gnome.clockapplet.mechanism.policy
share/applications/gnome-panel.desktop
share/dbus-1/system-services/org.gnome.ClockApplet.Mechanism.service
share/gnome-2.0/ui/GNOME_ClockApplet.xml
@@ -36,13 +36,13 @@ share/gnome-2.0/ui/GNOME_ShowDesktopApplet.xml
share/gnome-2.0/ui/GNOME_WindowListApplet.xml
share/gnome-2.0/ui/GNOME_WindowMenuApplet.xml
share/gnome-2.0/ui/GNOME_WorkspaceSwitcherApplet.xml
-%%DATADIR%%/glade/clock.glade
-%%DATADIR%%/glade/fish.glade
-%%DATADIR%%/glade/panel-properties-dialog.glade
-%%DATADIR%%/glade/panel-run-dialog.glade
-%%DATADIR%%/glade/panel-test-applets.glade
-%%DATADIR%%/glade/window-list.glade
-%%DATADIR%%/glade/workspace-switcher.glade
+%%DATADIR%%/ui/clock.ui
+%%DATADIR%%/ui/fish.ui
+%%DATADIR%%/ui/panel-properties-dialog.ui
+%%DATADIR%%/ui/panel-run-dialog.ui
+%%DATADIR%%/ui/panel-test-applets.ui
+%%DATADIR%%/ui/window-list.ui
+%%DATADIR%%/ui/workspace-switcher.ui
%%DATADIR%%/pixmaps/clock-calendar-icon.png
%%DATADIR%%/pixmaps/clock-face-large.svg
%%DATADIR%%/pixmaps/clock-face-small-day.svg
@@ -192,50 +192,6 @@ share/gnome/help/fish/uk/legal.xml
share/gnome/help/fish/zh_CN/figures/fish_applet.png
share/gnome/help/fish/zh_CN/fish.xml
share/gnome/help/fish/zh_CN/legal.xml
-share/gnome/help/window-list/C/window-list.xml
-share/gnome/help/window-list/ar/window-list.xml
-share/gnome/help/window-list/ca/window-list.xml
-share/gnome/help/window-list/cs/window-list.xml
-share/gnome/help/window-list/da/window-list.xml
-share/gnome/help/window-list/de/window-list.xml
-share/gnome/help/window-list/el/window-list.xml
-share/gnome/help/window-list/en_GB/window-list.xml
-share/gnome/help/window-list/es/window-list.xml
-share/gnome/help/window-list/eu/window-list.xml
-share/gnome/help/window-list/fi/window-list.xml
-share/gnome/help/window-list/fr/window-list.xml
-share/gnome/help/window-list/it/window-list.xml
-share/gnome/help/window-list/ko/window-list.xml
-share/gnome/help/window-list/oc/window-list.xml
-share/gnome/help/window-list/pa/window-list.xml
-share/gnome/help/window-list/pt_BR/window-list.xml
-share/gnome/help/window-list/ru/window-list.xml
-share/gnome/help/window-list/sv/window-list.xml
-share/gnome/help/window-list/uk/window-list.xml
-share/gnome/help/window-list/zh_CN/window-list.xml
-share/gnome/help/workspace-switcher/C/workspace-switcher.xml
-share/gnome/help/workspace-switcher/ar/workspace-switcher.xml
-share/gnome/help/workspace-switcher/ca/workspace-switcher.xml
-share/gnome/help/workspace-switcher/cs/workspace-switcher.xml
-share/gnome/help/workspace-switcher/da/workspace-switcher.xml
-share/gnome/help/workspace-switcher/de/workspace-switcher.xml
-share/gnome/help/workspace-switcher/el/workspace-switcher.xml
-share/gnome/help/workspace-switcher/en_GB/workspace-switcher.xml
-share/gnome/help/workspace-switcher/es/workspace-switcher.xml
-share/gnome/help/workspace-switcher/eu/workspace-switcher.xml
-share/gnome/help/workspace-switcher/fi/workspace-switcher.xml
-share/gnome/help/workspace-switcher/fr/workspace-switcher.xml
-share/gnome/help/workspace-switcher/it/workspace-switcher.xml
-share/gnome/help/workspace-switcher/ko/workspace-switcher.xml
-share/gnome/help/workspace-switcher/nl/workspace-switcher.xml
-share/gnome/help/workspace-switcher/oc/workspace-switcher.xml
-share/gnome/help/workspace-switcher/pa/workspace-switcher.xml
-share/gnome/help/workspace-switcher/pt_BR/workspace-switcher.xml
-share/gnome/help/workspace-switcher/ru/workspace-switcher.xml
-share/gnome/help/workspace-switcher/sv/workspace-switcher.xml
-share/gnome/help/workspace-switcher/uk/workspace-switcher.xml
-share/gnome/help/workspace-switcher/vi/workspace-switcher.xml
-share/gnome/help/workspace-switcher/zh_CN/workspace-switcher.xml
share/icons/hicolor/16x16/apps/gnome-panel-clock.png
share/icons/hicolor/16x16/apps/gnome-panel-drawer.png
share/icons/hicolor/16x16/apps/gnome-panel-fish.png
@@ -438,101 +394,10 @@ share/omf/fish/fish-sv.omf
share/omf/fish/fish-th.omf
share/omf/fish/fish-uk.omf
share/omf/fish/fish-zh_CN.omf
-share/omf/window-list/window-list-C.omf
-share/omf/window-list/window-list-ar.omf
-share/omf/window-list/window-list-ca.omf
-share/omf/window-list/window-list-cs.omf
-share/omf/window-list/window-list-da.omf
-share/omf/window-list/window-list-de.omf
-share/omf/window-list/window-list-el.omf
-share/omf/window-list/window-list-en_GB.omf
-share/omf/window-list/window-list-es.omf
-share/omf/window-list/window-list-eu.omf
-share/omf/window-list/window-list-fi.omf
-share/omf/window-list/window-list-fr.omf
-share/omf/window-list/window-list-it.omf
-share/omf/window-list/window-list-ko.omf
-share/omf/window-list/window-list-oc.omf
-share/omf/window-list/window-list-pa.omf
-share/omf/window-list/window-list-pt_BR.omf
-share/omf/window-list/window-list-ru.omf
-share/omf/window-list/window-list-sv.omf
-share/omf/window-list/window-list-uk.omf
-share/omf/window-list/window-list-zh_CN.omf
-share/omf/workspace-switcher/workspace-switcher-C.omf
-share/omf/workspace-switcher/workspace-switcher-ar.omf
-share/omf/workspace-switcher/workspace-switcher-ca.omf
-share/omf/workspace-switcher/workspace-switcher-cs.omf
-share/omf/workspace-switcher/workspace-switcher-da.omf
-share/omf/workspace-switcher/workspace-switcher-de.omf
-share/omf/workspace-switcher/workspace-switcher-el.omf
-share/omf/workspace-switcher/workspace-switcher-en_GB.omf
-share/omf/workspace-switcher/workspace-switcher-es.omf
-share/omf/workspace-switcher/workspace-switcher-eu.omf
-share/omf/workspace-switcher/workspace-switcher-fi.omf
-share/omf/workspace-switcher/workspace-switcher-fr.omf
-share/omf/workspace-switcher/workspace-switcher-it.omf
-share/omf/workspace-switcher/workspace-switcher-ko.omf
-share/omf/workspace-switcher/workspace-switcher-nl.omf
-share/omf/workspace-switcher/workspace-switcher-oc.omf
-share/omf/workspace-switcher/workspace-switcher-pa.omf
-share/omf/workspace-switcher/workspace-switcher-pt_BR.omf
-share/omf/workspace-switcher/workspace-switcher-ru.omf
-share/omf/workspace-switcher/workspace-switcher-sv.omf
-share/omf/workspace-switcher/workspace-switcher-uk.omf
-share/omf/workspace-switcher/workspace-switcher-vi.omf
-share/omf/workspace-switcher/workspace-switcher-zh_CN.omf
-@dirrm share/omf/workspace-switcher
-@dirrm share/omf/window-list
+share/polkit-1/actions/org.gnome.clockapplet.mechanism.policy
@dirrm share/omf/fish
@dirrm share/omf/clock
@dirrm share/idl/gnome-panel-2.0
-@dirrm share/gnome/help/workspace-switcher/zh_CN
-@dirrm share/gnome/help/workspace-switcher/vi
-@dirrm share/gnome/help/workspace-switcher/uk
-@dirrm share/gnome/help/workspace-switcher/sv
-@dirrm share/gnome/help/workspace-switcher/ru
-@dirrm share/gnome/help/workspace-switcher/pt_BR
-@dirrm share/gnome/help/workspace-switcher/pa
-@dirrm share/gnome/help/workspace-switcher/oc
-@dirrm share/gnome/help/workspace-switcher/nl
-@dirrm share/gnome/help/workspace-switcher/ko
-@dirrm share/gnome/help/workspace-switcher/it
-@dirrm share/gnome/help/workspace-switcher/fr
-@dirrm share/gnome/help/workspace-switcher/fi
-@dirrm share/gnome/help/workspace-switcher/eu
-@dirrm share/gnome/help/workspace-switcher/es
-@dirrm share/gnome/help/workspace-switcher/en_GB
-@dirrm share/gnome/help/workspace-switcher/el
-@dirrm share/gnome/help/workspace-switcher/de
-@dirrm share/gnome/help/workspace-switcher/da
-@dirrm share/gnome/help/workspace-switcher/cs
-@dirrm share/gnome/help/workspace-switcher/ca
-@dirrm share/gnome/help/workspace-switcher/ar
-@dirrm share/gnome/help/workspace-switcher/C
-@dirrm share/gnome/help/workspace-switcher
-@dirrm share/gnome/help/window-list/zh_CN
-@dirrm share/gnome/help/window-list/uk
-@dirrm share/gnome/help/window-list/sv
-@dirrm share/gnome/help/window-list/ru
-@dirrm share/gnome/help/window-list/pt_BR
-@dirrm share/gnome/help/window-list/pa
-@dirrm share/gnome/help/window-list/oc
-@dirrm share/gnome/help/window-list/ko
-@dirrm share/gnome/help/window-list/it
-@dirrm share/gnome/help/window-list/fr
-@dirrm share/gnome/help/window-list/fi
-@dirrm share/gnome/help/window-list/eu
-@dirrm share/gnome/help/window-list/es
-@dirrm share/gnome/help/window-list/en_GB
-@dirrm share/gnome/help/window-list/el
-@dirrm share/gnome/help/window-list/de
-@dirrm share/gnome/help/window-list/da
-@dirrm share/gnome/help/window-list/cs
-@dirrm share/gnome/help/window-list/ca
-@dirrm share/gnome/help/window-list/ar
-@dirrm share/gnome/help/window-list/C
-@dirrm share/gnome/help/window-list
@dirrm share/gnome/help/fish/zh_CN/figures
@dirrm share/gnome/help/fish/zh_CN
@dirrm share/gnome/help/fish/uk/figures
@@ -622,7 +487,7 @@ share/omf/workspace-switcher/workspace-switcher-zh_CN.omf
@dirrm share/gnome/help/clock/C
@dirrm share/gnome/help/clock
@dirrm %%DATADIR%%/pixmaps
-@dirrm %%DATADIR%%/glade
+@dirrm %%DATADIR%%/ui
@dirrm %%DATADIR%%
@dirrmtry share/applications
@dirrm include/panel-2.0