aboutsummaryrefslogtreecommitdiff
path: root/x11/gnome-screensaver
diff options
context:
space:
mode:
authorKoop Mast <kwm@FreeBSD.org>2011-08-23 18:39:19 +0000
committerKoop Mast <kwm@FreeBSD.org>2011-08-23 18:39:19 +0000
commitfe61bf1eb4f2758636a3c065686a833eb412df25 (patch)
tree1474457ea487adcafec2ab29e99ab61897a3e479 /x11/gnome-screensaver
parent5732783897145621b6af3ab08fba8d9af40f338b (diff)
downloadports-fe61bf1eb4f2758636a3c065686a833eb412df25.tar.gz
ports-fe61bf1eb4f2758636a3c065686a833eb412df25.zip
Notes
Diffstat (limited to 'x11/gnome-screensaver')
-rw-r--r--x11/gnome-screensaver/Makefile8
-rw-r--r--x11/gnome-screensaver/files/patch-src_gs-lock-plug.c11
2 files changed, 16 insertions, 3 deletions
diff --git a/x11/gnome-screensaver/Makefile b/x11/gnome-screensaver/Makefile
index 53db051654d3..55cb5c7ea4a1 100644
--- a/x11/gnome-screensaver/Makefile
+++ b/x11/gnome-screensaver/Makefile
@@ -3,12 +3,12 @@
# Whom: Joe Marcus Clarke <marcus@FreeBSD.org>
#
# $FreeBSD$
-# $MCom: ports/x11/gnome-screensaver/Makefile,v 1.121 2010/09/30 19:51:41 kwm Exp $
+# $MCom: ports/x11/gnome-screensaver/Makefile,v 1.124 2011/04/09 16:54:20 mezz Exp $
#
PORTNAME= gnome-screensaver
PORTVERSION= 2.30.2
-PORTREVISION= 1
+PORTREVISION= 2
CATEGORIES= x11 gnome
MASTER_SITES= GNOME
DIST_SUBDIR= gnome2
@@ -16,9 +16,11 @@ DIST_SUBDIR= gnome2
MAINTAINER= gnome@FreeBSD.org
COMMENT= GNOME screen saver and locker
-LIB_DEPENDS= notify.1:${PORTSDIR}/devel/libnotify
+LIB_DEPENDS= notify.4:${PORTSDIR}/devel/libnotify
RUN_DEPENDS= xscreensaver-gl-helper:${PORTSDIR}/x11/xscreensaver-gnome-hacks
+CONFLICTS= gnome-screensaver-3.[0-9]*
+
USE_BZIP2= yes
USE_GMAKE= yes
USE_GETTEXT= yes
diff --git a/x11/gnome-screensaver/files/patch-src_gs-lock-plug.c b/x11/gnome-screensaver/files/patch-src_gs-lock-plug.c
new file mode 100644
index 000000000000..af5d39f8e346
--- /dev/null
+++ b/x11/gnome-screensaver/files/patch-src_gs-lock-plug.c
@@ -0,0 +1,11 @@
+--- src/gs-lock-plug.c.orig 2011-03-06 21:27:00.000000000 +0100
++++ src/gs-lock-plug.c 2011-03-06 21:27:36.000000000 +0100
+@@ -1090,7 +1090,7 @@ submit_note (GtkButton *button,
+ strftime (summary, 128, "%X", tmp);
+
+ notify_init ("gnome-screensaver-dialog");
+- note = notify_notification_new (summary, escaped_text, NULL, NULL);
++ note = notify_notification_new (summary, escaped_text, NULL);
+ notify_notification_set_timeout (note, NOTIFY_EXPIRES_NEVER);
+ notify_notification_show (note, NULL);
+ g_object_unref (note);