aboutsummaryrefslogtreecommitdiff
path: root/x11/gnome-session/Makefile
diff options
context:
space:
mode:
authorJoe Marcus Clarke <marcus@FreeBSD.org>2003-10-14 18:34:35 +0000
committerJoe Marcus Clarke <marcus@FreeBSD.org>2003-10-14 18:34:35 +0000
commitf9f5836288e579cbc20418153cce5d49b8ffd0b8 (patch)
tree7016c0d6ce3e9d58936b58512d4967635c0b9707 /x11/gnome-session/Makefile
parente3d72bdc0527b10f95c73d402f12b57f48fba3fb (diff)
downloadports-f9f5836288e579cbc20418153cce5d49b8ffd0b8.tar.gz
ports-f9f5836288e579cbc20418153cce5d49b8ffd0b8.zip
Notes
Diffstat (limited to 'x11/gnome-session/Makefile')
-rw-r--r--x11/gnome-session/Makefile15
1 files changed, 12 insertions, 3 deletions
diff --git a/x11/gnome-session/Makefile b/x11/gnome-session/Makefile
index 48f0b8e7bbb9..4971fdced352 100644
--- a/x11/gnome-session/Makefile
+++ b/x11/gnome-session/Makefile
@@ -6,11 +6,14 @@
#
PORTNAME= gnomesession
-PORTVERSION= 2.4.0
+PORTVERSION= 2.4.1
CATEGORIES= x11 gnome
-MASTER_SITES= ${MASTER_SITE_GNOME}
+MASTER_SITES= ${MASTER_SITE_GNOME} \
+ http://people.freebsd.org/~marcus/:local
MASTER_SITE_SUBDIR= sources/gnome-session/2.4
DISTNAME= gnome-session-${PORTVERSION}
+DISTFILES= ${DISTNAME}${EXTRACT_SUFX} \
+ splash.png:local
DIST_SUBDIR= gnome2
MAINTAINER= gnome@FreeBSD.org
@@ -18,7 +21,6 @@ COMMENT= Session component for the GNOME 2 desktop
USE_BZIP2= yes
USE_X_PREFIX= yes
-USE_REINPLACE= yes
USE_GNOME= gnomeprefix gnomehack gnomehier libgnomeui
USE_GMAKE= yes
USE_LIBTOOL= yes
@@ -29,4 +31,11 @@ MAN1= gnome-session.1 gnome-smproxy.1 gnome-wm.1 session-properties.1 \
gnome-session-save.1
MAN5= default.session.5
+post-extract:
+ @${CP} ${DISTDIR}/${DIST_SUBDIR}/splash.png ${WRKDIR}
+
+post-install:
+ ${INSTALL_DATA} ${WRKDIR}/splash.png \
+ ${PREFIX}/share/gnome/pixmaps/splash/gnome-splash.png
+
.include <bsd.port.mk>