aboutsummaryrefslogtreecommitdiff
path: root/x11/gnome-session
diff options
context:
space:
mode:
authorJoe Marcus Clarke <marcus@FreeBSD.org>2009-01-10 05:22:13 +0000
committerJoe Marcus Clarke <marcus@FreeBSD.org>2009-01-10 05:22:13 +0000
commit610ae5681637c1051a0c17b54e29d97f53da2f3a (patch)
treec231a1eb74b07e444fa7363012cb84bf23d83ce0 /x11/gnome-session
parent15b6544926b07a98710eeb765baf03e3fc9a195c (diff)
downloadports-610ae5681637c1051a0c17b54e29d97f53da2f3a.tar.gz
ports-610ae5681637c1051a0c17b54e29d97f53da2f3a.zip
Notes
Diffstat (limited to 'x11/gnome-session')
-rw-r--r--x11/gnome-session/Makefile10
-rw-r--r--x11/gnome-session/distinfo6
-rw-r--r--x11/gnome-session/files/patch-data_Makefile.in20
-rw-r--r--x11/gnome-session/files/patch-disable_debug13
-rw-r--r--x11/gnome-session/files/patch-gnome-session_Makefile.in10
-rw-r--r--x11/gnome-session/files/patch-gnome-session_gsm-autostart-app.c10
-rw-r--r--x11/gnome-session/pkg-descr2
-rw-r--r--x11/gnome-session/pkg-plist23
8 files changed, 51 insertions, 43 deletions
diff --git a/x11/gnome-session/Makefile b/x11/gnome-session/Makefile
index 453051987f60..bebfa085cb59 100644
--- a/x11/gnome-session/Makefile
+++ b/x11/gnome-session/Makefile
@@ -3,11 +3,11 @@
# Whom: Joe Marcus Clarke <marcus@FreeBSD.org>
#
# $FreeBSD$
-# $MCom: ports/x11/gnome-session/Makefile,v 1.141 2008/03/10 23:48:33 ahze Exp $
+# $MCom: ports/x11/gnome-session/Makefile,v 1.164 2008/11/25 19:25:49 marcus Exp $
#
PORTNAME= gnome-session
-PORTVERSION= 2.22.3
+PORTVERSION= 2.24.2
CATEGORIES= x11 gnome
MASTER_SITES= GNOME \
http://www.marcuscom.com/downloads/:local
@@ -22,7 +22,8 @@ COMMENT= Session component for the GNOME 2 desktop
BUILD_DEPENDS= ${LOCALBASE}/libexec/gnome-settings-daemon:${PORTSDIR}/sysutils/gnome-settings-daemon
LIB_DEPENDS= dbus-glib-1.2:${PORTSDIR}/devel/dbus-glib \
gnome-keyring.0:${PORTSDIR}/security/gnome-keyring \
- notify.1:${PORTSDIR}/devel/libnotify
+ notify.1:${PORTSDIR}/devel/libnotify \
+ execinfo:${PORTSDIR}/devel/libexecinfo
RUN_DEPENDS= ${LOCALBASE}/libexec/gnome-settings-daemon:${PORTSDIR}/sysutils/gnome-settings-daemon \
${LOCALBASE}/bin/xdpyinfo:${PORTSDIR}/x11/xdpyinfo
@@ -34,6 +35,7 @@ USE_GNOME= gnomeprefix gnomehack intlhack libgnomeui
GNOME_DESKTOP_VERSION=2
USE_GMAKE= yes
GNU_CONFIGURE= yes
+CONFIGURE_ARGS= --disable-docbook-docs
CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include" \
LDFLAGS="-L${LOCALBASE}/lib"
@@ -45,7 +47,7 @@ GCONF_SCHEMAS= gnome-session.schemas
SPLASHES= freebsd-splashes-gnome-2.18_1.tar
post-extract:
- cd ${WRKDIR} && ${TAR} xf ${DISTDIR}/${DIST_SUBDIR}/${SPLASHES}
+ cd ${WRKDIR} && ${TAR} -xf ${DISTDIR}/${DIST_SUBDIR}/${SPLASHES}
post-install:
${INSTALL_DATA} ${WRKSRC}/data/gnome-splash.png \
diff --git a/x11/gnome-session/distinfo b/x11/gnome-session/distinfo
index e0168c18970f..2a485ff1bc98 100644
--- a/x11/gnome-session/distinfo
+++ b/x11/gnome-session/distinfo
@@ -1,6 +1,6 @@
-MD5 (gnome2/gnome-session-2.22.3.tar.bz2) = 859b61b5368aa000c9bcb8b0d0688ca2
-SHA256 (gnome2/gnome-session-2.22.3.tar.bz2) = 07ec872ae8213c4e92072ff74451caa2b6afb747fd0b07d2cea40cfcd32b7176
-SIZE (gnome2/gnome-session-2.22.3.tar.bz2) = 773853
+MD5 (gnome2/gnome-session-2.24.2.tar.bz2) = 13e882a8c73bebb5403c207da0455156
+SHA256 (gnome2/gnome-session-2.24.2.tar.bz2) = b69216120e0fa972f3fbbff36b5520979974fa665d76d8c7db59970dca61b629
+SIZE (gnome2/gnome-session-2.24.2.tar.bz2) = 800914
MD5 (gnome2/freebsd-splashes-gnome-2.18_1.tar) = 80eb8c52fcf9fe977e0bf8ed48b85fe5
SHA256 (gnome2/freebsd-splashes-gnome-2.18_1.tar) = fcca0f6eb759a4ef0211ecd61340f84ce8ad4d7493f725ac8613724faadbb508
SIZE (gnome2/freebsd-splashes-gnome-2.18_1.tar) = 1630720
diff --git a/x11/gnome-session/files/patch-data_Makefile.in b/x11/gnome-session/files/patch-data_Makefile.in
deleted file mode 100644
index 82e1ed49f216..000000000000
--- a/x11/gnome-session/files/patch-data_Makefile.in
+++ /dev/null
@@ -1,20 +0,0 @@
---- data/Makefile.in.orig 2008-03-01 02:09:17.000000000 -0500
-+++ data/Makefile.in 2008-03-01 02:10:21.000000000 -0500
-@@ -258,7 +258,7 @@ default_in_files = default.session.in
- default_DATA = $(default_in_files:.session.in=.session)
- xsessiondir = $(datadir)/xsessions
- xsession_in_files = gnome.desktop.in
--xsession_DATA = $(xsession_in_files:.desktop.in=.desktop)
-+xsession_DATA = # $(xsession_in_files:.desktop.in=.desktop)
- settingsdir = $(datadir)/applications
- @SESSION_TRUE@settings_in_files = session-properties.desktop.in
- @SESSION_TRUE@settings_DATA = $(settings_in_files:.desktop.in=.desktop)
-@@ -280,7 +280,7 @@ CLEANFILES = \
- gnome.desktop \
- session-properties.desktop
-
--all: all-recursive
-+all: all-recursive default.session
-
- .SUFFIXES:
- $(srcdir)/Makefile.in: @MAINTAINER_MODE_TRUE@ $(srcdir)/Makefile.am $(am__configure_deps)
diff --git a/x11/gnome-session/files/patch-disable_debug b/x11/gnome-session/files/patch-disable_debug
deleted file mode 100644
index 778d72c9e67f..000000000000
--- a/x11/gnome-session/files/patch-disable_debug
+++ /dev/null
@@ -1,13 +0,0 @@
---- gnome-session/main.c.orig 2008-01-16 16:48:55.000000000 -0600
-+++ gnome-session/main.c 2008-01-16 16:50:01.000000000 -0600
-@@ -626,8 +626,8 @@
- major = atoi (versions [1]);
- if ((major % 2) != 0)
- {
-- g_setenv ("G_DEBUG", "fatal_criticals", FALSE);
-- g_log_set_always_fatal (G_LOG_LEVEL_CRITICAL);
-+ /* g_setenv ("G_DEBUG", "fatal_criticals", FALSE);
-+ g_log_set_always_fatal (G_LOG_LEVEL_CRITICAL); */
- }
- }
- g_strfreev (versions);
diff --git a/x11/gnome-session/files/patch-gnome-session_Makefile.in b/x11/gnome-session/files/patch-gnome-session_Makefile.in
new file mode 100644
index 000000000000..7e78d6ed5deb
--- /dev/null
+++ b/x11/gnome-session/files/patch-gnome-session_Makefile.in
@@ -0,0 +1,10 @@
+--- gnome-session/Makefile.in.orig 2008-08-20 14:29:34.000000000 -0400
++++ gnome-session/Makefile.in 2008-08-20 14:29:56.000000000 -0400
+@@ -332,6 +332,7 @@ test_client_dbus_LDADD = \
+
+ gnome_session_LDADD = \
+ -lSM -lICE \
++ -lexecinfo \
+ libgsmutil.la \
+ $(top_builddir)/egg/libeggdesktopfile.la \
+ $(GNOME_SESSION_LIBS) \
diff --git a/x11/gnome-session/files/patch-gnome-session_gsm-autostart-app.c b/x11/gnome-session/files/patch-gnome-session_gsm-autostart-app.c
new file mode 100644
index 000000000000..3044f1b8988f
--- /dev/null
+++ b/x11/gnome-session/files/patch-gnome-session_gsm-autostart-app.c
@@ -0,0 +1,10 @@
+--- gnome-session/gsm-autostart-app.c.orig 2008-08-20 14:18:52.000000000 -0400
++++ gnome-session/gsm-autostart-app.c 2008-08-20 14:19:02.000000000 -0400
+@@ -25,6 +25,7 @@
+ #include <string.h>
+ #include <sys/wait.h>
+ #include <errno.h>
++#include <signal.h>
+
+ #include <glib.h>
+ #include <gio/gio.h>
diff --git a/x11/gnome-session/pkg-descr b/x11/gnome-session/pkg-descr
index 50986ef910b2..ee3e0826ec85 100644
--- a/x11/gnome-session/pkg-descr
+++ b/x11/gnome-session/pkg-descr
@@ -1,2 +1,4 @@
This provides session management for the GNOME 2 desktop, and
provides the tools used to start the desktop.
+
+WWW: http://www.gnome.org
diff --git a/x11/gnome-session/pkg-plist b/x11/gnome-session/pkg-plist
index 9c51b437c0e5..6612cb2a9c39 100644
--- a/x11/gnome-session/pkg-plist
+++ b/x11/gnome-session/pkg-plist
@@ -1,10 +1,18 @@
bin/gnome-session
bin/gnome-session-properties
-bin/gnome-session-remove
bin/gnome-session-save
bin/gnome-wm
+lib/gnome-session/helpers/at-spi-registryd-wrapper
+lib/gnome-session/helpers/gnome-keyring-daemon-wrapper
+lib/gnome-session/helpers/gnome-session-splash
+lib/gnome-session/helpers/gnome-settings-daemon-helper
share/applications/session-properties.desktop
-share/gnome/default.session
+%%DATADIR%%/gsm-inhibit-dialog.glade
+%%DATADIR%%/session-properties.glade
+share/gnome/autostart/at-spi-registryd-wrapper.desktop
+share/gnome/autostart/gnome-keyring-daemon-wrapper.desktop
+share/gnome/autostart/gnome-session-splash.desktop
+share/gnome/autostart/gnome-settings-daemon-helper.desktop
share/icons/hicolor/16x16/apps/session-properties.png
share/icons/hicolor/22x22/apps/session-properties.png
share/icons/hicolor/24x24/apps/session-properties.png
@@ -13,6 +21,7 @@ share/icons/hicolor/scalable/apps/session-properties.svg
share/locale/af/LC_MESSAGES/gnome-session-2.0.mo
share/locale/am/LC_MESSAGES/gnome-session-2.0.mo
share/locale/ar/LC_MESSAGES/gnome-session-2.0.mo
+share/locale/ast/LC_MESSAGES/gnome-session-2.0.mo
share/locale/az/LC_MESSAGES/gnome-session-2.0.mo
share/locale/be/LC_MESSAGES/gnome-session-2.0.mo
share/locale/be@latin/LC_MESSAGES/gnome-session-2.0.mo
@@ -81,7 +90,7 @@ share/locale/sk/LC_MESSAGES/gnome-session-2.0.mo
share/locale/sl/LC_MESSAGES/gnome-session-2.0.mo
share/locale/sq/LC_MESSAGES/gnome-session-2.0.mo
share/locale/sr/LC_MESSAGES/gnome-session-2.0.mo
-share/locale/sr@Latn/LC_MESSAGES/gnome-session-2.0.mo
+share/locale/sr@latin/LC_MESSAGES/gnome-session-2.0.mo
share/locale/sv/LC_MESSAGES/gnome-session-2.0.mo
share/locale/ta/LC_MESSAGES/gnome-session-2.0.mo
share/locale/te/LC_MESSAGES/gnome-session-2.0.mo
@@ -117,8 +126,12 @@ share/pixmaps/splash/original-gnome-splash.png
share/pixmaps/splash/tremulant-2.12.png
share/pixmaps/splash/tremulant-blood-2.12.png
share/pixmaps/splash/tremulant-brushed-metal-2.12.png
+share/xsessions/gnome.desktop
@dirrmtry share/xsessions
+@dirrm %%DATADIR%%
@dirrmtry share/applications
+@dirrm lib/gnome-session/helpers
+@dirrm lib/gnome-session
@dirrmtry share/locale/zu/LC_MESSAGES
@dirrmtry share/locale/zu
@dirrmtry share/locale/zh_HK/LC_MESSAGES
@@ -127,6 +140,8 @@ share/pixmaps/splash/tremulant-brushed-metal-2.12.png
@dirrmtry share/locale/xh
@dirrmtry share/locale/te/LC_MESSAGES
@dirrmtry share/locale/te
+@dirrmtry share/locale/sr@latin/LC_MESSAGES
+@dirrmtry share/locale/sr@latin
@dirrmtry share/locale/si/LC_MESSAGES
@dirrmtry share/locale/si
@dirrmtry share/locale/rw/LC_MESSAGES
@@ -153,3 +168,5 @@ share/pixmaps/splash/tremulant-brushed-metal-2.12.png
@dirrmtry share/locale/bn_IN
@dirrmtry share/locale/be@latin/LC_MESSAGES
@dirrmtry share/locale/be@latin
+@dirrmtry share/locale/ast/LC_MESSAGES
+@dirrmtry share/locale/ast