aboutsummaryrefslogtreecommitdiff
path: root/x11/gnome-shell
diff options
context:
space:
mode:
authorKoop Mast <kwm@FreeBSD.org>2017-05-15 21:36:27 +0000
committerKoop Mast <kwm@FreeBSD.org>2017-05-15 21:36:27 +0000
commitdd0e9e7708d2347c6a4d322c6db2c5edb3a94484 (patch)
treeaa3cd65078a4ad522f4043d997143bef98da2da7 /x11/gnome-shell
parent2bed486d22d92896fd0e5cc32c431c45bbba7bd5 (diff)
downloadports-dd0e9e7708d2347c6a4d322c6db2c5edb3a94484.tar.gz
ports-dd0e9e7708d2347c6a4d322c6db2c5edb3a94484.zip
Notes
Diffstat (limited to 'x11/gnome-shell')
-rw-r--r--x11/gnome-shell/Makefile42
-rw-r--r--x11/gnome-shell/distinfo5
-rw-r--r--x11/gnome-shell/pkg-message4
3 files changed, 30 insertions, 21 deletions
diff --git a/x11/gnome-shell/Makefile b/x11/gnome-shell/Makefile
index 916a7ca203ab..3463470b5f20 100644
--- a/x11/gnome-shell/Makefile
+++ b/x11/gnome-shell/Makefile
@@ -2,8 +2,7 @@
# $FreeBSD$
PORTNAME= gnome-shell
-PORTVERSION= 3.18.4
-PORTREVISION= 4
+PORTVERSION= 3.18.5
CATEGORIES= x11 gnome
MASTER_SITES= GNOME
DIST_SUBDIR= gnome3
@@ -11,44 +10,56 @@ DIST_SUBDIR= gnome3
MAINTAINER= gnome@FreeBSD.org
COMMENT= Next generation GNOME desktop shell
+LICENSE= GPLv2+
+LICENSE_FILE= ${WRKSRC}/COPYING
+
BUILD_DEPENDS= ca_root_nss>=0:security/ca_root_nss \
+ nss>=0:security/nss \
gnome-control-center:sysutils/gnome-control-center
LIB_DEPENDS= libstartup-notification-1.so:x11/startup-notification \
libcaribou.so:accessibility/caribou \
libmutter.so:x11-wm/mutter \
+ libatk-bridge-2.0.so:accessibility/at-spi2-atk \
+ libnspr4.so:devel/nspr \
+ libsoup-2.4.so:devel/libsoup \
+ libjson-glib-1.0.so:devel/json-glib \
libsecret-1.so:security/libsecret \
libgcr-3.so:security/gcr \
libtelepathy-glib.so:net-im/telepathy-glib \
- libtelepathy-logger.so:net-im/telepathy-logger \
- libfolks.so:net-im/folks \
libibus-1.0.so:textproc/ibus \
+ libical.so:devel/libical \
+ libmozjs-24.so:lang/spidermonkey24 \
+ libicuuc.so:devel/icu \
libpulse.so:audio/pulseaudio \
libcroco-0.6.so:textproc/libcroco \
libdbus-glib-1.so:devel/dbus-glib \
+ libcanberra.so:audio/libcanberra \
+ libcanberra-gtk3.so:audio/libcanberra-gtk3 \
+ libp11-kit.so:security/p11-kit \
+ libpolkit-gobject-1.so:sysutils/polkit \
+ libcogl.so:graphics/cogl \
libclutter-1.0.so:graphics/clutter \
libgjs.so:lang/gjs
RUN_DEPENDS= py*-dbus>=0:devel/py-dbus \
+ nss>=0:security/nss \
gnome-control-center:sysutils/gnome-control-center \
ca_root_nss>=0:security/ca_root_nss \
gkbd-keyboard-display:x11/libgnomekbd
PORTSCOUT= limitw:1,even
-USES= compiler:c11 cpe gettext gmake gnome libtool pathfix \
- pkgconfig tar:xz webplugin:native
-USE_GNOME= evolutiondataserver3 gnomedesktop3 gtk30 intlhack \
- introspection
-USE_XORG= x11 xfixes sm
+USES= compiler:c11 cpe gettext gmake gnome libtool localbase \
+ pathfix pkgconfig sqlite tar:xz webplugin:native
+USE_GNOME= cairo evolutiondataserver3 gdkpixbuf2 gtk30 intltool \
+ introspection libxml2
+USE_XORG= x11 xcomposite xdamage xext xfixes xi xrandr
+USE_GL= egl
USE_GSTREAMER1= yes
GNU_CONFIGURE= yes
USE_LDCONFIG= yes
WEBPLUGIN_NAME= libgnome-shell-browser-plugin.so
WEBPLUGIN_DIR= ${PREFIX}/lib/mozilla/plugins/
WEBPLUGIN_FILES=libgnome-shell-browser-plugin.so
-CONFIGURE_ARGS+=--enable-compile-warnings=no \
- --with-ca-certificates=${LOCALBASE}/share/certs/ca-root-nss.crt
-CPPFLAGS+= -I${LOCALASE}/include
-LDFLAGS+= -L${LOCALBASE}/lib
INSTALL_TARGET= install-strip
CPE_VENDOR= gnome
@@ -57,10 +68,5 @@ GLIB_SCHEMAS= org.gnome.shell.gschema.xml
post-patch:
@${REINPLACE_CMD} -e 's|applications.menu|gnome-applications.menu|g' \
${WRKSRC}/src/shell-app-system.c
- @${REINPLACE_CMD} -e 's|\-DG_DISABLE_DEPRECATED||g' \
- ${WRKSRC}/src/Makefile.in \
- ${WRKSRC}/browser-plugin/Makefile.in
- @${REINPLACE_CMD} -e 's|libnm-glib libnm-util ||g' \
- ${WRKSRC}/configure
.include <bsd.port.mk>
diff --git a/x11/gnome-shell/distinfo b/x11/gnome-shell/distinfo
index 3aa3df14cc15..8470830495c9 100644
--- a/x11/gnome-shell/distinfo
+++ b/x11/gnome-shell/distinfo
@@ -1,2 +1,3 @@
-SHA256 (gnome3/gnome-shell-3.18.4.tar.xz) = d959c0aae4c10b194d1fa29e89d34d73a4d35d74f384bf604d78435bf9ced5d7
-SIZE (gnome3/gnome-shell-3.18.4.tar.xz) = 1591644
+TIMESTAMP = 1493586851
+SHA256 (gnome3/gnome-shell-3.18.5.tar.xz) = 6fc9cd8b43b1ca0669e1c5a9de092a67eea648e38585f0cdb960f08a16c6cb20
+SIZE (gnome3/gnome-shell-3.18.5.tar.xz) = 1591860
diff --git a/x11/gnome-shell/pkg-message b/x11/gnome-shell/pkg-message
index a169c16947cd..e0f247cadbe4 100644
--- a/x11/gnome-shell/pkg-message
+++ b/x11/gnome-shell/pkg-message
@@ -8,8 +8,10 @@ gdm user also needs this access.
Access can be granted by adding the user(s) to the video group.
+% pw groupmod video -m jerry
+
Additional for FreeBSD versions before FreeBSD 11.0-CURRENT revision
-286524. And any FreeBSD 10.x version and FreeBSD 9.3-Release.
+286524, and any FreeBSD 10.x version.
By using a devfs.rules(5) to change the mode of the /dev/dri/card0 on creation.