aboutsummaryrefslogtreecommitdiff
path: root/x11/gnome-shell
diff options
context:
space:
mode:
authorJoe Marcus Clarke <marcus@FreeBSD.org>2009-11-28 20:06:37 +0000
committerJoe Marcus Clarke <marcus@FreeBSD.org>2009-11-28 20:06:37 +0000
commitf76d32b8e89fed7c0e459c1a7fe7a4b57661b01c (patch)
treead29e6808ff698f84e08dab8e047f0ae72838df9 /x11/gnome-shell
parent873cae3ab41a109b6f9cf9f4149f101d6d996235 (diff)
Presenting GNOME 2.28.1 for FreeBSD. The official release notes for this
release can be found at http://library.gnome.org/misc/release-notes/2.28/ . Officially, this is mostly a polishing release in preparation for GNOME 3.0 due in about a year. On the FreeBSD front, though, a lot went into this release. Major thanks goes to kwm and avl who did a lot of the porting work for this release. In particular, kwm brought in Evolution MAPI support for better Microsoft Exchange integration. Avl made sure that the new gobject introspection repository ports were nicely compartmentalized so that large dependencies aren't brought in wholesale. But, every GNOME team member (ahze, avl, bland, kwm, mezz, and myself) contributed to this release. Other major improvements include an updated HAL with better volume probing code, ufsid integration, and support for volume names containing spaces (big thanks to J.R. Oldroyd); a new WebKit; updated AbiWord; an updated Gimp; and a preview of the new GNOME Shell project (thanks to Pawel Worach). The FreeBSD GNOME Team would like to that the following additional contributors to this release whose patches and testing really helped make it a success: Andrius Morkunas Dominique Goncalves Eric L. Chen J.R. Oldroyd Joseph S. Atkinson Li Pawel Worach Romain Tartière Thomas Vogt Yasuda Keisuke Rui Paulo Martin Wilke (and an extra shout out to miwi and pav for pointyhat runs) We would like to send this release out to Alexander Loginov (avl) in hopes that he feels better soon. PR: 136676 136967 138872 (obsolete with new epiphany-webkit) 139160 134737 139941 140097 140838 140929
Notes
Notes: svn path=/head/; revision=244923
Diffstat (limited to 'x11/gnome-shell')
-rw-r--r--x11/gnome-shell/Makefile49
-rw-r--r--x11/gnome-shell/distinfo3
-rw-r--r--x11/gnome-shell/files/patch-src_Makefile.in18
-rw-r--r--x11/gnome-shell/files/patch-src_gdmuser_gdm-user-manager.c11
-rw-r--r--x11/gnome-shell/files/patch-src_gnome-shell.in8
-rw-r--r--x11/gnome-shell/pkg-descr3
-rw-r--r--x11/gnome-shell/pkg-message33
-rw-r--r--x11/gnome-shell/pkg-plist76
8 files changed, 201 insertions, 0 deletions
diff --git a/x11/gnome-shell/Makefile b/x11/gnome-shell/Makefile
new file mode 100644
index 000000000000..6c9aa50c86fd
--- /dev/null
+++ b/x11/gnome-shell/Makefile
@@ -0,0 +1,49 @@
+# New ports collection makefile for: gnome-shell
+# Date created: 14 Aug 2009
+# Whom: Pawel Worach <pawel.worach@gmail.com>
+#
+# $FreeBSD$
+# $MCom: ports/x11/gnome-shell/Makefile,v 1.6 2009/10/08 06:58:31 kwm Exp $
+#
+
+PORTNAME= gnome-shell
+PORTVERSION= 2.28.0
+CATEGORIES= x11
+MASTER_SITES= GNOME
+DIST_SUBDIR= gnome2
+
+MAINTAINER= gnome@FreeBSD.org
+COMMENT= Next generation GNOME desktop shell
+
+BUILD_DEPENDS= ${LOCALBASE}/share/gir-1.0/Gtk-2.0.gir:${PORTSDIR}/x11-toolkits/gir-repository-gtk20
+LIB_DEPENDS= startup-notification-1.0:${PORTSDIR}/x11/startup-notification \
+ mutter-private.0:${PORTSDIR}/x11-wm/mutter \
+ clutter-glx-1.0:${PORTSDIR}/graphics/clutter \
+ gjs-gi:${PORTSDIR}/lang/gjs
+RUN_DEPENDS= ${LOCALBASE}/libdata/pkgconfig/dbus-python.pc:${PORTSDIR}/devel/py-dbus \
+ ${LOCALBASE}/share/gir-1.0/Gtk-2.0.gir:${PORTSDIR}/x11-toolkits/gir-repository-gtk20
+
+USE_BZIP2= yes
+USE_XORG= x11 xfixes sm
+USE_GETTEXT= yes
+USE_GMAKE= yes
+USE_AUTOTOOLS= libtool:22
+USE_GNOME= gnomeprefix gnomehack intlhack gtk20 gconf2 gnomemenus \
+ gnomedesktop ltverhack libgnomeui librsvg2
+USE_GSTREAMER= theora
+USE_LDCONFIG= yes
+CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include/js -I${LOCALBASE}/include/nspr"
+
+GCONF_SCHEMAS= gnome-shell.schemas
+
+post-patch:
+ @${REINPLACE_CMD} -e 's|-Werror||g' \
+ ${WRKSRC}/configure
+ @${REINPLACE_CMD} -e 's|/usr/bin/python|/usr/bin/env python|g' \
+ -e 's|%%LOCALBASE%%|${LOCALBASE}|g' \
+ ${WRKSRC}/src/gnome-shell.in
+
+post-install:
+ @${CAT} ${PKGMESSAGE}
+
+.include <bsd.port.mk>
diff --git a/x11/gnome-shell/distinfo b/x11/gnome-shell/distinfo
new file mode 100644
index 000000000000..a96b0a90297d
--- /dev/null
+++ b/x11/gnome-shell/distinfo
@@ -0,0 +1,3 @@
+MD5 (gnome2/gnome-shell-2.28.0.tar.bz2) = a9f93a6f03da60f2f6e3fb82a9e7dc94
+SHA256 (gnome2/gnome-shell-2.28.0.tar.bz2) = 64d30bd2692af2047a3056545b8f549c713ee91877cee8742d4b02d606ef6bd4
+SIZE (gnome2/gnome-shell-2.28.0.tar.bz2) = 591376
diff --git a/x11/gnome-shell/files/patch-src_Makefile.in b/x11/gnome-shell/files/patch-src_Makefile.in
new file mode 100644
index 000000000000..592ea873a8f7
--- /dev/null
+++ b/x11/gnome-shell/files/patch-src_Makefile.in
@@ -0,0 +1,18 @@
+--- src/Makefile.in.orig 2009-08-29 12:13:13.000000000 +0200
++++ src/Makefile.in 2009-08-29 12:13:25.000000000 +0200
+@@ -492,7 +492,6 @@ libtray_la_CPPFLAGS = $(tray_cflags)
+ libtray_la_LDFLAGS = $(LDADD)
+ gnome_shell_cflags = \
+ $(MUTTER_PLUGIN_CFLAGS) \
+- $(LIBGNOMEUI_CFLAGS) \
+ -I$(srcdir)/tray \
+ -DGETTEXT_PACKAGE=\"gnome-shell\" \
+ -DLOCALEDIR=\"$(datadir)/locale\" \
+@@ -548,7 +547,6 @@ libgnome_shell_la_gir_sources = \
+ libgnome_shell_la_LDFLAGS = -avoid-version -module
+ libgnome_shell_la_LIBADD = \
+ $(MUTTER_PLUGIN_LIBS) \
+- $(LIBGNOMEUI_LIBS) \
+ libbig-1.0.la \
+ libgdmuser-1.0.la \
+ libtray.la
diff --git a/x11/gnome-shell/files/patch-src_gdmuser_gdm-user-manager.c b/x11/gnome-shell/files/patch-src_gdmuser_gdm-user-manager.c
new file mode 100644
index 000000000000..1bf59d1bcdf9
--- /dev/null
+++ b/x11/gnome-shell/files/patch-src_gdmuser_gdm-user-manager.c
@@ -0,0 +1,11 @@
+--- src/gdmuser/gdm-user-manager.c.orig 2009-08-14 05:38:43.000000000 +0000
++++ src/gdmuser/gdm-user-manager.c 2009-08-14 05:39:14.000000000 +0000
+@@ -1297,7 +1297,7 @@
+ }
+ }
+
+- for (pwent = fgetpwent (fp); pwent != NULL; pwent = fgetpwent (fp)) {
++ for (pwent = getpwent(); pwent != NULL; pwent = getpwent()) {
+ GdmUser *user;
+
+ user = NULL;
diff --git a/x11/gnome-shell/files/patch-src_gnome-shell.in b/x11/gnome-shell/files/patch-src_gnome-shell.in
new file mode 100644
index 000000000000..07775f34dba4
--- /dev/null
+++ b/x11/gnome-shell/files/patch-src_gnome-shell.in
@@ -0,0 +1,8 @@
+--- src/gnome-shell.in.orig 2009-08-28 18:34:04.000000000 +0200
++++ src/gnome-shell.in 2009-08-29 12:13:44.000000000 +0200
+@@ -1,4 +1,4 @@
+-#!/usr/bin/python
++#!/usr/bin/env python
+
+ import atexit
+ import optparse
diff --git a/x11/gnome-shell/pkg-descr b/x11/gnome-shell/pkg-descr
new file mode 100644
index 000000000000..693aa3b6e258
--- /dev/null
+++ b/x11/gnome-shell/pkg-descr
@@ -0,0 +1,3 @@
+Next generation GNOME desktop shell
+
+WWW: http://live.gnome.org/GnomeShell
diff --git a/x11/gnome-shell/pkg-message b/x11/gnome-shell/pkg-message
new file mode 100644
index 000000000000..e00823112f4b
--- /dev/null
+++ b/x11/gnome-shell/pkg-message
@@ -0,0 +1,33 @@
+Running
+
+You can either start gnome-shell "nested" in a window within your current
+session, or you can run it within your session replacing gnome-panel and
+window manager.
+
+Depending on the state of your X drivers, one or of the other of these may
+work better. So, if the first one you try doesn't work, try the other.
+
+====
+
+Running gnome-shell replacing the panel
+
+This approach is best when trying out the GNOME Shell and wanting to see its
+full potential.
+
+gnome-shell --replace
+
+When gnome-shell exits (you can kill it with Control-C in the terminal in which
+you started it), gnome-panel and metacity are restarted.
+
+====
+
+Running gnome-shell nested
+
+This approach is useful when developing the GNOME Shell and wanting to quickly
+test some changes. NOTE: It isn't useful for getting a good feel for how the
+shell works since it will be really slow, and won't properly integrate with
+the rest of your desktop.
+
+gnome-shell
+(This requires a relatively recent version of Xephyr with GLX support to be
+installed on your system (x11-servers/xephyr).
diff --git a/x11/gnome-shell/pkg-plist b/x11/gnome-shell/pkg-plist
new file mode 100644
index 000000000000..a5c993c9bee7
--- /dev/null
+++ b/x11/gnome-shell/pkg-plist
@@ -0,0 +1,76 @@
+bin/gnome-shell
+lib/gnome-shell/Big-1.0.typelib
+lib/gnome-shell/Shell-0.1.typelib
+lib/gnome-shell/St-1.0.typelib
+share/applications/gnome-shell.desktop
+%%DATADIR%%/images/app-well-glow.png
+%%DATADIR%%/images/add-workspace.svg
+%%DATADIR%%/images/back.svg
+%%DATADIR%%/images/close-black.svg
+%%DATADIR%%/images/close.svg
+%%DATADIR%%/images/info.svg
+%%DATADIR%%/images/magnifier.svg
+%%DATADIR%%/images/remove-workspace.svg
+%%DATADIR%%/js/misc/docInfo.js
+%%DATADIR%%/js/misc/format.js
+%%DATADIR%%/js/ui/appIcon.js
+%%DATADIR%%/js/ui/altTab.js
+%%DATADIR%%/js/ui/appDisplay.js
+%%DATADIR%%/js/ui/button.js
+%%DATADIR%%/js/ui/calendar.js
+%%DATADIR%%/js/ui/chrome.js
+%%DATADIR%%/js/ui/dash.js
+%%DATADIR%%/js/ui/dnd.js
+%%DATADIR%%/js/ui/docDisplay.js
+%%DATADIR%%/js/ui/environment.js
+%%DATADIR%%/js/ui/genericDisplay.js
+%%DATADIR%%/js/ui/lightbox.js
+%%DATADIR%%/js/ui/link.js
+%%DATADIR%%/js/ui/lookingGlass.js
+%%DATADIR%%/js/ui/main.js
+%%DATADIR%%/js/ui/overview.js
+%%DATADIR%%/js/ui/panel.js
+%%DATADIR%%/js/ui/places.js
+%%DATADIR%%/js/ui/runDialog.js
+%%DATADIR%%/js/ui/shellDBus.js
+%%DATADIR%%/js/ui/sidebar.js
+%%DATADIR%%/js/ui/tweener.js
+%%DATADIR%%/js/ui/widget.js
+%%DATADIR%%/js/ui/widgetBox.js
+%%DATADIR%%/js/ui/windowManager.js
+%%DATADIR%%/js/ui/workspaces.js
+%%DATADIR%%/theme/gnome-shell.css
+%%DATADIR%%/theme/scroll-button-down-hover.png
+%%DATADIR%%/theme/scroll-button-down.png
+%%DATADIR%%/theme/scroll-button-up-hover.png
+%%DATADIR%%/theme/scroll-button-up.png
+%%DATADIR%%/theme/scroll-vhandle.png
+share/locale/ar/LC_MESSAGES/gnome-shell.mo
+share/locale/ca/LC_MESSAGES/gnome-shell.mo
+share/locale/cs/LC_MESSAGES/gnome-shell.mo
+share/locale/da/LC_MESSAGES/gnome-shell.mo
+share/locale/de/LC_MESSAGES/gnome-shell.mo
+share/locale/en_GB/LC_MESSAGES/gnome-shell.mo
+share/locale/es/LC_MESSAGES/gnome-shell.mo
+share/locale/fr/LC_MESSAGES/gnome-shell.mo
+share/locale/ga/LC_MESSAGES/gnome-shell.mo
+share/locale/gl/LC_MESSAGES/gnome-shell.mo
+share/locale/hu/LC_MESSAGES/gnome-shell.mo
+share/locale/it/LC_MESSAGES/gnome-shell.mo
+share/locale/ko/LC_MESSAGES/gnome-shell.mo
+share/locale/nb/LC_MESSAGES/gnome-shell.mo
+share/locale/nl/LC_MESSAGES/gnome-shell.mo
+share/locale/pa/LC_MESSAGES/gnome-shell.mo
+share/locale/pl/LC_MESSAGES/gnome-shell.mo
+share/locale/pt_BR/LC_MESSAGES/gnome-shell.mo
+share/locale/sl/LC_MESSAGES/gnome-shell.mo
+share/locale/sv/LC_MESSAGES/gnome-shell.mo
+share/locale/tr/LC_MESSAGES/gnome-shell.mo
+share/locale/zh_CN/LC_MESSAGES/gnome-shell.mo
+@dirrm %%DATADIR%%/theme
+@dirrm %%DATADIR%%/js/ui
+@dirrm %%DATADIR%%/js/misc
+@dirrm %%DATADIR%%/js
+@dirrm %%DATADIR%%/images
+@dirrm %%DATADIR%%
+@dirrm lib/gnome-shell