aboutsummaryrefslogtreecommitdiff
path: root/x11/gnome-terminal/Makefile
diff options
context:
space:
mode:
authorKoop Mast <kwm@FreeBSD.org>2015-08-05 19:13:24 +0000
committerKoop Mast <kwm@FreeBSD.org>2015-08-05 19:13:24 +0000
commitd129587b5d568b0ff5300386f1e1b706c349f38e (patch)
treee398c7b6ea5203fd3953999e6dd9d6c83c9ec931 /x11/gnome-terminal/Makefile
parentc13de12f75988e599e389d9c77ed92db8d927185 (diff)
downloadports-d129587b5d568b0ff5300386f1e1b706c349f38e.tar.gz
ports-d129587b5d568b0ff5300386f1e1b706c349f38e.zip
Notes
Diffstat (limited to 'x11/gnome-terminal/Makefile')
-rw-r--r--x11/gnome-terminal/Makefile29
1 files changed, 19 insertions, 10 deletions
diff --git a/x11/gnome-terminal/Makefile b/x11/gnome-terminal/Makefile
index 21baaceb1f6d..d1b33ec2de5d 100644
--- a/x11/gnome-terminal/Makefile
+++ b/x11/gnome-terminal/Makefile
@@ -1,9 +1,8 @@
# Created by: Joe Marcus Clarke <marcus@FreeBSD.org>
# $FreeBSD$
-# $MCom: ports/trunk/x11/gnome-terminal/Makefile 20059 2014-11-10 21:24:07Z gusi $
PORTNAME= gnome-terminal
-PORTVERSION= 3.14.3
+PORTVERSION= 3.16.2
CATEGORIES= x11 gnome
MASTER_SITES= GNOME
DIST_SUBDIR= gnome3
@@ -13,17 +12,18 @@ COMMENT= Terminal component for the GNOME 3 Desktop
BUILD_DEPENDS= gsettings-desktop-schemas>=0:${PORTSDIR}/devel/gsettings-desktop-schemas \
itstool:${PORTSDIR}/textproc/itstool \
- appdata-tools>=0:${PORTSDIR}/devel/appdata-tools \
+ appdata-validate:${PORTSDIR}/devel/appstream-glib \
vala:${PORTSDIR}/lang/vala
LIB_DEPENDS= libstartup-notification-1.so:${PORTSDIR}/x11/startup-notification \
libuuid.so:${PORTSDIR}/misc/e2fsprogs-libuuid
RUN_DEPENDS= gsettings-desktop-schemas>=0:${PORTSDIR}/devel/gsettings-desktop-schemas
+PORTSCOUT= limitw:1,even
+
USES= cpe gettext gmake libtool pathfix pkgconfig tar:xz
-USE_GNOME= dconf gnomeprefix gtk30 intlhack nautilus3 vte3
+USE_GNOME= dconf gtk30 intlhack nautilus3 vte3
USE_XORG= sm ice
GNU_CONFIGURE= yes
-CONFIGURE_ARGS= --disable-search-provider
CPPFLAGS+= -I${LOCALBASE}/include
LDFLAGS+= -L${LOCALBASE}/lib
INSTALL_TARGET= install-strip
@@ -31,12 +31,16 @@ CPE_VENDOR= gnome
GLIB_SCHEMAS= org.gnome.Terminal.gschema.xml
-OPTIONS_SUB= yes
-OPTIONS_DEFINE= MIGRATION
-OPTIONS_DEFAULT= MIGRATION
+OPTIONS_SUB= yes
+OPTIONS_DEFINE= MIGRATION SEARCHPROVIDER
+OPTIONS_DEFAULT= SEARCHPROVIDER
+SEARCHPROVIDER_DESC= Gnome-shell search provider
+SEARCHPROVIDER_CONFIGURE_ENABLE= search-provider
+SEARCHPROVIDER_BUILD_DEPENDS= gnome-shell:${PORTSDIR}/x11/gnome-shell
+SEARCHPROVIDER_RUN_DEPENDS= gnome-shell:${PORTSDIR}/x11/gnome-shell
MIGRATION_CONFIGURE_ENABLE= migration
-MIGRATION_USE= GNOME=gconf2
-MIGRATION_DESC= Profile migration to gsettings (pulls in gconf2)
+MIGRATION_USE= GNOME=gconf2
+MIGRATION_DESC= Profile migration to gsettings (pulls in gconf2)
.include <bsd.port.options.mk>
@@ -50,4 +54,9 @@ post-patch:
EXTRA_PATCHES+= ${FILESDIR}/extra-src_terminal-screen.c
.endif
+post-install:
+.for i in cs de el es fi fr gl hu pt_BR ru
+ @${RMDIR} ${STAGEDIR}${PREFIX}/share/help/${i}/gnome-terminal/figures
+.endfor
+
.include <bsd.port.mk>