aboutsummaryrefslogtreecommitdiff
path: root/x11/gnome-terminal
diff options
context:
space:
mode:
authorJoe Marcus Clarke <marcus@FreeBSD.org>2006-10-14 08:35:50 +0000
committerJoe Marcus Clarke <marcus@FreeBSD.org>2006-10-14 08:35:50 +0000
commitf1bb12de8e50bf76ae21f37debda60994ec7fd99 (patch)
tree1671d4beef381f12d939e34b344eb385a3af4f19 /x11/gnome-terminal
parent29adee7bb42244f34736c5c24ed18a9b269d0925 (diff)
Notes
Diffstat (limited to 'x11/gnome-terminal')
-rw-r--r--x11/gnome-terminal/Makefile8
-rw-r--r--x11/gnome-terminal/distinfo6
-rw-r--r--x11/gnome-terminal/files/patch-src_terminal-screen.c12
-rw-r--r--x11/gnome-terminal/pkg-plist70
4 files changed, 73 insertions, 23 deletions
diff --git a/x11/gnome-terminal/Makefile b/x11/gnome-terminal/Makefile
index 1ec65fad47aa..ef60118c8920 100644
--- a/x11/gnome-terminal/Makefile
+++ b/x11/gnome-terminal/Makefile
@@ -3,11 +3,11 @@
# Whom: Joe Marcus Clarke <marcus@FreeBSD.org>
#
# $FreeBSD$
-# $MCom: ports/x11/gnometerminal/Makefile,v 1.69 2006/04/13 07:52:41 bland Exp $
+# $MCom: ports/x11/gnome-terminal/Makefile,v 1.81 2006/10/03 10:31:27 ahze Exp $
#
PORTNAME= gnome-terminal
-PORTVERSION= 2.14.2
+PORTVERSION= 2.16.1
CATEGORIES= x11 gnome
MASTER_SITES= ${MASTER_SITE_GNOME}
MASTER_SITE_SUBDIR= sources/${PORTNAME}/${PORTVERSION:C/^([0-9]+\.[0-9]+).*/\1/}
@@ -19,9 +19,9 @@ COMMENT= Terminal component for the GNOME 2 Desktop
USE_GETTEXT= yes
USE_BZIP2= yes
INSTALLS_OMF= yes
-USE_X_PREFIX= yes
+USE_XLIB= yes
USE_GMAKE= yes
-USE_GNOME= gnomeprefix gnomehack intlhack libgnomeui vte
+USE_GNOME= gnomeprefix gnomehack intlhack libgnomeui vte gnomedocutils
GNU_CONFIGURE= yes
CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include" \
LDFLAGS="-L${LOCALBASE}/lib"
diff --git a/x11/gnome-terminal/distinfo b/x11/gnome-terminal/distinfo
index 999f8bf18e87..8338f725a82c 100644
--- a/x11/gnome-terminal/distinfo
+++ b/x11/gnome-terminal/distinfo
@@ -1,3 +1,3 @@
-MD5 (gnome2/gnome-terminal-2.14.2.tar.bz2) = da80071cd707e89cedcfb476cab8b39a
-SHA256 (gnome2/gnome-terminal-2.14.2.tar.bz2) = bd7d500b16ecf1d6189f12ea5d936c218a3e1927ee5ce39119d3aeb8015cca91
-SIZE (gnome2/gnome-terminal-2.14.2.tar.bz2) = 1791473
+MD5 (gnome2/gnome-terminal-2.16.1.tar.bz2) = 861e1b780819214b4d5a398e7999c093
+SHA256 (gnome2/gnome-terminal-2.16.1.tar.bz2) = 814ab099689aabdc6351565215ce6e5a2fc93e8b05fafd3ca70f4cefe167caf0
+SIZE (gnome2/gnome-terminal-2.16.1.tar.bz2) = 1840537
diff --git a/x11/gnome-terminal/files/patch-src_terminal-screen.c b/x11/gnome-terminal/files/patch-src_terminal-screen.c
index 0f5c397cbadd..ffa05b4fcfd6 100644
--- a/x11/gnome-terminal/files/patch-src_terminal-screen.c
+++ b/x11/gnome-terminal/files/patch-src_terminal-screen.c
@@ -1,19 +1,19 @@
---- src/terminal-screen.c.orig Sun Apr 2 18:27:36 2006
-+++ src/terminal-screen.c Sun Apr 2 18:42:41 2006
+--- src/terminal-screen.c.orig Wed May 17 17:02:36 2006
++++ src/terminal-screen.c Thu May 18 15:30:27 2006
@@ -278,22 +278,22 @@ terminal_screen_init (TerminalScreen *sc
#define URLPATH "/[" PATHCHARS "]*[^]'.}>) \t\r\n,\\\"]"
terminal_widget_match_add (screen->priv->term,
- "\\<" SCHEME "//(" USER "@)?[" HOSTCHARS ".]+"
-- "(:[0-9]+)?(" URLPATH ")?\\>", FLAVOR_AS_IS);
+- "(:[0-9]+)?(" URLPATH ")?\\>/?", FLAVOR_AS_IS);
+ "[[:<:]]" SCHEME "//(" USER "@)?[" HOSTCHARS ".]+"
-+ "(:[0-9]+)?(" URLPATH ")?[[:>:]]", FLAVOR_AS_IS);
++ "(:[0-9]+)?(" URLPATH ")?[[:>:]]/?", FLAVOR_AS_IS);
terminal_widget_match_add (screen->priv->term,
- "\\<(www|ftp)[" HOSTCHARS "]*\\.[" HOSTCHARS ".]+"
-- "(:[0-9]+)?(" URLPATH ")?\\>",
+- "(:[0-9]+)?(" URLPATH ")?\\>/?",
+ "[[:<:]](www|ftp)[" HOSTCHARS "]*\\.[" HOSTCHARS ".]+"
-+ "(:[0-9]+)?(" URLPATH ")?[[:>:]]",
++ "(:[0-9]+)?(" URLPATH ")?[[:>:]]/?",
FLAVOR_DEFAULT_TO_HTTP);
terminal_widget_match_add (screen->priv->term,
diff --git a/x11/gnome-terminal/pkg-plist b/x11/gnome-terminal/pkg-plist
index 380a52ff47c5..efd1e99662db 100644
--- a/x11/gnome-terminal/pkg-plist
+++ b/x11/gnome-terminal/pkg-plist
@@ -26,7 +26,6 @@ share/gnome/help/gnome-terminal/fr/figures/gnome-terminal-default.png
share/gnome/help/gnome-terminal/fr/figures/gnome-terminal-tabbed.png
share/gnome/help/gnome-terminal/fr/figures/terminal_window.png
share/gnome/help/gnome-terminal/fr/gnome-terminal.xml
-share/gnome/help/gnome-terminal/fr/legal.xml
share/gnome/help/gnome-terminal/it/figures/gnome-terminal-default.png
share/gnome/help/gnome-terminal/it/figures/gnome-terminal-tabbed.png
share/gnome/help/gnome-terminal/it/figures/terminal_window.png
@@ -51,7 +50,6 @@ share/gnome/help/gnome-terminal/sv/figures/gnome-terminal-default.png
share/gnome/help/gnome-terminal/sv/figures/gnome-terminal-tabbed.png
share/gnome/help/gnome-terminal/sv/figures/terminal_window.png
share/gnome/help/gnome-terminal/sv/gnome-terminal.xml
-share/gnome/help/gnome-terminal/sv/legal.xml
share/gnome/help/gnome-terminal/uk/figures/gnome-terminal-default.png
share/gnome/help/gnome-terminal/uk/figures/gnome-terminal-tabbed.png
share/gnome/help/gnome-terminal/uk/gnome-terminal.xml
@@ -86,8 +84,8 @@ share/locale/az/LC_MESSAGES/gnome-terminal.mo
share/locale/be/LC_MESSAGES/gnome-terminal.mo
share/locale/bg/LC_MESSAGES/gnome-terminal.mo
share/locale/bn/LC_MESSAGES/gnome-terminal.mo
+share/locale/bn_IN/LC_MESSAGES/gnome-terminal.mo
share/locale/bs/LC_MESSAGES/gnome-terminal.mo
-share/locale/br/LC_MESSAGES/gnome-terminal.mo
share/locale/ca/LC_MESSAGES/gnome-terminal.mo
share/locale/cs/LC_MESSAGES/gnome-terminal.mo
share/locale/cy/LC_MESSAGES/gnome-terminal.mo
@@ -114,19 +112,22 @@ share/locale/hy/LC_MESSAGES/gnome-terminal.mo
share/locale/id/LC_MESSAGES/gnome-terminal.mo
share/locale/it/LC_MESSAGES/gnome-terminal.mo
share/locale/ja/LC_MESSAGES/gnome-terminal.mo
+share/locale/ka/LC_MESSAGES/gnome-terminal.mo
share/locale/ko/LC_MESSAGES/gnome-terminal.mo
share/locale/ku/LC_MESSAGES/gnome-terminal.mo
share/locale/lt/LC_MESSAGES/gnome-terminal.mo
share/locale/lv/LC_MESSAGES/gnome-terminal.mo
+share/locale/mg/LC_MESSAGES/gnome-terminal.mo
share/locale/mk/LC_MESSAGES/gnome-terminal.mo
share/locale/ml/LC_MESSAGES/gnome-terminal.mo
share/locale/mn/LC_MESSAGES/gnome-terminal.mo
+share/locale/mr/LC_MESSAGES/gnome-terminal.mo
share/locale/ms/LC_MESSAGES/gnome-terminal.mo
share/locale/nb/LC_MESSAGES/gnome-terminal.mo
share/locale/ne/LC_MESSAGES/gnome-terminal.mo
share/locale/nl/LC_MESSAGES/gnome-terminal.mo
share/locale/nn/LC_MESSAGES/gnome-terminal.mo
-share/locale/no/LC_MESSAGES/gnome-terminal.mo
+share/locale/or/LC_MESSAGES/gnome-terminal.mo
share/locale/pa/LC_MESSAGES/gnome-terminal.mo
share/locale/pl/LC_MESSAGES/gnome-terminal.mo
share/locale/pt/LC_MESSAGES/gnome-terminal.mo
@@ -148,13 +149,8 @@ share/locale/vi/LC_MESSAGES/gnome-terminal.mo
share/locale/wa/LC_MESSAGES/gnome-terminal.mo
share/locale/xh/LC_MESSAGES/gnome-terminal.mo
share/locale/zh_CN/LC_MESSAGES/gnome-terminal.mo
+share/locale/zh_HK/LC_MESSAGES/gnome-terminal.mo
share/locale/zh_TW/LC_MESSAGES/gnome-terminal.mo
-@dirrmtry share/locale/ku/LC_MESSAGES
-@dirrmtry share/locale/ku
-@dirrmtry share/locale/dz/LC_MESSAGES
-@dirrmtry share/locale/dz
-@dirrmtry share/locale/br/LC_MESSAGES
-@dirrmtry share/locale/br
@dirrm share/gnome/omf/gnome-terminal
@dirrm share/gnome/help/gnome-terminal/zh_TW/figures
@dirrm share/gnome/help/gnome-terminal/zh_TW
@@ -185,3 +181,57 @@ share/locale/zh_TW/LC_MESSAGES/gnome-terminal.mo
@dirrm share/gnome/help/gnome-terminal
@dirrm share/gnome/gnome-terminal/glade
@dirrm share/gnome/gnome-terminal
+@dirrmtry share/locale/zh_TW/LC_MESSAGES
+@dirrmtry share/locale/zh_TW
+@dirrmtry share/locale/zh_HK/LC_MESSAGES
+@dirrmtry share/locale/zh_HK
+@dirrmtry share/locale/zh_CN/LC_MESSAGES
+@dirrmtry share/locale/zh_CN
+@dirrmtry share/locale/xh/LC_MESSAGES
+@dirrmtry share/locale/xh
+@dirrmtry share/locale/uk/LC_MESSAGES
+@dirrmtry share/locale/uk
+@dirrmtry share/locale/sr/LC_MESSAGES
+@dirrmtry share/locale/sr
+@dirrmtry share/locale/sl/LC_MESSAGES
+@dirrmtry share/locale/sl
+@dirrmtry share/locale/sk/LC_MESSAGES
+@dirrmtry share/locale/sk
+@dirrmtry share/locale/rw/LC_MESSAGES
+@dirrmtry share/locale/rw
+@dirrmtry share/locale/ro/LC_MESSAGES
+@dirrmtry share/locale/ro
+@dirrmtry share/locale/pt/LC_MESSAGES
+@dirrmtry share/locale/pt
+@dirrmtry share/locale/pl/LC_MESSAGES
+@dirrmtry share/locale/pl
+@dirrmtry share/locale/nn/LC_MESSAGES
+@dirrmtry share/locale/nn
+@dirrmtry share/locale/ne/LC_MESSAGES
+@dirrmtry share/locale/ne
+@dirrmtry share/locale/mr/LC_MESSAGES
+@dirrmtry share/locale/mr
+@dirrmtry share/locale/mg/LC_MESSAGES
+@dirrmtry share/locale/mg
+@dirrmtry share/locale/ku/LC_MESSAGES
+@dirrmtry share/locale/ku
+@dirrmtry share/locale/ko/LC_MESSAGES
+@dirrmtry share/locale/ko
+@dirrmtry share/locale/hy/LC_MESSAGES
+@dirrmtry share/locale/hy
+@dirrmtry share/locale/gl/LC_MESSAGES
+@dirrmtry share/locale/gl
+@dirrmtry share/locale/fi/LC_MESSAGES
+@dirrmtry share/locale/fi
+@dirrmtry share/locale/el/LC_MESSAGES
+@dirrmtry share/locale/el
+@dirrmtry share/locale/dz/LC_MESSAGES
+@dirrmtry share/locale/dz
+@dirrmtry share/locale/cs/LC_MESSAGES
+@dirrmtry share/locale/cs
+@dirrmtry share/locale/ca/LC_MESSAGES
+@dirrmtry share/locale/ca
+@dirrmtry share/locale/bn_IN/LC_MESSAGES
+@dirrmtry share/locale/bn_IN
+@dirrmtry share/locale/be/LC_MESSAGES
+@dirrmtry share/locale/be