aboutsummaryrefslogtreecommitdiff
path: root/x11/gnome-terminal
diff options
context:
space:
mode:
authorJoe Marcus Clarke <marcus@FreeBSD.org>2006-04-30 00:47:21 +0000
committerJoe Marcus Clarke <marcus@FreeBSD.org>2006-04-30 00:47:21 +0000
commit798e9bed2a389dce8a970e15b68176fd49f442db (patch)
tree9dc5597aab073298ec381964f72cd853b3dd366c /x11/gnome-terminal
parent48b92584b0722f7f6ca412e6cfe16f1381e043cc (diff)
downloadports-798e9bed2a389dce8a970e15b68176fd49f442db.tar.gz
ports-798e9bed2a389dce8a970e15b68176fd49f442db.zip
Notes
Diffstat (limited to 'x11/gnome-terminal')
-rw-r--r--x11/gnome-terminal/Makefile8
-rw-r--r--x11/gnome-terminal/distinfo6
-rw-r--r--x11/gnome-terminal/files/patch-src::terminal-screen.c23
-rw-r--r--x11/gnome-terminal/files/patch-src_terminal-screen.c33
-rw-r--r--x11/gnome-terminal/pkg-plist18
5 files changed, 57 insertions, 31 deletions
diff --git a/x11/gnome-terminal/Makefile b/x11/gnome-terminal/Makefile
index c1c5d6bcecde..a8578865b0f7 100644
--- a/x11/gnome-terminal/Makefile
+++ b/x11/gnome-terminal/Makefile
@@ -3,24 +3,24 @@
# Whom: Joe Marcus Clarke <marcus@FreeBSD.org>
#
# $FreeBSD$
-# $MCom: ports/x11/gnometerminal/Makefile,v 1.52 2005/10/14 20:39:58 adamw Exp $
+# $MCom: ports/x11/gnometerminal/Makefile,v 1.69 2006/04/13 07:52:41 bland Exp $
#
PORTNAME= gnometerminal
-PORTVERSION= 2.12.0
+PORTVERSION= 2.14.1
CATEGORIES= x11 gnome
MASTER_SITES= ${MASTER_SITE_GNOME}
-MASTER_SITE_SUBDIR= sources/gnome-terminal/2.12
+MASTER_SITE_SUBDIR= sources/gnome-terminal/${PORTVERSION:C/^([0-9]+\.[0-9]+).*/\1/}
DISTNAME= gnome-terminal-${PORTVERSION}
DIST_SUBDIR= gnome2
MAINTAINER= gnome@FreeBSD.org
COMMENT= Terminal component for the GNOME 2 Desktop
+USE_GETTEXT= yes
USE_BZIP2= yes
INSTALLS_OMF= yes
USE_X_PREFIX= yes
-USE_REINPLACE= yes
USE_GMAKE= yes
USE_GNOME= gnomeprefix gnomehack intlhack libgnomeui vte
GNU_CONFIGURE= yes
diff --git a/x11/gnome-terminal/distinfo b/x11/gnome-terminal/distinfo
index 951536429cf1..73abf3d6655d 100644
--- a/x11/gnome-terminal/distinfo
+++ b/x11/gnome-terminal/distinfo
@@ -1,3 +1,3 @@
-MD5 (gnome2/gnome-terminal-2.12.0.tar.bz2) = 483c9397dd165845e2528a80e3df6dfc
-SHA256 (gnome2/gnome-terminal-2.12.0.tar.bz2) = e515509f2d07ab1360723b70345ac18b44c5525abc31cce48f135b43fbb444cc
-SIZE (gnome2/gnome-terminal-2.12.0.tar.bz2) = 1684178
+MD5 (gnome2/gnome-terminal-2.14.1.tar.bz2) = 7abe60db5359c88392d2b4f0d5587ef5
+SHA256 (gnome2/gnome-terminal-2.14.1.tar.bz2) = c1e7674bb75343db89ad6769bc2d7ecfb115d9eda02035d374d8c4d952091647
+SIZE (gnome2/gnome-terminal-2.14.1.tar.bz2) = 1783063
diff --git a/x11/gnome-terminal/files/patch-src::terminal-screen.c b/x11/gnome-terminal/files/patch-src::terminal-screen.c
deleted file mode 100644
index 0198f748c37d..000000000000
--- a/x11/gnome-terminal/files/patch-src::terminal-screen.c
+++ /dev/null
@@ -1,23 +0,0 @@
---- src/terminal-screen.c.orig Fri Jul 1 20:37:58 2005
-+++ src/terminal-screen.c Tue Jul 5 13:26:21 2005
-@@ -248,16 +248,16 @@ terminal_screen_init (TerminalScreen *sc
- #define URLPATH "/[" PATHCHARS "]*[^]'.}>) \t\r\n,\\\"]"
-
- terminal_widget_match_add (screen->priv->term,
-- "\\<(" SCHEME "://(" USER "@)?)[" HOSTCHARS ".]+(:[0-9]+)?(" URLPATH ")?", FLAVOR_AS_IS);
-+ "[[:<:]](" SCHEME "://(" USER "@)?)[" HOSTCHARS ".]+(:[0-9]+)?(" URLPATH ")?", FLAVOR_AS_IS);
-
- terminal_widget_match_add (screen->priv->term,
-- "\\<(www|ftp)[" HOSTCHARS "]*\\.[" HOSTCHARS ".]+(:[0-9]+)?(" URLPATH ")?", FLAVOR_DEFAULT_TO_HTTP);
-+ "[[:<:]]<(www|ftp)[" HOSTCHARS "]*\\.[" HOSTCHARS ".]+(:[0-9]+)?(" URLPATH ")?", FLAVOR_DEFAULT_TO_HTTP);
-
- terminal_widget_match_add (screen->priv->term,
-- "\\<(mailto:)?[a-z0-9][a-z0-9.-]*@[a-z0-9][a-z0-9-]*(\\.[a-z0-9][a-z0-9-]*)+\\>", FLAVOR_MAILTO);
-+ "[[:<:]](mailto:)?[a-z0-9][a-z0-9.-]*@[a-z0-9][a-z0-9-]*(\\.[a-z0-9][a-z0-9-]*)+\\>", FLAVOR_MAILTO);
-
- terminal_widget_match_add (screen->priv->term,
-- "\\<news:[-A-Z\\^_a-z{|}~!\"#$%&'()*+,./0-9;:=?`]+@[" HOSTCHARS ".]+(:[0-9]+)?\\>", FLAVOR_AS_IS);
-+ "[[:<:]]<news:[-A-Z\\^_a-z{|}~!\"#$%&'()*+,./0-9;:=?`]+@[" HOSTCHARS ".]+(:[0-9]+)?\\>", FLAVOR_AS_IS);
-
-
- terminal_screen_setup_dnd (screen);
diff --git a/x11/gnome-terminal/files/patch-src_terminal-screen.c b/x11/gnome-terminal/files/patch-src_terminal-screen.c
new file mode 100644
index 000000000000..0f5c397cbadd
--- /dev/null
+++ b/x11/gnome-terminal/files/patch-src_terminal-screen.c
@@ -0,0 +1,33 @@
+--- src/terminal-screen.c.orig Sun Apr 2 18:27:36 2006
++++ src/terminal-screen.c Sun Apr 2 18:42:41 2006
+@@ -278,22 +278,22 @@ terminal_screen_init (TerminalScreen *sc
+ #define URLPATH "/[" PATHCHARS "]*[^]'.}>) \t\r\n,\\\"]"
+
+ terminal_widget_match_add (screen->priv->term,
+- "\\<" SCHEME "//(" USER "@)?[" HOSTCHARS ".]+"
+- "(:[0-9]+)?(" URLPATH ")?\\>", FLAVOR_AS_IS);
++ "[[:<:]]" SCHEME "//(" USER "@)?[" HOSTCHARS ".]+"
++ "(:[0-9]+)?(" URLPATH ")?[[:>:]]", FLAVOR_AS_IS);
+
+ terminal_widget_match_add (screen->priv->term,
+- "\\<(www|ftp)[" HOSTCHARS "]*\\.[" HOSTCHARS ".]+"
+- "(:[0-9]+)?(" URLPATH ")?\\>",
++ "[[:<:]](www|ftp)[" HOSTCHARS "]*\\.[" HOSTCHARS ".]+"
++ "(:[0-9]+)?(" URLPATH ")?[[:>:]]",
+ FLAVOR_DEFAULT_TO_HTTP);
+
+ terminal_widget_match_add (screen->priv->term,
+- "\\<(mailto:)?[a-z0-9][a-z0-9.-]*@[a-z0-9]"
+- "[a-z0-9-]*(\\.[a-z0-9][a-z0-9-]*)+\\>",
++ "[[:<:]](mailto:)?[a-z0-9][a-z0-9.-]*@[a-z0-9]"
++ "[a-z0-9-]*(\\.[a-z0-9][a-z0-9-]*)+[[:>:]]",
+ FLAVOR_EMAIL);
+
+ terminal_widget_match_add (screen->priv->term,
+- "\\<news:[-A-Z\\^_a-z{|}~!\"#$%&'()*+,./0-9;:=?`]+"
+- "@[" HOSTCHARS ".]+(:[0-9]+)?\\>", FLAVOR_AS_IS);
++ "[[:<:]]news:[-A-Z\\^_a-z{|}~!\"#$%&'()*+,./0-9;:=?`]+"
++ "@[" HOSTCHARS ".]+(:[0-9]+)?[[:>:]]", FLAVOR_AS_IS);
+
+ terminal_screen_setup_dnd (screen);
+
diff --git a/x11/gnome-terminal/pkg-plist b/x11/gnome-terminal/pkg-plist
index 721f659b8cd1..380a52ff47c5 100644
--- a/x11/gnome-terminal/pkg-plist
+++ b/x11/gnome-terminal/pkg-plist
@@ -1,6 +1,5 @@
bin/gnome-terminal
libdata/bonobo/servers/gnome-terminal.server
-share/gnome/application-registry/gnome-terminal.applications
share/gnome/applications/gnome-terminal.desktop
share/gnome/gnome-terminal/glade/gnome-terminal.glade2
share/gnome/help/gnome-terminal/C/figures/gnome-terminal-default.png
@@ -8,6 +7,11 @@ share/gnome/help/gnome-terminal/C/figures/gnome-terminal-tabbed.png
share/gnome/help/gnome-terminal/C/figures/terminal_window.png
share/gnome/help/gnome-terminal/C/gnome-terminal.xml
share/gnome/help/gnome-terminal/C/legal.xml
+share/gnome/help/gnome-terminal/bg/figures/gnome-terminal-default.png
+share/gnome/help/gnome-terminal/bg/figures/gnome-terminal-tabbed.png
+share/gnome/help/gnome-terminal/bg/figures/terminal_window.png
+share/gnome/help/gnome-terminal/bg/gnome-terminal.xml
+share/gnome/help/gnome-terminal/bg/legal.xml
share/gnome/help/gnome-terminal/de/figures/gnome-terminal-default.png
share/gnome/help/gnome-terminal/de/figures/gnome-terminal-tabbed.png
share/gnome/help/gnome-terminal/de/figures/terminal_window.png
@@ -63,6 +67,7 @@ share/gnome/help/gnome-terminal/zh_TW/figures/terminal_window.png
share/gnome/help/gnome-terminal/zh_TW/gnome-terminal.xml
share/gnome/help/gnome-terminal/zh_TW/legal.xml
share/gnome/omf/gnome-terminal/gnome-terminal-C.omf
+share/gnome/omf/gnome-terminal/gnome-terminal-bg.omf
share/gnome/omf/gnome-terminal/gnome-terminal-de.omf
share/gnome/omf/gnome-terminal/gnome-terminal-es.omf
share/gnome/omf/gnome-terminal/gnome-terminal-fr.omf
@@ -82,11 +87,13 @@ share/locale/be/LC_MESSAGES/gnome-terminal.mo
share/locale/bg/LC_MESSAGES/gnome-terminal.mo
share/locale/bn/LC_MESSAGES/gnome-terminal.mo
share/locale/bs/LC_MESSAGES/gnome-terminal.mo
+share/locale/br/LC_MESSAGES/gnome-terminal.mo
share/locale/ca/LC_MESSAGES/gnome-terminal.mo
share/locale/cs/LC_MESSAGES/gnome-terminal.mo
share/locale/cy/LC_MESSAGES/gnome-terminal.mo
share/locale/da/LC_MESSAGES/gnome-terminal.mo
share/locale/de/LC_MESSAGES/gnome-terminal.mo
+share/locale/dz/LC_MESSAGES/gnome-terminal.mo
share/locale/el/LC_MESSAGES/gnome-terminal.mo
share/locale/en_CA/LC_MESSAGES/gnome-terminal.mo
share/locale/en_GB/LC_MESSAGES/gnome-terminal.mo
@@ -108,6 +115,7 @@ share/locale/id/LC_MESSAGES/gnome-terminal.mo
share/locale/it/LC_MESSAGES/gnome-terminal.mo
share/locale/ja/LC_MESSAGES/gnome-terminal.mo
share/locale/ko/LC_MESSAGES/gnome-terminal.mo
+share/locale/ku/LC_MESSAGES/gnome-terminal.mo
share/locale/lt/LC_MESSAGES/gnome-terminal.mo
share/locale/lv/LC_MESSAGES/gnome-terminal.mo
share/locale/mk/LC_MESSAGES/gnome-terminal.mo
@@ -141,6 +149,12 @@ share/locale/wa/LC_MESSAGES/gnome-terminal.mo
share/locale/xh/LC_MESSAGES/gnome-terminal.mo
share/locale/zh_CN/LC_MESSAGES/gnome-terminal.mo
share/locale/zh_TW/LC_MESSAGES/gnome-terminal.mo
+@dirrmtry share/locale/ku/LC_MESSAGES
+@dirrmtry share/locale/ku
+@dirrmtry share/locale/dz/LC_MESSAGES
+@dirrmtry share/locale/dz
+@dirrmtry share/locale/br/LC_MESSAGES
+@dirrmtry share/locale/br
@dirrm share/gnome/omf/gnome-terminal
@dirrm share/gnome/help/gnome-terminal/zh_TW/figures
@dirrm share/gnome/help/gnome-terminal/zh_TW
@@ -164,6 +178,8 @@ share/locale/zh_TW/LC_MESSAGES/gnome-terminal.mo
@dirrm share/gnome/help/gnome-terminal/es
@dirrm share/gnome/help/gnome-terminal/de/figures
@dirrm share/gnome/help/gnome-terminal/de
+@dirrm share/gnome/help/gnome-terminal/bg/figures
+@dirrm share/gnome/help/gnome-terminal/bg
@dirrm share/gnome/help/gnome-terminal/C/figures
@dirrm share/gnome/help/gnome-terminal/C
@dirrm share/gnome/help/gnome-terminal